New Update not installing

I have tried all the ideas I have (and could find posts for) to update from 1.10.11.0 to 1.11.3. My system picked up all the Airport and Plane updates, but they are all saying “Newer Game Version Required to update”, but my Core Content shows “Up to Date” while my active version shows as 1.10.11.0 Any ideas or tricks? I’m game to try anything…

Thanks in Advance,

Harry

After starting the sim, go to your gamertag and choose LOGOUT.
Shut down the sim, restart the pc, start the sim and you will be asked to login.
@ checking for updates it will finish the download. You should end with 1.11.6.0

Thanks…I’ll give that a try…

I tired that…no luck. Ended up at the same point. I logged out my gamer tag, then exited FS, and restarted computer. When I restarted FS, an XBOX screen popped up and auto-logged me back into my gamer tag, then the program started normally, on the old version.

Did you perhaps missed an XBOX update ? Re-install else.

I uninstalled and reinstalled xbox app, and also logged off my gamertag on my xbox console, in case that was interferring. Still no update.

Is a full reinstall a workable option? How do I force that?

Hi @AtlantaGuy