No ATC Taxi instructions or Blue Taxi Arrows Anymore

`PC, no community folder, Store

I get ATC flight instructions and the landing red/blue brackets to guide in to land but once I touch down, I’m on my own. I get no ATC instructions or the blue arrows. I have to drive around until I find the flagman in a parking lot.
(It’s been on both RNAV and ILS flights)

Are the assistance options for Taxi Arrows on in the menu?

If you mean the “Taxi Ribbon”, it’s on.

Does ATC tell you to contact Ground? (Would only happen at a towered airport)

If this a bug I hope you get it fixed. “Driving around an airport until you see a flag man” sounds incredibly tedious! Especially if you are trying to do a good block to block flight

1 Like

I get this pretty frequently also.

It seems the taxi ribbon can work sometimes and decide to not work on other occasions.

You can see this at the same airport and same plane. One day it works, another day it doesn’t.

It’s on in the settings, the ATC triggers have all happened correctly but randomly the taxi ribbon will not show.

Given that the airport gate numbers do not match those in the real world and the ATC frequently sends you to a generic “general aviation parking” (no number to reference on an external chart anyway) it does sort of suck.

At least PC players can use Little Navmap for gates which have been given a number. Xbox users do not have this fall back and this leaves them lost and wandering around the airport.

It’s actually been this way for a while. Months, maybe even as long as I’ve been playing. (almost a year)
Asobo really need to pull their socks up, this really isn’t good enough for prime time on console.

1 Like

One of the airports was KROC - Rochester, NY, US. It has a tower and accommodates full-size commercial aircraft. (I used it many times as a passenger in a previous life.)

I tested it again with a flight from Buffalo to Rochester.

  • In the MSFS planner, I set up an ILS runway to land. (What I got was a localizer when I got there.)
  • Buffalo handed me off the a series of Cleveland frequencies.
  • Cleveland never handed me to the Rochester tower and dropped me on the final approach.
  • The last I heard from ATC was a 2,100 feet.
  • Rochester ATC vanished.
  • There were no taxi instructions and no blue arrows .
  • It’s a fair-sized airport. I could drive around for quite a while. Maybe I’ll leave the plane out here in on a main taxiway between runways. Then someone from the tower might notice. :grinning_face_with_smiling_eyes:
    From this screenshot you can see the last transmissions.

That’s interesting that Clear of the Runway is still available even after you called it out.

You said you have No Community folder at all? That’s strange because even in a vanilla configuration, there is a Community folder, it’s just empty and has a Content.xml.

Me saying no folder is probably confusing. Sorry. By no I meant that mine is there but empty. I saw so many posts the last year with community folder issues, I decided that when I loaded the game on my new laptop, I would keep it clean. I miss the F-15 I had but…

1 Like

The other aircraft announcing to “Rochester traffic”, and you having the option to “announce clear of runway” indicates the airport is acting as an uncontrolled airport. Sounds like they misconfigured the airport. By the way only runways 4/22/28 actually have an ILS, so if you set up for one of the others it might be right to only have a localizer. I can’t check the sim right now.
Regards

From what I see in that screenshot, the ATC system is acting as if you’re at an uncontrolled airport. If you select a parking/gate location as your final destination in the planner, you should still get the ribbon at an uncontrolled field, but it seems the bigger issue is the lack of ATC at the airport. KROC should definitely have ground and tower controllers:

http://www.airnav.com/airport/kroc

That’s another issue in this mess. I did specify ILS runway 28 and it got called “localizer”.

Something wacky is going on! I tried a very short test flight into Louisville, KY, US this morning.

Again, it was set, with MSFS route planning, as an ILS into the airport. As I approached the runway, ATC told me to descend to 3,000 ft. When close I hit approach mode and the ILS started to grab control, dropping me toward the landing.

When it got to about 1,500 the ATC warned me that I was below my assigned altitude and to climb to 3,000. Then the big CDT gremlin got me. There was never any communication with local Louisville tower ATC and no red/blue landing brackets to show the path.

You weren’t a Navigraph user in the past by any chance were you?

No. I have only let MSFS do my planning for my, almost year of flying.

It almost seems like the Navdata is incomplete or corrupted.

If you go to a known big PG airport like JFK or LAX, does the taxi and ATC work correctly?

Sadly, I am within a couple short hops of finishing my 109,000 NM, every country visited world tour and I can’t finish it easily.

I’ll try that and see what happens. Thanks for the replies.

Interesting; a nice ILS 11:03 flight, as designed, from Newark to JFK. It had a hand-off to JFK tower, the red/blue landing brackets, “get off the runway” ATC announcement, a hand-off to tower ground and the blue ribbon guiding me to my parking spot.

Yep. So I suspect it’s that you’re picking airports that are uncontrolled. That may or may not match Real Life in terms of them being towered or not, but things are working as expected at a controlled field.