No option to request IFR clearance from default ATC

Please tag your post with #pc and/or #xbox.

Are you on Steam or Microsoft Store version?
Microsoft

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
Yes, I retested already

Are you using Developer Mode or made changes in it?
no

Brief description of the issue:
Whenever loading into a flight at any airport with any aircraft, I never get the option to request IFR clearance from the ATC menu anymore. I only see options to request taxi from clearance. I always program my flight from the FMC and never from the world map.

Provide Screenshot(s)/video(s) of the issue encountered:


(as you can see, there’s no option for IFR)

Detail steps to reproduce the issue encountered:
Well, for me just load in to any airport at the gate and start up the aircraft, and once your ready to request IFR clearance head to the ATC menu. If you have the same problem as me, you wont see the option there.

PC specs for those who want to assist (if not entered in your profile)

Build Version # when you first started experiencing this issue:
1.18.15.0

Are you on the Steam or Microsoft Store version?
Microsoft Store

Did you submit this to Zendesk? If so, what is your ticket #?
no

Personal Comments:

There’s likely a flag that accompanies a plan either created in the stock sim FP or via an import from an external EFB like LNM or SimBrief that marks it as IFR. This is a consistent phenomenon. Even hand entering a correctly routed plan in the new G1000 NXi doesn’t trigger an IFR clearance option.

sorry if I’m not understanding your reply correctly, so in order to trigger the IFR clearance option I have to import the FPL?

Correct. Or create an IFR (low or high airways) flight in the sim’s World Map Flight Planner screen. I usually import my plans from Little Nav Map.

I always plan outside of game and input manually and sometimes I can get IFR clearance from ATC. I think it might also have something to do with ~turning your transponder on.

I used to always get ifr clearance when I would manually input the FPL, but that stopped happening. I tried your suggestion and made sure the transponder was on, unfortunately didn’t work.

1 Like

I recently asked a similar question so you might want to look through that thread. There were a few suggestions but I can’t get it to work. Maybe it will help you.

1 Like

The way it works for me is you have a flight loaded in to the GPS, then contact Ground. One of the top menu options should be to contact Clearance, where you can file your IFR flight plan.

You need to have both the departure, and arrival airport loaded into the plan.

Clearance really should be on the top level menu, and not hidden beneath Ground shouldn’t it?

I don’t think there is any upstream communications from the FMS to ATC.

I’ll try this
EDIT: I tried to load in the GPS then contact ground like you said, but when I load in and power up the aircraft, it’s automatically connected to ATC.

You can’t file an IFR plan if your GPS doesn’t have a valid flight plan loaded.

I get my flight plans straight from simbrief and manually put it into the FMC myself. I always have a STAR/SID, waypoints, and airways, so I’d assume that’s enough for the sim to recognize it as an IFR plan. It used to always work for me, and I didn’t change anything about how I plan my flights

1 Like

It used to work before, so I don’t know what changed

There are many different FMSs in different aircraft and they all work differently. Assuming you are flying a stock aircraft with a stock FMS, and FMS to ATC worked before, then this is a problem if it isn’t working now. If you are using a non-stock aircraft and/or a non-stock FMS, then check with the 3rd party vendor to see if there is an update.

Try not to assume anything about how MSFS works. Technically SIDs, STARs, approaches, and waypoints can all exist in both VFR and IFR flight plans. Just because Navigraph or SimBrief only create IFR flight plans doesn’t mean they can’t be modified into a VFR flight plan.

Also, I haven’t used a FMS that has a switch to indicate VFR or IFR flight plan. ATC won’t give an IFR clearance to a VFR flight plan but I haven’t used all FMSs.

That said, I think there should be two-way communication between all FMSs and ATC, some way to communicate changes in flight plans. The best example is changing the flight plan enroute due to bad weather.

Here’s the authoritative answer for G1000 NXi from Working Title:

2 Likes

Thanks. Now I can stop trying to find a method.

The glitch happens with all my aircraft, stock and non-stock, unfortunately.

I 100% agree, we should definitely be able to switch from VFR to IFR, it would save us so much trouble. I hope the next update addresses this issue

@PacificSet90456

does that apply to all aircraft systems or just the working title G1000 mod?

I think most stock systems will work this way. The exceptions are probably third party planes that implemented their own internal FP systems just like the NXi; the FBW A320 comes to mind, the CRJ another.

So I was having the same issues and I did a couple things that fixed it and I suggest you start with the easiest:

  • Updated all of my Working Title packages from Github
  • Updated FSUIPC
  • I uninstalled and reinstalled MSFS completely.

Uninstalling and reinstalling took almost 24hrs to complete, but freed up almost 200GB of space on my HD (which was great).

Also I highly suggest you copy the MSFS settings files (C:\Users\user\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\Settings). Then after the reinstall you can copy them back and keep all of your settings. Good luck!

1 Like