None of the aircraft screens are working after latest patch

Same here with the 787 and nothing in the Community folder. When you restart then its Ok but this is not the solution, the solution must come from Asobo

1 Like

Have you updated everything in the content manager? They don’t get updated automatically, so you need to check them regularly and download the updates manually.

Yes I did update everything in the content manager, but as I said it doesn’t happen all the time. I would say 25% of the time and then I restart the route and its gone. It is an issue that Asobo must look into it.

1 Like

Very true. Just couldn’t see any way around it at the time. Was trying that or wait for a patch and hope for a fix :slight_smile:

I have the same problem with the flybywire A320. Even after a restart, I get the same issue only with the A320. The 787 locks up my simulator and I have to END TASK in task manager. Really sucks, but I guess it will eventually get worked out.

Just found out at testing some settings for my zendesk-ticket, that running the flightsim as administrator seems to fix that issue - can somebody check this and tell me if it also does the trick on other installations?
would be a hint, that the issue is located within user settings/profiles…

I also have this problem for every aircraft… I hadn’t played the game in months and as soon as it downloaded the massive 50gb update it has caused this issue i am heistent to reinstall due to how long this will take i have already tried renaming the folder for the virtualcockpit with no joy… any other suggestions? run as admin also doesn’t work.

May this problem only affect the microsoft-store-version of the sim?

Please try the following:

  1. Rename the folder “asobo-vcockpits-instruments” in Official/OneStore directory
  2. Run MSFS as Admin - reload the content - start a flight, screens should work.
  3. If so, take a flight or exit and start the sim again without admin-rights to see, if the screens are still working.

I had this problem on every second session, until the game repaired something when running with admin rights, but until now I couldn’t get the reason, what causes it…
Currently it lookls like something within the “Windows-App” is fuzzy (MS-Store-version) - so this should not happen with the steam version I think.

same problem here screens go dark after like 3 minutes.

delete and redownload Asobo-vcockpits-instruments doesnt work. this is in SIM update 9 after i updated the Deluxe Packet. this came with new bugs.

My screens are coming on but I just have lots of Xs in them??

Do you have any mods installed?

This procedure solves 99% of problems.

“My sim worked perfectly before but now is broken!”

  1. Do you have any mods?

    a. Yes

  2. Remove all mods. All Mods… ALL MODS

  3. Do you still have the problem?

    a. Wow, no I don’t!

  4. Sim is not broken. A mod is broken.

  5. Figure out which mod is broken.

  6. Delete or update mod.

  7. Problem solved.

The fact that this is still continuing to happen today is jsut embarrassing, truly I am dissapointed that they refuse to even acknowldge this problem.