Not able to run FS after latest update

After the latest update, I’m no longer able to start FS, it crashes during loading of the program. Sometimes I’m able to reach the “welcome menu” but never longer.

I have tried all the suggestion provide by the support team except turning off the CPU overclocking because I’m unable to do it, my PC provider tells me that
“there is no way to turn off the CPU overclocking on your Matebook X Pro.”

Any idea on how do I go further?


do you have any mod’s and or liveries in your community folder ? if so rename your community folder and restart game , new community folder will be created , then you can move em over 1 by 1 till it starts crashing again…

i think there is a way to stop overclock, google i dont like it when the factory does that
its a cheap way to improve performance, some games have issues with it.
waych out for overheating with that thing.
laptops are not he best for gaming.

My Community folder is empty, I tried to rename it and FS created another one. Still CTD.

Increase the size of your pagefile.

I did increase it to 3072-8192, still crashing during loading.

I was unable to find (via gogle) how to stop overclock.

Back in Aug 2020 I found some info in the forum:
When I disable the NVIDIA graphics card display adapter in the Windows Device Manager menu I’m able load the game without CTD, the issue now is FS is unplayable (too slow).
The solution to this seems to be to stop overclock which I’m not able to.
Any other way to fix this?