Nvidia 40 series Frame Generation causes Warning: Your graphics device has encountered a problem

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

no

Have you disabled/removed all your mods and addons?

Tried with and without mods

Brief description of the issue:

Getting the “graphics card has encountered a problem” error when using my 4070ti with Frame Generation turned on. It works fine if I turn it off (which I obviously don’t want to do). I have also managed to pinpoint what is causing it and have provided a video which also has a couple of temporary solutions (hopefully). The problem seems to be with the games windowing system in that whenever I resize the window it causes the crash. This is 100% reproducible (see vid)

Provide Screenshot(s)/video(s) of the issue encountered:

MSFS 2020 "Your Graphics card has encountered a problem" (Possible solutions) - YouTube

Detailed steps to reproduce the issue encountered:

The video shows me loading the sim 4 times. Notice that before I click on the “Continue in Normal Mode” button (the same happens if I click on the “Safe Mode” button) I can resize the window no problem. After I click on the button, any window resize causes the crash. As I said, this only happens for me with Frame Insertion turned on.

I may have found a couple of solutions but I need to do more testing.

  1. Use full screen mode. It may still crash when you first change to full screen but seems to work on any subsequent loading of the sim.

  2. When using Window mode make sure the window is in Maximised mode (the button next to the close button at the top right of the window). When it is in Maximised mode the mouse should NOT change to the “drag” curser when you move it to the edge of the screen. Once in this mode you can still Minimise/Maximise but never try to drag the window as it will cause the crash. You will still have access to your taskbar and be able to pull up other windows like Navigraph etc.

PC specs and/or peripheral set up if relevant:

i7 9700
4070ti
32gigs Ram

Build Version # when you first started experiencing this issue:

1.30.12


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

I have made this a separate thread as it seems to be specific scenario of the 40 series (Frame Generation) although I know people with other cards also get the same message

If relevant, provide additional screenshots/video:

Hi @mk1234444, I’ve updated your topic title to differentiate the issue you’ve found from the other threads talking about that error :+1:

2 Likes

Yup … new hardware, new dlss behaviour = new problems for Asobo/MS/Nvidia to fix

does it happens in the MSFS Beta version only ?

Not gone back to the release version. Don’t want to screw up my install. Been on the beta for months.

yep… its only for information for others. I seen other reports where Frame Gen not crashed / caused that, also on my system ( not in the beta ) it not crashed as I tried it for a while, so may be its a beta-problem only :slight_smile: