Oculus CV1 with 6900 XT + USB problem

Hi all,
if been trying out VR with my Oculus CV1 in MSFS lately. I’m running MSFS on a 10700K@5GHz, 32 Gb RAM and a 6900 XT. Performance in GA aircraft is ok, however in airliners it is quity choppy. I get around 30 fps but it doesn’t feel very smooth. I already tried the suggested settings (30fps locked, 80% render res in MSFS + 1.5 SS via OTT or OculusDebugTool). I’m hoping to improve my performance and have two specific questions in that regard:

  1. I have the well documented problem with my Rift that the Oculus software keeps saying the headset is attached to USB2 even though it is on a USB3 port. During install it recognises the port as USB3 but when starting the Oculus app later, it always keeps saying that it is only connected to USB2. I tried all fixes discussed on various topics on the net, but I cannot fix it. Even a fresh reinstall of Win 10 didn’t help. But is this really a problem for performance? It’s only tracking data that is going through the USB connection, isn’t it? And tracking is ok.
  2. When I start development mode and look at the fps overlay then I’m always limited by the mainthread. The GPU is not running at 100% at all. How can this be? I can run the sim in 2D@4K with around 40-45 fps on ultra in airliners and my CPU is totally relaxed. I’m always GPU limited (as it should be). But why on earth does VR hit the CPU so hard that I end up being CPU limited with only around 30 fps?

Thanks for your help!

Even if USB 2.0 is displayed, the Oculus is still controlled via USB 3.0. I have the same problem

1 Like

Yup, it looks like Oculus have never got their drivers right, as I have been getting this behaviour for over 4 years now, with the headset reporting USB2 or USB3 apparently depending upon as yet unfound random factors.

I’ve now given up trying to find a cure and just accepted that as “USB2” appears to work as well as “USB3” it’s not worth worrying about. :slight_smile:


I agree with the USB problem, have the same with my CV1, and according my tests and benchmark you can safely ignore it. Saying that sometimes it make me angry and I restart several time the Oculus Software (Beta tab->Restart) until it show USB 3.

For performance, I run with also an I7 10700K (Oc 4,9Ghz for now) and RT3070, and I keep 45fps Locked ASW OFF (CTRL+Numpad 2). I use RenderScale in game at 70%, TAA, and Supersampling (PixelDensity) for Oculus Debug Tool at 1,7. Fine depending which plane and which airport, but you already discovered this :wink:

The “Limited by Mainframe” is about the CPU, not the GPU, and this is something MSFS devs need and know they have to optimize. They currently use more or less 4 cores on our processor, with an excessive load in only one core, the last one for me #8 reaching 100%. It’s worse from the last update for several of us and Devs are aware and work on it.

Edit : I forgot : I read people have problem with AMD GPU and Oculus ASW performance. You card is more powerful than mine but I suggest anyway to keep ASW OFF as the experience is less “wobbly” (ASW 1.0 only, not 2.0 AFAIK).

1 Like

I confirm, I was on Oculus CV1 with an RX 6800 XT + Ryzen 5 3600 + 32 GB of Ram until the beginning of the week. With ASW on Auto, or forced; I had a beiguing when I looked down at the ground. I had noticed that by turning off ASW the fluttering was reduced.
It should also be said that Facebook does not care a bit about our CV1, the updates only concern headsets like the Quest 2. This is also why we have USB 3 recognized in USB 2. Basically we must be happy that our good old CV1 continue to operate.

As of the start of this week I have the HP Reverb G2, although it is a much higher resolution than the CV1 with mostly all Ultra settings, I no longer have a flicker when I look at the ground above. of a city like London.

1 Like

Thanks to all of you for the helpful feedback!

@Gsx31: Is the upgrade to the Reverb G2 worth it? I’m also on the fence if I should buy a G2 without controllers just for MSFS.

Basically, I wanted to take it without the controllers. But finally I took the version with the controllers. At first I didn’t take them out of the box, but I had to. When you configure the WMR (Windows Mixed Reality) you have to move with the stick from one area to another. He recognized the XBOX One controller, but I couldn’t move, the right stick was inactive. So I could not complete the configuration. With the controllers, I was able to complete the configuration without any problem. Afterwards, I discovered WMR.

As for the picture quality compared to the CV1, it is night and day. With the CV1 you are astonished to put all the graphics in Ultra to have something suitable. With the G2 even with the basic settings, the images are beautiful.

The BIG negative: [There are crash issues with AMD GPUs] (MSFS 2020 Crash in VR - HP Reverb G2 - #21 by Gsx31)

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.