Oculus Rift S Clarity

Is it me and my system or is the oculus rift not very clear in the distance?
I7 intel chip
Nvidia GTX 1660 TI card

Ideas on settings (though, I have tried them all…)?
I have checked out most of the ideas on this site.


My image is pretty clear in the distance with
100 TAA
6x6 texture sampling
8x8 antistrophic filtering

No external Oculus supersampling tools whatsoever…

I’m on Rift S

1 Like

Thanks, I will try that. Not sure what else I can do. Seems I’ve tried all suggestions, but reults are not giving me a clear picture.


hello do you want to see clearly? in game rendering at 60 and supersempling in oculus debung tool at 1.8/2.0 and everything else off and disabled.
for me it works great, adjust the settings to find a good compromise with fps.
this is my experience

Info PC
i9 9900kf
3070 zotac
Rift s
Divers Nvidia 466.27

When you say “Everything else off…” are you referring to the settings in the Options-General screen?

you’re right I explained myself wrong … all disabled in the oculus debug tool except supersempling try 1.8 or 2.0 … the settings in the game set the rendering to 60 then you will have to try which ones are better for you … I share 2 screenshots

try rendering scale at 50 to get more fps … it doesn’t change much in clarity

Thanks, I will give those a try. Your help has been truly appreciated.

I find the Rift S clarity is pretty poor. It is not as sharp and detailed as i had hoped for no matter what settings i try. Perhaps its a limitation of the VR hardware.

hi, i don’t know your level of clarity you want, for me it is very good so … have you tried the setting above? i recommend using debug oculs tool to set supersempling to 2.0 in game rendering to 50

1 Like

I think it’s very clear, I think you’ve probably not got it configured correctly.

I use 100% in game and 1.4 supersampling. You need to apply the supersampling before you launch into vr.

That’s my settings too, it’s the best combo I can find for clarity

Fino a qualche giorno fa, il mio Rift S funzionava a meraviglia, volo fluido e immagini scorrevoli. Adesso, quando indosso il casco, se giro lo sguardo sfarfalla tutto intorno e il volo è a scatti. Ho provato a cambiare le impostazioni, ma non ho ottenuto nessun miglioramento.
Il fatto strano è che il mio Rift S gira perfettamente nelle sfide di atterraggio e nelle escursioni naturalistiche (volo fluido e immagini scorrevoli) dove le impostazioni sono sempre quelle scelte da me.
Quando pianifico un volo, invece, nascono i problemi…

Until a few days ago, my Rift S worked beautifully, smooth flight and smooth images. Now, when I wear the helmet, if I turn my gaze it flickers all around and the flight is jerky. I tried to change the settings, but I didn’t get any improvements.
The strange fact is that my Rift S runs perfectly on landing challenges and nature excursions where the settings are always the ones chosen by me.
When I plan a flight, however, problems arise again…

Mine also flashes more now, but as I’ve learnt with flashes, there’s no fix until a driver update so just have to wait for an update from oculus

Thank you for the answer.
I hope so.

To get rid of the flickering turn off game mode and HAGS in Win10 settings.
My vr settings: 70% render in game and 1.4 SS with OTT.

1 Like

Supersampling is merely changing the resolution, as is game rendering in MSFS. Lowering in one and raising in the other is basically taking money out of one wallet and putting it in another thinking you are somehow going to create more money.

When I use OTT, I have problems…

I’m trying it

Don’t change anything in OTT, do it in ODT if you want to change SS