Oculus Rift (v1) to Quest 2?

Anyone have experience going from the Rift to the Quest 2?

Thinking of picking one up today. The Rift is actually working well but I have a combination of wanting more resolution and the need to have a bit more distance for my 50 year old eyes. I’m thinking the spacer will help.

I did it, so glad I did. No screen door and can use it wirelessly to watch 3D movies among other things.

Do it!

I updated, I’m glad I did.

I went from a CV1 to the quest 2, it’s true, the image quality was better, but I spent far too much time fiddling with settings. Also the poor IPD adjustment solution was a pain in the rear. In the end I forked out for a G2 and it’s much much better for seated VR.


I picked one up! Unfortunately, my PC does not have USB-C ports. I put an order on a PCIe card with 20Gbps USB C 3.2 and enough power to run the headset.

I did get some flying in on WiFi. Despite having a good 802.11 AX router and my PC hardwired to the AP, I couldn’t keep it connected. The process of connecting is also way more involved than with the Rift.

I’ll see how the PCIe card goes. It arrives tomorrow. Until then the Rift is going back on.

My initial thoughts:

  • Resolution is way better! I was able to read text better and see instruments better. But I could use perhaps a little bit more of a spacer over what was included.
  • Quest 2 headset seems less adjustable than the Rift is
  • The “framerate” seemed smoother (I was expecting the same or less, especially because of WiFi).
  • Headset tracking on the Rift just seemed so much smoother. On the Quest 2 I was jittering around in the cockpit. Once in the air it seemed okay as it just feels like turbulence, lol. But on the ground doing a checklist, it was unnerving.

Otherwise, the Quest 2 is a neat device, I like how you can map a desk, couch, walk out of bounds and get environment view. It might be worth keeping if I go for the G2 (I haven’t looked at the price yet).

I’m not totally sold on replacing the Rift. Will have to see how the USB-C connection goes.

1 Like

You should have no problems with the Link Cable. With the Cable, the process should be almost identical to the RiftS. I used to keep my RiftS plugged into the PC, even when I wasn’t using it so, for my RiftS, I’d just grab it put it on my head and the Oculus application would start. When I switched to the Quest 2, it’s basically the same but I keep it turned off. I put it on my head, turn it on, and soon the Quest software will ask if I want to Link with the Oculus software. I say I do, then it cranks up the Oculus software and it’s like being in the RiftS again, only clearer. To end, there is a little area of the Oculus dashboard (sorry, I don’t remember its real name. It’s the bar in front of you when you’re in the Oculus software) anyway, you press a button on the farthest left part of the bar and you exit back into the Quest interface. At that point it will ask if I want to Link to Oculus again but I answer that with a “No” and power down the headset. That should be all you have to do.

1 Like

I’m about to run over with the Quest 2 with my truck, lol.

MSFS and Quest seem to have a very hard time hooking up. I did a nice session, but I wanted to redraw the room boundaries.

Disconnected, setup the room again and now the Quest says “You can’t use this app at your desktop. Move to another area.” when I try to use the air connect.

MSFS thinks it’s in VR, but the Quest keeps either showing that message or the Oculus home.

Go into your Guardian settings in the BETA branch of the software and you can get it to ignore the Guardian altogether, or change it etc.

Do you use your Quest for more than seated applications? I ask because I have never set up room boundaries for the Quest. I just choose the option that says I’m going to remain seated.

I eventually got it to connect again. I did use it in both modes. I had just tried to expand the zone since I wanted to try an experiment of walking around outside the airplane.

I was really confused because it was basically not letting me airconnect while seated.

I had drawn my desk, which was neat to have.

I think I walked somewhere else to establish the connection and got it going again. It was late and I was very tired. Hopefully goes better today.

I hope have better luck than I did with a PCI-E card. I bought 2 different types, one was also a Gen 3.2 20Gb model. Neither worked with the Quest 2. In the end I just bought a simple USB A to C cable and plugged it into a powered hub. That did work.

Just tried the new card and had a terrible time. Any time I moved my head there was terrible stuttering.

Here is the card, https://www.amazon.com/gp/product/B08T6FCF9S/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1

It doesn’t have a power header. I may give another once a try.

I also have an Insignia Oculus cable. I usually avoid Insignia stuff but it was the only one.

I’ll have to compare to WiFi again but I don’t remember that was an issue. I do think clarity was improved.

Now the Rift Home refuses to launch unless I use WiFi. But I do have an active data link. I can copy file and stuff at least.

I think having the virtual desk enabled is your problem. I seem to remember having a similar issue and it went away when I turned of the desk.

Wow, that was 7 days ago, lol! Yeah, I’ve disabled most of that stuff. It’s like trying to run two games at the same time.

MSFS with Quest 2 through Virtual Desktop has been very stable. I’ve had fewer CTDs now flying in VR than I did when I first started out.

1 Like

Glad you worked it out and sorry I was way late!

It is terrible when the system is trying to render two Virtual environments at the same time.

I made some additional nvidia control panel settings too that may be helping. There is one, I forget which, that allows the rendering priority to drop when in the background.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.