Oculus Update Warning

I started having issues with flashing lately, too. Then I found this-- How to Configure MSFS for VR - Channel LFD

I followed most of the advice (except for adjusting the page file) about windows and openxr and the Oculus stuff and the nvidia control panel settings and haven’t had an issue with flashing since. I’m not sure which particular setting cured the flashes…I was too anxious to get back up in the air to do a proper test. Sorry.

Be advised…one of the settings in the article will reset your registry key that points to your .json file. Oculus link won’t work until you modify that registry key.

I also had the flashing oculus issue. it worked find this morning and it looks like a sneaky update broke it, lots of flashing and audio glitches. Deselecting oculus beta, running the installer and selecting repair fixed it. Thanks to those that took the time to post a fix :slight_smile:

Ok,. So I just reinstalled the public test channel beta again… yes I’m getting more flashes but settles down after a few minutes but…

I don’t know how exactly but I’m getting a solid stable 45fps and I’m on a 3070 (cpu 10700k nothing overclocked.) which has been an absolute struggle for frames compared to lower end GPUs like the 2080s.

Couple of key things:
Oculus debug tool
Fov: .8/.75
Adaptive GPU off
Asw disabled
Distortion low however you should try High as it might suprise you
Encode res 2448
Bitrate 350.

Oculus settings:
90hz at 2448 (1.5)

Msfs settings:

Render 80
Tod 100
High
Med
Med
Low
Old 100
High
High
4x4
Off
Med
Low
768
256
Med
High
Off
Med
Med
On
Low

NVIDIA:
All the usual suspects
Vsync fast
VR pre rendered frames 2 but you should try 3 or 4.

The more and more I play with this the more I think it’s msfs to some respect.

Test this for me please:

Be in current v26 beta
You will get flashing however
Fly in outside view and look to your left or right towards the horizon

You will notice:
Plane pops down and up like crazy but…
The rest of the image that is not the plane operates beautifully and smooth

For reference on my specs above I got about 30fps at London City

Switch it off and all works fine without jerking and flashing.

I guess this issue is related with bitrate setting. I applied settings suggested by TonyTazer1504 and partial flickering or flashing became far reduced.

I can confirm. Lots of white flashes in my rift s. It looks like it was trying to switch between internal cockpit view, and external view. It happend straight after the update. I deleted the oculus update, went out of the oculus beta and everything worked fine after that!

I don’t know how anyone can really be bothered with VR in the sim at the moment. I know that once you experience VR the level of immersion makes it difficult to going back and playing a on a flat screen but at least on a flat screen you can just get on with enjoying the sim. The ratio of faffing around with set up guides, instability issues and general nonsense with VR to actually enjoying it just isn’t anywhere near being there, certainly with the Quest 2, which seems especially problematic.

VR is so tantalisingly great but there’s clearly big issues with the software, both in the sim and with the Quest 2. The problem with these set up guides is that you’re always convinced one of them is going to provide the magic answer. I had my Quest 2 as close to being perfect as I’ve had it a few weeks back. Then I decided to tweak a few settings following a new ‘cure all problems’ guide that was put up here recently and I totally lost my VR experience. Its a total mess again and I really can’t be bothered spending hours and hours trying to get things working again. I just want to enjoy the sim again. I had more fun with it before VR came out and I got my Quest 2.

It seems like VR has to be so finely tuned to each users very specific hardware combination. On top of that the VR experience is so subjective. One persons really smooth and really clear may be another persons blurry and juddery mess.

1 Like

I have also those white flash or more probably violent shifting of head position with my Oculus Rift CV1 so nothing to do with bitrate of your Q2. It’s just it change the speed of the game so flash happen less or more often depending what you tried. if I hit CTRL+2 (45fps locked ASW OFF) I have it less often than CTRL+1 (no ASW). Just fps which have incidence on flash frequency.

Totally feel your pain, I’m a sound engineer and constantly tweaking settings is the norm for me so I think maybe I have a tolerance for it :joy:

I have desktop sticky note with my last known stable settings, so when I get lost in a tweaking frenzy I can just follow my sticky :wink:

But I get it, it’s all SO subjective! I hope you can rekindle your love for VR soon and stability and performance improves for all of us :+1:

It is a hardware issue. The early production batches have this problem. I exchanged mine which was bought in November (manufacture date June if I remember correctly) for a new one 8 months later and no longer have this problem.

SteamVR is an additional layer on top of oculus software. Is there performance drop switching from Oculus VR to Steam VR?

Now that’s almost exactly what is happening to me, and it got worse after the UK update, however Oculus did an update about the same time, so I don’t know which one is really making the problem worse.

Deselecting oculus beta worked for. No more flashes.

weve been playing daily including after the uk patch, and the odd flicker which has always been there in the game with the quest 2 continued. Im sure it is the oculus patch and not the uk patch which caused it. Absolutely certain.

We had been flying fine, we came out of it, the oculus update happened to land so i installed it and went straight back flying and it was flickering every few seconds or even more often that that. Unplayable.

FWIW, flight was from chichen itza to cancun.
Then flew cancun to guatamala and the problem was sporadic, worse than pre update but still playable and since then, most flights are close to being fine - although flickering does seem to appear around pattern entry sometimes, though not for long.

i havent changed any settings at all. Hopeffully oculus will just roll back to pre update as a quick fix before they sort what appears to be a very common problem.

quest 2
i7 9700
RTX 3090

Out of interest, how do you deselect oculus beta and still fly?

Beta flag was needed between Oculus release V24 and release V25. problem like black pencil are now fixed in v25, so removing beta flag will let you use v25 instead of beta version v26, and all should be fine (didn’t test yet, didn’t want…the plane Flaps problem killed the Sim for me, for sure).

1 Like

You were lucky. I got tired of communicating with Oculus. So much back-and-forth on the issue. Finally they suggested it was my OS and wanted me to reinstall. My instinct told me that was twaddle, and there was no way I was reinstalling my whole system just to find out. So they won, and I’ve popped cables and burned batteries ever since.

Anyway, cheers for the info. I’ve just emailed Oculus asking to replace.

Sound to me more on Oculus side as it don’t appear for me right after UK update, but right after the Oculus Beta update. Saying that, it could be something inaccurately coded on MSFS side showing this issue obviously, who knows…

Good luck with that. If exchange is unattainable and you really want to get rid of the problem, buy a USB PCIe card (Amazon.com) and plug your rift S usb into it. This setup worked for me until I built a new PC where the PCIe slot is next to GPU and affects ventilation of GPU. So I was forced to ask for an exchange.

1 Like