Official Discussion: Hotfix 1.18.15.0

Thanks at least I am now able to enjoy this sim again. Not quite as good as SU4 visuals for me yet but more than acceptable now.
Hopefully to be improved with the next few updates. :crossed_fingers:
Just flying round the Naples area with live weather and it’s pretty decent apart from some AA and water reflection issues :+1: :slight_smile:

1 Like

Patch is working great here, really just wanted to say thanks to the team for getting this out. In an ever updated sim there will be some bumps in the road, and SU5 was a big bump, but I appreciate how quick Asobo has been to acknowledge and address issues.

1 Like

Hey, excellent observation ! :slight_smile:
Most people do not catch such stuff.
Anyway, it’s also a type of culling, called the occlusion culling. In this case, the airplane is the occluder. The algorithm can be really finely tweaked, so they set how much percent of an object has to be occluded in order for the culling to ensue, the LODs that the culling process will use, etc.

There is even larger issue than textures in regards to the sim and the parts that required optimization - that is geometry.
Much of the necessary geometry has been delt with. If you remember there were certain buildings that you would approach with the drone cam and the VRAM usage would shoot up from 10GB to 15GB.

This is actually the thing that DirectX 12 is known to be dealing with. Drawing of millions of details in real time, the parallelization of the geometry processing, and of course there are visuals thanks to the DXR part of it. DirectX 12 has powerful denoisers from both nVidia’s and AMD’s graphics SDK and so even the screen-space reflections, shadows and occlusion look flawless. Of course the DXR or RTX based denoisers with the raytraced scenery is the ultimate real deal and I cannot wait to see the simulator in all its glory…lots of people have been dreaming of that and waiting for it for so long, like, for more than a decade.

2 Likes

Yes they acknowledged it’s still an issue and will fix by WU6 if not before

The patch is mostly working ok for me BUT, lightening…

If there is a storm either live weather or manually set, it makes my VR act very strangely. Its as if the frames drop to 1ffps - but infact its some sort of image stability issue and image brake up. Its difficult to explain, but the only way to get VR working again is to shutdown MSFS and reload.

(Turning graphics settings down, no reflections etc makes no difference)

Anybody else?

These were taken AFTER the second hotfix?? I thought those bright clouds had been toned down a little.

@KevyKevTPA
Not really sure where to start. First of all, I never said anything bad about Asobo/MS or the devs, never asked for a refund, threatened a class action suit, etc. I think the worst thing I said was “GRRR”, to vent my frustration at the situation. I don’t appreciate the patronizing tone of some of your posts from up there on your special high horse.

Am I frustrated that I’m having BRAND NEW problems with the sim? heck yeah I am. I have been running the sim for the last ~6 months, in exactly the same configuration (mild OC and a few helper add ons in my community folder) with absolutely no issues related to CTD or BSOD. Is that what the guide says I should do? Admittedly, no. But it worked great until now. I like to push the envelope. I even go so far as to rip off the fire warning labels from my couch cushions, under penalty of law! And have been known to occasionally cross the street outside of the crosswalk lines.

Fast forward to SU5…
I followed the guidance to clear out community folder, back to pure vanilla, even reinstalled the sim because it couldn’t find the files that were still right there in the default install location. AND, I turned off my mild OC.

First load of the sim, I deleted the rolling cache, updated whatever needed updating in the content manager and shut down the sim. Rebooted even.
Next load of the sim, I tried to select a departure and arrival airport in the world map… CTD. With a vanilla setup, no OC.
Third… CTD
Fourth… might have let me fly a bit before BSOD

Messed around with a bunch of nvidia control panel settings and I think what helped was to set a cap on background process frame rate and a general frame rate limit globally. Those made it more stable but I still have occasional CTD and the weird freeze with sound that started my involvement in this thread. Why should the loading and GUI menu run my GPU at 99% when the sim is only using 80-90% while flying? Something isn’t right.

My point is that even at pure vanilla settings, there are new issues with the sim. Many others have found the same to be true.

My system is pretty high end (bordering on what some might call bleeding edge) and I have a bunch of custom & OTS hardware peripherals so I may be a bit “special” (to use your term again). By special, I’m not saying that in an elitist way, rather…I’m suggesting that I’m likely in a small minority corner case of folks who built a new rig and have spent >100 hours crafting/soldering/programming LUA scripts/etc. to build a cockpit that lets me fly without touching the mouse or keyboard. It was my avocation during COVID. Yeah, I’m fortunate to have the time, ability and resources to do this. I realize not everyone can or would even want to do what I’ve done. I chose that path and it was a very rewarding experience. And I fully understand that being in this minority puts me at extra risk of issues. Moving on…

I do NEED a few things in my community folder to interface with all of my hardware:

  • Air Manager
  • Honeycomb Bravo LED driver
  • MobiFlight WASM module

Once I got the sim to be more stable with no OC, I added these back in to the folder. And it seems like they aren’t causing the issues. Still random crashes with similar frequency. However, yesterday, I was able to fly for quite a while without crashes so I tried to then add my mild OC back into the mix, along with the CJ4 mod. Flew about 4 hours total without issues. Everything in my setup back to how it was before SU5.

My hunch is that it may have something to do with data streaming. Could there have been something amiss in the data being sent that has now been changed? The sim on my PC didn’t change but the behavior did.

Back to the topic at hand, something fundamentally changed with SU5 that is/was causing the crashes. I’m sure the devs will straighten it out in due time, along with fixing the list of new, known and unknown bugs, and hopefully restore the ability to utilize higher end graphics cards at their full potential.

I agree with what many reasonable folks have said that there’s way too much hyperbole on this forum, from both extremes: rage quitters to apologists. I would hope that we can all try to be more constructive.

In the meantime, might I suggest you could take some of your own advice and have a look in the mirror yourself before posting condescending words to others. I’m not interested in a feud or p1$$1ng contest with you. It’s just that your posts struck a nerve and I wanted to get it off of my chest.

From an inflight situation pressing esc to go back to main menu still results in an CTD. Why oh why… never ever had this problem before SU5.

Yes after the hotfix 2, I have mixed feelings about the quality, yes the clouds are too clear, and the textures not bad, but here I think it’s probably a problem with the servers.

I hope that in the next update we will find the beautiful graphics of the SU4

The Good: With SU5 I’m also able to run the sim at higher graphic settings and higher FPS.
The Bad: Since SU5 I cannot access General Options from the Main Menu.

I can only access the General Options menu once a flight is started. That’s not good enough for editing data settings. It is impossible to access the Manual Cache, which is greyed out because I’m already flying. Before SU5 Manual Cache could be reached only via Main Menu and General Options before starting a flight.
Now, the General Options menu shows only an aircraft in the hangar (same picture as in Profile menu), when choosing it from the Main Menu, but no editing possibilities.
Any ideas or fixes?

EDIT - Solution: I uninstalled and reinstalled the sim, and General Options (and Profile menu) work correctly when accessing from Main menu. All OK now.

If it were an off-host issue wouldn’t it affect everyone equally? For the record I have had no crashes with SU5 so far. I believe the issues are local, to each users machine, and outside of issues with mods or unstable OCs is most likely some combination of hardware, and software that causes this.

Another example would be the download looping issue. Many people get this, but I never have.

One thing I would add is that whenever a new patch is deployed, I make sure I fly without addons for the first few flights till I establish some sense of stability. I then introduce mods slowly. Right now the only things I have loaded are Navigraph data, the BBS BN2 Islander, and the JF Turbo Arrow.

I’ll probably fly like this for a week or so, and if I still have no crashes I’ll add the more exotic ones like the PMS50 GPS mods.

By the way… did SU-5 really solve the flying under bridges issue ? ( :partying_face: )

I’m sure a few months ago I could not fly under this one… Höja Kusten Bridge POI Sweden…

Depends on the bridge. I still crash if I try to fly through London’s Tower Bridge.

That’s true, and a good point. And very constructive as well, I might add. :wink:

1 Like

Quick update from my end on the update. Visuals are stunning when the sim is working (I’ve now used it twice in a row without a CTD and that’s the first streak since SU5, so we’re headed in the right direction. I’m set on Ultra (3900X, 32GB, 2060 Super & FPS locked at 30 in NVidia).

The bugginess/stabiltliy is the main issue. As with so many others, prior to SU5 I had less than five CTDs since day ONE. Since SU5, I’ve doubled that (mostly in the World Map although I think I’ve isolated that issue and now seem to avoid those). Without my payware airports added I was seeing the same frequency of CTDs as with some, and I hate the default airports and am tired of trying to figure out which scenery is safe and which isn’t so I’m testing one after other.

ATC bug is pretty annoying. It’ll start out fine and then at some point it isn’t working (sometimes at all). Last flight it did (kinda). Started out first hour OK, then it mysteriously went to offline mode (you can always tell because my female copilot sounds like she’s 12 and ATC sounds a lot slower). At some point, it came back into Azure, and then totally quit before final approach. I’m OK with it switching - I mean that’s what redundancy is about (if Azure is down I expect the slower guys and the preteen girl to automatically fill in - and they did…the first time).

Sometimes the altitude works and other times it doesn’t. Better than before, so there’s that. OAT seems more accurate and that’s a big fix for me.

Guess we’re on hold for further fixes until late August now…bummer, but at least it can be fixed.

Thank you. I also practically rebuilt my system yesterday, from a Z390 9900K, to an 11900K Z590, via an NVMe disk swap, taking both disks over to the new board, rather than reinstall. A few driver issues to sort, and re-license Windows but other than that smooth sailing.

The ones I feel sorry for are those who state they have done entire reinstalls of Windows along with MSFS, and still get crashes. The only way I can look at that is if they are reinstalling the same software each time i.e. driver versions or some other piece of software, MSFS doesn’t like that software or the hardware combination.

If I had the money, and space, and no COVID, it would be an interesting thing to lab that. Take someones system that crashes all the time, and pick it to pieces. Take an image of the disks, or clone them, and transplant them into different systems then re-test. Include a wide array of different boards, CPUs, and GPU’s.

Have you tried buying another PC………lol

1 Like

@Toddimus831 I have no high horse, and I was talking about far more people than just you. You were the one who outright said you were having problems and still refused to turn your overclocks off. You are not alone, there are a lot of people in that same place, and that’s where my frustration lies. There is simply no reason to be on here complaining in any way unless you’ve done what Microsoft and Asobo have already said to do. They’ve already given people in your boat steps 1-40 to go through BEFORE asking for formal help. Now, 40 being just a guesstimate of course, I have not gone through and counted, but there are 26 software apps specifically called out, a few of which I run myself, and likely so do you.

I simply don’t think it’s the right thing to do to complain or to seek help before completing the list they have already given us. And that applies to every single person who is having similar issues, you just happened to be the lucky one who outright said the equivalent of “I’m not following instructions but I’m still frustrated by these problems I’m having…” And no, you made no comments about refunds or lawsuits, but plenty who came before you have done precisely that, and it seems like nobody has even a lick of patience.

I could start getting CTDs myself with the next update, who knows. But I know you won’t find me here complaining about it until I’ve followed every single step on that list to see if anything helped first. And I can relate with “it worked until now” because I had heavy overclocks on mine that appeared to be working fine… until they weren’t. But now I know, for a tested fact, at least pre-SU5 that if I turned on my GPU overclock, it was not a question of if I would start getting CTDs, just how many and how quickly. The upside, of course, being the fact that I can make them go away as quickly as I made them happen, by using preset #3 on my Afterburner settings, which is factory settings.

For anyone who might have just read that, those are specific to my personal settings, preset #3 is by no means a universal “no OC” setting. The other alternative, which is recommended by MS, is simply to not have Afterburner running at all, but that’s something that, so far anyway, I have gotten away with. But if the unexplained CTDs start in with me, I’ll turn that off, too.

And if I misread you personally, and you did in fact turn your OCs off, then I apologize for that misunderstanding. But that doesn’t extend to the hundreds of other people who frequent these boards who are too stubborn to do so, despite being told oh so many times.

Data streaming could indeed be a culprit in many people’s problems, including yours. The biggest issue with trying to test that, however, requires that you have two systems on the exact same Internet connection exhibiting similar symptoms. If you can establish that, then there is a good chance it does have something to do with connectivity, and given the very recent release of the Xbox version, as well as a major patch for PC followed up very quickly by 2 hotfixes, it’s not all that hard to understand how such a thing might be happening. Other than waiting a few days to do anything, my only recommendation if you can narrow it down to connectivity is to avoid the areas where a huge amount of other people may be congregating trying to get server data for like NYC, London, etc…

However, my overall position remains unchanged. If you (the generic you) can’t at least follow the pre-published instructions from MS/Asobo, then I don’t want to hear your whining, nor do I think doing so is fair to the guys who have poured their heart and souls into this product.

Just for the record, I am not affiliated with MS in any way. I don’t work for them, I don’t work for any sub-contractors, or anything else. I’m just an avid supporter of the product and the people that have made it for us, I do not suppose I am entitled to the fruits of their labors for free, and I just want them, and the product, treated fairly. It bothers me when people slam them without even following their troubleshooting instructions first, which I think is pretty clear by now. In fact, I think I’ve repeated that message 3 or 4 times in this post alone.

Kev

8 Likes

@hobanagerik Not necessarily. For example, let’s say I’m trying to email you a large video file, and for some reason, you’re just not getting it. It could be my connection, it could be yours, or it could be one or more of the hundreds of other points it bounces off of in between you and I. When you start talking about connectivity issues, it’s one of those things that is as much voodoo as it is science. Which is why nobody will ever guarantee you any specific broadband speed. It’s always “up to”. There is not enough capacity in the entire world for every individual circuit to be pumping out data at it’s rated capacity simultaneously, and for good reason. Because such a thing simply never happens, so why spend the money to be ready for it anyway?

Kev

1 Like

It was working for me with 1.18.15.0, but now the game just crashes on start up every time. I did both a repair and reset with no luck. I was already running a vanilla install with no mods. Followed all the knowledge base recommendations. This is garbage. Never had any issues before SU5.

3 Likes