Offscreen Terrain Pre-Caching Not Available in VR

So WU6 is out, and initial indications are that the new setting for Offscreen Terrain Pre-Caching is NOT available in VR!

On August 19th, Jummivanna stated, “In order to ensure that World Update 6 reaches a very high level of quality, we have decided to move back the release date to September 7th.” So… did they miss their goal of releasing at a very high level of quality, or does Asobo simply not care about VR users?


It seems that the setting may well be there in the config file, but perhaps not in the User Interface. Jummivana has been made aware and has said she’s looking into it.
I don’t know whether this means it’s working in VR or not, but at least they are aware of the issue.

1 Like

Which leads me back to my original question. Did they miss their goal of releasing at a very high level of quality, which would be the case if they intended this feature to be available in VR but did not notice that it was missing? Or do they simply not care about VR users, and therefore intentionally shipped the update without this functionality being added to the VR user interface?

1 Like

I’ve been saying this, but sadly Asobo has not touched VR side al all. Their focus has been market place and Xbox. They have no incentive to cater the wants and needs of VR users at the moment. They are simply following the money.


Dont have time to test …but read on a FB group that the setting affects VR as well !
Maybe its just a glitch in settings ?

Can you try setting ultra in 2D settings and test in VR ?

Setting enable=1 and quality=3 in the config file for VR definitley seems to do the trick… no noticeable loading when moving my head and my VRAM usage definitely went up about 1.5-2GB


I’m not so much interested in workarounds to get the caching going - you can open another thread for that. I started this thread so we could discuss what went wrong to cause this issue in the first place.

Did they…
a. Not realize this UI element was missing?
b. Release without this UI element working intentionally?

1 Like

Where is this file located?


I can just confirm and I am a bit disappointed. I have bought my PC, RTX 3090, G2 and other stuff for the MSFS VR.

And still 2 phenomenas are around in VR. Just tested.
The poppin sceneries like costs and mountains and the growing buildings or trees when I move my head from the right to the left or back.

So sad…no pre caching set up and no solution for popping up mountains. Sometimes…the mountains keep a gap and you can watch under the scenery. Immersion good bye.

I hope, a patch comes out soon. For VR.



See this post - not tried it myself yet, but looks like it works in VR but needs the config file edited to do it:


Ok thanks so far…I hope I can find the file.:slight_smile:

And I hope both phenomenas disappear…popping up landscape even if I watch into one direction and I am close to mountains or coasts…and the growing trees and buildings while watching around.

The precache can definately help concerning the 2nd point.
The first point…I’m not sure.

I will give a feed back later.


This is just simply dreadful, I’m almost out of words as to seeing something like this happening and especially after the update was delayed so it’s not like they didn’t have time to check… It’s appalling quite frankly, sorry Asobo but it really is.


You’d think that at some point before releasing the update that adds a new graphics option, they would have had at least one QA tester fire up the sim in VR and… you know… make sure the option is actually there. Maybe they’d even want to go a step further and actually enable it! Maybe even test to see if it’s working!

If I ran any software releases at my job the way Asobo is handling these updates, I would have been fired a long time ago.


Ya. In general you right. Maybe not fired here. But no extra money for a good job and maybe a rebuke.

Ok…could be the priority like said already. X Box and 2 D world first.

But in the end it not an elegant result…working with setup-files …should not be and I am disappointed. Now going to try the file idea.

Update follows soon…

also have to say that this is very disappointing! I only fly VR. Far too little love for VR. Somehow I’m speechless …


Ok friends…just tried the ideas of Gordonreig and acutally numbernumber481.

I have changed the setting in the config data.The name is cfgdata.

And I can say…I am “just” 2/3 disappointed. The growing trees and buildings disappeared. And my memories are still free. I have 32 GB Ram and 24 VRAM.

Therefore, there are still 2 points. The menu for setting precache is not available…so why?

And the popping up of (parts of) the mountains or coasts is still around.

But really…after changing the precache…I can say “wow” already.

Thank you to the 2 colleagues who mentioned this solution.

But I have to repeat…still disappointed.

My friends are going to visit me next weekend and I wanted to show the VR flight. So…

If you have any idea, I would be glad to read it.

And last but not least…I hope, the next successful and complete patch comes out soon and it will be not too late after 7th September 2021.

Regards and thx again


Hi Siedo, Is that the UserCfg.opt file? usually it can be found in:
C:\Users\blahblah\AppData\Roaming\Microsoft Flight Simulator =Steam Version
C:\Users\blahblah\AppData\Local\Microsoft Flight Simulator = MSstore version

1 Like

I have used this path


I guess it’s better to use this one. In case you move your data of MSFS to another drive.

But usercfg.opt is correct. :slight_smile:

Edit: I have the disc version.

1 Like

Your right… the pre-caching helps a lot with fluidity of panning your head around but it does not solve the LOD issue.

If that screenshot is from your file, only thing I can suggest is cranking up the LOD sliders. They are 1.0 (%100 in the sim) in that screenshot. Try %200 (sliders maxed in sim). If you have 24GB VRAM, that means you have a 3090…as do I. You can go farther than 2.0 by editing the “Terrain” and “ObjectsLoD” values directly in the config file. I also have a 3090 but I start to see serious performance loss past %200

@Jummivana this needs Devs attention please.

1 Like