Old problem showing up again - stuck on updating

I know this problem has been around for awhile, but not having the issue for a long time, I was very disappointed when I finished the most recent download to upgrade NZ, then tried to start MSFS again, only to see that I am now stuck AGAIN on the waiting for update issue. I went back and tried every suggestion from 2021 on, and I can’t seem to get around the problem. Anybody else having the same issue and were you able to eventually solve it and get the program running again?

Yes I have the issue everyday since many months ago. It only works well when there are any online outages or after you kill and launch game several times. Basically you can´t do anything to solve it because the client is failing to get the updating info from servers. The only way to load game in one go without issues is to run it offline. In that case the updating loop is bypassed instantly.

According to beta release notes SU12 appears to have a fix to improve the checking for updates time. I hope they fix the whole issue as that never ending loop it´s a real pain and it prevents game from loading.

Cheers

Not what I wanted to hear, but thanks for the response. Hopefully it will get fixed one of these days.
Regards

Perhaps a stupid question, but I’ve never tried to run the game offline except when I lose the internet while on line. How do you start the game in the offline mode? I tried disconnecting from the internet and starting the game, but then it asks me for the MSFS game disk which I don’t have since I downloaded the game from MS on line. Now what??? You really have to want to use the MSFS to put up with all these headaches every time they do an update. I have a number of games on Steam, and when I press the button, everything works the first time, every time. Sure wish MS could have a chat with the Steam folks to learn how to do it.

You need to disconnect network while at the checking for updates loop (so after licence was checked). Then a message box will appear asking you to continue in offline mode. Network can be enabled after loading game in offline mode, while at the main menu, to have all online services except marketplace available again (you may need to activate them as well in the Data Options menu).

However there are three checking for updates loops, so network shall be disabled and enabled again while on the main menu everytime to bypass them or game will never progress beyond them:

  • The one at game launch
  • One after loading game, short before loading menu
  • Another after finishing a flight, short before loading menu

This is why this bug is so annoying.

Cheers

Thank you so much for all your help. I have no idea how some of you folks acquire so much knowledge about the program without spending many, many hours delving into the literature and possibly even the software if you can get at it, but thanks so much for being willing to pass on and share all the knowledge you have gained, probably over a long time.

I’ll try diving into it again, otherwise all I have is an expensive collection of software and hardware that clutters up my desk!!

Regards,
Cdrbuck

1 Like

Amazing, that’s the first time I’ve seen in back of the Waiting for Updates sign in the past week. Thanks for the directions.
However, even more amazing, was when I tried it a second and third time, everything worked completely normal. Magic I guess because I didn’t do anything differently than I have been all along.
In any event, I’m not going to tug on Superman’s cape and will just go along with the program as long as it’s working. Thanks for all your input and I’ll just believe you help me to get everything working again.
Cdrbuck

As far as I have seen the bug is random and it´s just dealing with the online connection between servers and client. Your local files or addons don´t have any impact because you can launch game several times without changing your local files and sometimes it will fail to pass the loop and others it will work fine.

By the way none of the proposed solutions at helpdesk knowledgebase work. Asobo needs to fix this. All they need to do is to set a few seconds timer to exit loop automatically if anything fails on the updates loop. Currently there’s no way to exit other than disabling network or killing the process.

Cheers

I’m beginning to learn how the system really works due to your input. Today, nothing worked again so I now just write it off as bug in the program and wait until next time and maybe I’ll get lucky again. At least, I’ve learned to play offline so the game is not a total waste until Asobo eventually gets around to fixing the problem. Hopefully you’re right about what you’ve heard regarding the next Beta version currently under development.

Regards

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.