Online functionality issues, missing all aircraft, and out of ideas

Please tag your post with #pc and/or #xbox.


Are you on Steam or Microsoft Store version?


Are you using Developer Mode or made changes in it?


Brief description of the issue:


So, this all starts with my last update (to about 10 days ago when I started having issues with Gaming Services (you can review my other issue here: Image stutter in cockpit view since SU6 - #20 by MTpiperpilot). That’s (I think) a separate issue than this one. Maybe not though!

To try to solve the Gaming Services issue, I tried all sorts of Microsoft and Xbox fixes, and nothing helped. Could not update, reset, restore, etc…so I tried doing a system restore to solve that issue, and after the system restore, I’m not getting errors from Gaming Services in event viewer anymore, but I am having an issue with MSFS2020.

When I launch the Simulator, it checks for updates and finds none, and then loads and drops me on the home screen as normal. However, my “Discovery Flights” button and my “Flight Training” buttons are both greyed out.

Then I noticed that while the Marketplace is available, something else is very wrong, I’m afraid…because I only have one aircraft installed (Ultralight 103) in my hangar, even though everything else is showing installed correctly in content manager.

I tried this ( and it did not help. All that did is revert most of my general options settings to default.

I also noticed even though my Online Functionality is showing “ON” under the General Options, Data settings, when I click on my name in the upper right corner, it shows “Status: offline

I also tried this: (

It did not help. I’m using Steam, so I dont think this help article is geared to me.

I tried removing a plane (Icon A5) that showed installed with the Content Manager (but not available to fly), and then re-downloading it. It downloaded but would not let me complete the install - the sim froze and I had to kill it with Task Manager.

When I re-launched, to my surprise it did install the Icon A5 afterall, and now I have an icon for “Discovery Flights” again. So it seems it is not able to detect anything in the “Official” folder now, unless it downloads it fresh.

It’s still concerning it was not able to complete the Icon A5 install without the game freezing…

Thoughts? What does this all mean? I tried contacting Zendesk, but this sounds like a real challenge and I’m not hopeful they’ll help.

PS> I’ve tried resetting Xbox app and Companion App, I tried logging out and in with both the Simulator and the Xbox apps, and made sure all my Windows and Windows store updates are current.

Provide Screenshot(s)/video(s) of the issue encountered:

(name blurred out)

Detail steps to reproduce the issue encountered:

See above

PC specs and/or peripheral set up of relevant:

i7-10750 6-core CPU, 32 GB DDR4 ram, and Nvidia RTX 2060 GPU with 6bg of memory. Two 1TB M.2 NVMe SSDs.

GPU / CPU are factory default clock speeds. Have never enabled overclocking. I’ve tried all of the applicable CTD guide’s suggestions.

Build Version # when you first started experiencing this issue:

Here’s the follow up to this: Now Missing all Discovery Flights, Flight Training, etc

That the dropdown shows “offline” is due to mulltiplayer turned off → red herring. For the rest of the problems, since you made a system restore FS is now likely missing some or all of its registry entries and linkage to its own folders, possibly because the used restore point was created before you installed FS. So a full FS uninstall, making sure your computer has all necessary stuff still updated after the restore, then reinstalling FS from scratch might be the only way to fix this.

Ah, right you are about the “offline” thing!

I actually have tried to do a full uninstall/reinstall. The issue still persists unfortunately.

It appears the issue now is that I’m missing all of my flights/training/challenges. The screens are blank of all content other than the background images.