Only 2 Aircraft!

I believe PhThompson was referring to his suggestion of going to Profile - Content Manager to download the rest of the aircrafts.

Thanks - unfortunately it doesn’t work for me as I only have 2 aircrafts in content manager

Hi, I purchased a high end gamer pc (64 GB RAM, 2 1TB SSD, RTX 2080S), installed WIN10 PRO V2004, installed and update MSFS from MS STORE.
I tried this procedure now for 5 times without success.
I ONLY HAVE 2 AIRCRAFTS IN THE CONTENT MANAGER and Marketplace is greyed out.
I am very disapointed and stuck.
WHAT went wrong???

Hi i had very similar problem and the solution was extremely simple - check if your on-line services are on. Mine got switched off during reinstall and that cause all my problems

Thanks, but what are online services? How can I check?

In options, general, data - check all the online options are set to “on”

For the “2 aircraft issue” the troubleshooting steps above are the recognised solution from the known issues list:

1 Like

Thanks, I will check the online options.
In my content manager there are NO additional aircrafts to download.
I tried the download now three times (!!) in the default folder , 4 hours each

Try searching the forum, you may find somethign more there

Additional aircraft will not appear in your content manager if the on-line services are off. I had the same problem and like you wasted hours/days installing reainstalling software including clean windows install …

1 Like

Hi, thank you for this advice. I enabled the online-service and suddenly all the aircrafts and others were ready for download.
Microsoft should tell us how does it come and why there is NO hint about this trick.
I read, that the online service option is for Bing data downloading only ??!!

Thanks so much.

1 Like

Hi Gordon, as you can read I was successful due to your and HomeKnight’s advices.
Thank you both.
Regards
Alhard

Glad you got it fixed. Happy flying

so, i reinstalled the game because it was broken. now the game works but i only have 2 aircraft the cessna 152 and the tbm 930

I was forced to reinstall the sim. today, I had the same issue, as I’d also manually deleted all the basic install folders from my D drive to make sure I had a clean reinstall, so only two planes! I figured this out on my own, however, but your post gave me the clue as to what was wrong. I really appreciate your help! Last time I reinstalled the basic content and all the planes were still there.

Scott B. NY

Hey Phil

I am facing this issue as well. Did clean installs 4 times now. When I am downloading a package, it says “Package Failed”

  • I have checked that online services are on
  • Logged out and logged in again
    Please advise.

I have the xbox game pass version of MS Flight Simulator. Now I am aware of the CTD Hotfix and have since downloaded and applied it which has got me into the game/sim. Please bear with me as the first section is from before the hotfix.

After updating with the new patch, it simply CTD’s at the “Japan Update has Landed” screen. Well it actually got to the next screen “New Activities” etc.

I tried the suggested fixes (by Microsoft) as follows:

‘Repair’.
This option as expected had absolutely no effect whatsoever. The issue remained.

‘Reset’
This was the next option. This resulted in having to wait until it finished downloading and installing 95Gb of game data. When it finally completed I was presented with the same CTD as outlined above.

With nothing left to lose I tried the final option which was a complete uninstall and reinstall from scratch. Another 95Gb of data plus whatever it downloads beforehand. This too, not surprisingly gave exactly the same result.

===========================================================================

OK, so I waited until the hotfix was released. After downloading and applying it the sim finally loaded to the main menu screen. My go to aircraft, the Daher TBM 930 was already selected so I took it for a short flight.

Next I thought I’d try something different and tried to select the A320. To my surprise the only aircraft available for selection were the Daher TBM and the Cessna 152. The rest were simply not shown. Not just greyed out, they were not even showing in the menu.

Of course because of that none of the activities were available either, bush flights, landing challenges etc.

I tried Repair, Reset and complete uninstall/reinstall from scratch options once again, (yet another 190 plus gigs of data, all to no avail. Still I’m presented with only the same two aircraft. I also removed the community folder just in case any mods were having an adverse affect but no difference.

Does anyone having a similar issue or know of a fix for this, as after downloading around 400 gigs of data I’m on the point of giving up on this thing altogether, which is a shame as I was actually enjoying the sim before this patch, bugs and all.

Thanks in advance.

https://flightsimulator.zendesk.com/hc/en-us/articles/360016763120-Only-2-aircraft-in-the-hangar-How-to-install-additional-content-

Hi Rivet7038 and flyboyf117.

flyboyf117 you are missing the point. We have NO other items to download in Contents Manger. What your link has is greyed out items ready for download.

I have exactly the same problem. I purchased a code for the Premium Deluxe version, installed through the store. I could install all the adds and play until… Horror! The patch would not download, all I got was 'Error!" Gave up on that and did a complete re-install which had been patched. All okay then all sorts of corruption too numerous to mention. Decided to uninstall and re-install and I’m at the place you are at. Tried four times. Just the two planes in Contents Manager. Also I purchased a airport in game but Marketplace is now greyed out. No airports etc either. Noticed while downloading, those two planes are the only ones mentioned in the downloading messages that you get… All other plane types came up as generic.

I’m sorry I have no fix for you. I have to say that I’m glad it’s not just me. I have left a message on this forum but I’m new so can’t atm point you to it. Couple of moderators have come up with suggestions which I tried but with no effect.

Guess it’s back to my trusty Zebo modded 737 night flying (lighting so much more realistic) in XPlane.

Hi Flyboyf117 and alanrco5287,

First, thanks to Flyboyf117. That solution worked for me. Actually after posting my original message, I did notice the '2 aircraft ’ solution in the ‘Known Issues’ section. Should have looked there first.

@alanrco5287
Exactly so Alan. I didn’t mention the airports + marketplace originally but they were also missing/greyed out. As to your continuing issue, I can only assume that it has something to do with the game version differences and possibly the source of download.

My version is the base version through Xbox Game Pass whereas yours is the Premium Deluxe version purchased through the store. I can’t see why that should have any adverse affect but I suppose stranger things have happened.

Sorry I can’t offer you any possible solution but I do hope you find one soon.

Edit. I just noticed your screenshot and that is where we differ. In the content manager in my case, all the missing files were there for download. Obviously not in your case which is more than strange.

I must be blessed because I never have problems with updates.

I am unsure if your Error! code is on the update screen, but if it is, I have found that if you just hit the little refresh button on the right of that bar, the download starts and completes.

My latest update package was much larger that the patch size listed (~26GB) but it all installed and there was nothing missing, that I have seen so far.

I have only reinstalled once and that was for Aug 18, and I run the MS package on my E drive.

I don’t have any more to advice to give, but it does look like the program works as intended and very well for an evergreen product.