OpenXR FPS Drops with Motion Repruduction/Vector Form 60fps to 20fps

Hello everyone,
today I dealt with the SU5 in VR and had the following experience.

It doesn’t explain to me why openXR behaves like this. in Steamvr I have around 38fps and frame times of 20ms. in 60hz Frequency on the Reverb 1 I can fly reasonably well with 30fps and motion vector. in openXR I have almost 60 FPS, so I would rather fly with openXR. to avoid stuttering I need motion vector in openXR, but then the FPS drop to 20. in 90hz I have 30fps. this explains to me only that openXR tries to calculate the FPS times three.
However at 60hz Frequency there should always be 20fps and not always 19fps and less, after all I have 59fps without motion vector in openXR.

anyway, openXR never seems to reach the display Frequency.

Software completely up-to-date (except for AMD graphics driver, a new one came yesterday) use the latest openXR component, i5 6600K @ 4.7Ghz, 32GB 3200 CL18, RX6900XT, Samsung 970Evo 500GB

You need to clarify exactly what you are talking about. Both steam and WMR use OPENXR, so are you referring to using steam vs WMR? Also what is motion vector? Do you mean motion reprojection?

There would never be a 20fps difference from steam to WMR. I have a G2 and found that steam’s OPEN XR is much smoother (less stutters) than WMR but roughly the same frames.

okay, that’s probably complicated. SteamVR is in use and either openVR / SteamVR or openXR is selected as the VR runtime component. That’s how I tested. Can I also use openXR when SteamVR (DVD version) is closed? So that I have nothing to do with SteamVR? Yes, I mean movement reproduction. The problem comes when ooenXR is selected in SteamVR and I choose motion projection in openXR, then the FPS collapse to 20. At an HMD frequency of 60 ooenXR actually has to do 30FPS

RTX 3060 mobile
5600x mobile
Samsung Odyssey Plus
MSFS Steam version
OpenXR beta (last version)
nVidia updated drivers

For me, now the sim works a lot better without OpenXR Motion Reprojection enabled. Since VR release I´ve been playing with automatic MR. Today was unplayable, with low fps, stuttering and wobbling.

Not sure I follow your what you’re saying completely, but it’s what motion reprojection does: if there is not enough FPS to meet 90Hz refresh rate of the G2 it limits the output to 45 FPS (half) and reprojects frames x2, adjusting for your head movement. If there’s not enough to meet 45FPS - it reprojects at x3 and limits frames to 30FPS. If even 30 is not achievable (often in MSFS) it does the new x4 reprojection (but only with OpenXR developer tool set to latest preview and reprojection on), and therefore caps FPS to 22.5. So reprojection = frame limiting, then multiplying back to 90Hz.

That’s why with 60Hz you’re seeing 20 (x3 reprojection), and on 90Hz you’re seeing 30Hz (x3 reprojection).

Reprojection cost CPU resources, so basically you will be loosing some FPS when it’s on, but gain smoothness. So if you’re getting 59FPS without repro, you could be getting 44FPS with repro, for example, and that woudl fall back on 30FPS with reprojection. Anything less than 30 (which would be more withour repro) would fall back to 20FPS.

1 Like

Good morning,
yes, followed correctly, that was the question. First of all thanks for the reply.

now I am becoming aware of some things. I know that the FPS are produced twice in order to achieve the frame rate of the display. in Steamvr I always have exactly half the FPS of the display (45/90 30/60). I’m just amazed why only 1/3 of the FPS of the display can be achieved via openXR even though I have 59fps without reprojection. there is no reason that openXR only uses 1/3 of the FPS even though half (45fps) can be kept loose. but apparently this is how openXR is supposed to work. your info on it brings light into the dark.

There is only one thing I do not understand, why do I still not have 30fps at 90hz, but always below that, i.e. 29, 28fps and at 60hz a maximum of 19fps. that way I don’t get smoother running. Even without re-projection, the FPS always remain 1-2 FPS below the display frequency. 60hz without re-projection makes 59fps and it stutters regardless of the setting.

yesterday I first installed the new Radeon driver from July 27th. and now openXR doesn’t work anymore, no matter what I do I only have 14fps. but the Steam runtime component now runs much better.

I think thats not a MFS problem, i think its a problem from openXR and the reprojection mode

1 Like

I have the same issue. I made the same thread a long time ago and still no solution. If I’m repro from 30 to 90 hz, I will be at 29hz sometimes but NEVER lower than 25. But if I’m repro at 20, I will go lower than 20 even though I never went lower than 25 in the previous mode. Hard to explain.

You keep saying OpenXR but I think you mean WMR. The only way youa re playing in VR at all is with OpenXR, Its just a matter of which software is running OpenXR: Steam/WMR.

Then I don’t understand what you mean by setting motion projection in OpenXR…Can you show a screenshot of where you are setting this?

My suggestion would be to disable reprojection within steamVR settings and within WMR.Then try running the game in each software and see how you feel about it. It should be roughly the same anyway.

I’ve now spent 6 hours testing. With the current Radeon driver, openxr is no longer possible because it does not matter whether with or without reprojection and whether standard or the latest runtime component, it always only makes under 15 FPS.

then I set everything in the sim to a minimum of 100% resolution and in Steam VR it ran at 90hz with reprojection with 45fps and 20ms frame times. then I set the supersampling quality to high in SteamVR and the frame times were 0.2ms. read that correctly, 0.2.

after restarting Steamvr but without changing anything suddenly at 30ms. 60hz does not improve the frame times either. I have tested all of the graphics card driver settings, it has no effect.

despite the fact that I only have 50% CPU load and 50% GPU load, the frame times are still so bad. everything weird how the sim reacts.

It sounds to me as another AMD driver issue. AMD makes great chips, but their drivers are notorious for this kind of bugs. I couldn’t make X-Plane VR work with RX 5700 XT at all. Had to sell the new GPU. A total fiasco It worked just fine with GTX 1660. I’m now on RTX 3080/Ryzen 5900.

xplane doesn’t work for me either. I was hoping that the Microsoft Sim is very much AMD optimized because of the Xbox. But I need at least 12gb memory for VR and there is only the extremely expensive 3080ti, the 6900XT I have directly from AMD at the AMD price. The funny thing is, with openXR everything looks very good and clear, with SteamVR everything flickers and the cockpit is barely legible

IT’S ALL OPENXR! This isn’t hard to figure out if you just check the correct settings.

What do you mean by that? I don’t understand what you’re getting at?

Simple?