Openxr_loader.dll crash on MSFS loading?


I dont know if trying the opencomposite site wide installer (aero) on my system initially did this or not, but, i also re-clicked steamvr in it to set things back and did the per game install. However, now when i try to launch MSFS (i didnt install the dll there for opencomposite anyway), MSFS crashes with openxr_loader.dll errors in event viewer.

The only other thing i did was install the varjo foveated rendering installer for DCS. I’m not sure whats going on with msfs

Any thoughts?

Around two months ago, I started in MSFS and was amazed that I just had to be connected with Virtual Desktop, used the shortcut to start the program and it went into VR with no problems.

Then after 2 weeks there was the issue with the order that I started everything, and then extreme stuttering. So I worked out it was SteamVR after some other programs updated, and then a week later SteamVR updated when I started it, and MSFS was good. But the order of starting everything was still important. It worked for 3 days.

So I tried Opencomposite, and it worked, solved the stuttering. Even though I had MSFS on a drive of its own, and there was no .dll file placed in the folder. So I did something, it did nothing, but there was a result. Also, starting order was important still.

Another week or so of good flying, and after the latest MSFS update, it now crashes.

I have spent more time trying to get this ■■■■ program to start, finding the exact order, messing with settings and trying to understand how to get the different launchers going, than actually flying. There is not one YouTube video or post that goes through the order of ‘how’ to change from SteamVR to OpenXR, just ‘change it’ and the comment replies if you ask this are basically ‘you are stupid, you can’t do it’.

So I’m out, and over this piece of ■■■■ program. I will become like another person from a different forum who replied to me saying ‘every month I start MSFS up to see if it works in VR, and it never does’.

Are you using the latest 0.2.0 version? There was an issue in the original version if you tried to play 2D and you did not have Varjo Base running.

And PS: OpenComposite is absolutely not needed for MSFS. The game already supports OpenXR. Anybody claiming they need OpenComposite for MSFS or it made a difference for them in MSFS = placebo effect.
Do not use OpenComposite via the switcher (“Switch to OpenComposite”), that plain doesn’t work with Varjo and will break everything.

Strangely this went away then popped back up again. Now even when not using VR but in 2d. I tried renaming the file temporarily but now msfs wont load at all let alone ctd with it enabled.