OpenXR Toolkit (upscaling, world scale, hand tracking...) - Release thread

Anyone have benchmarks or opinions on whether NIS or FSR works better w/ a 3080? I’m not quite sure what I should be looking for.

1 Like

I managed to get the Toolkit working after an uninstall, restart, reinstall and restart.

1 Like

That sounds good for me .

To make this somewhat more complicated (I have seen several likewise experiences / 6800 XT LC / 9900K / 64 RAM / HP G2 / UHD TV) I run Tool solely to get rid of microstutters.
Have OpenXR running 95% (got rid of some) then use Toolkit, do FSR but set on 100% - so FSR supposedly does actually nothing, and sharpening 100%. So, I use the sharpening of the Tool (and worldsize) and the Tool driver that ‘fixes something’, who knows what, and it’s really smoooth now.

MSFS renderings 100%, low SS, max anything that does not affect performance, Ambient Occlusion High is pretty, down everything that does not do anything useful. Smoothness is the aim with this Tool @ 31 FPS.

I also have this issue of double toolkit window in vr which is why I have to close one eye to operate the settings. Same happens with the fps counter, there are two of them in the view. Quitting and reentering vr doesn’t solve it for me. Reverb g2 + 3090.

Interesting approach, will try this. Do you notice any degradation in image quality compared to running natively?

100% FSR is no FSR supposedly, but the tool is still On and improves sharpness. Somehow by pushing data through this XR APILAYER NOVENDOR toolkit acacadabra channel, you also get a smoother VR and you keep native with bonuses. This for higher end setups.
I think mbucchia hinted at this without having an explanation, it’s a gift from the flightsim gods. (YMMV of course)

Got some serious issue. Since when I installed OpenXR Toolkit, I can’t enable VR any longer. When and if I do, MSFS freezes and don’t unfreze not even after 1 hour of continuous waiting. Just becomes permanently unresponsive. Disabling it, has no effect :frowning:

If you disable it and it still crashes, then it’s because of something else you’ve changed (settings? Driver?)

Can you send me the log as explained in our troubleshooting guide?

Then you should uninstall it and - perhaps - reinstall again. Also, if you are using DX12, try DX11 with fresh install of the app. Dx12 is not stable and does cause problems such as freezing and CTD, regardless of whether the OpenXR toolkit is installed or not. Most of any issues are MSFS related.

[OXRTK] 2022-02-06 03:19:12 +0100: dllHome is “C:\Program Files\OpenXR-Toolkit”
[OXRTK] 2022-02-06 03:19:12 +0100: XR_APILAYER_NOVENDOR_toolkit layer (Beta-2) is active
[OXRTK] 2022-02-06 03:19:12 +0100: Using OpenXR runtime Windows Mixed Reality Runtime 109.2111.23003
[OXRTK] 2022-02-06 03:19:12 +0100: Ignoring XR_MSFT_hand_interaction for Windows Mixed Reality Runtime 109.2111.23003
[OXRTK] 2022-02-06 03:19:32 +0100: dllHome is “C:\Program Files\OpenXR-Toolkit”
[OXRTK] 2022-02-06 03:19:32 +0100: XR_APILAYER_NOVENDOR_toolkit layer (Beta-2) is active
[OXRTK] 2022-02-06 03:19:32 +0100: Using OpenXR runtime Windows Mixed Reality Runtime 109.2111.23003
[OXRTK] 2022-02-06 03:19:32 +0100: Ignoring XR_MSFT_hand_interaction for Windows Mixed Reality Runtime 109.2111.23003

That’s all my log said :confused: I’m really confused. Now uninstalling had no impact, still freezing. I can’t really get what’s going on under the hood :smiley:

It seems a lot of people are missing the Eye Offset (think that’s the name, not at my PC) in the options menu, change that and you can “merge” the two menus into one and voila, easy to read.


I’m also PPL and for me C172/C152 cockpits are way to small. This is subjective and depends on your IPD. Fortunately with the toolkit we can finally set it individually.


Thank you for the tip on changing the VR post processing “sharpening” value in the Usercfg file to “0”. Much better and resulted in a little bit headroom.

I’d like to ammend that my system now averages 34 fps instead of the earlier reported 30 fps. After re-testing I descided to keep toolkit resolution at 80% but increased toolkit sharpening a bit to 35%. Also in MSFS I added bloom effect, without much apparent impact on fps. With 34fps, I like that it gives a tad of headroom when things in sim get busier compared to 30fps before.

All in all it is nicely balanced between graphics and average VR performance in various MSFS (still motion smoothing disabled in OpenXR).

Mucho kudos! :slight_smile:

1 Like



As asked, here are my MSFS setting for using my HP Reverb G2, using 100% in-game scaling

Nvidia driver settings: 40 max fps, low latency mode on, power management prefer max. OXR at 100% scaling.

Running my i7 10700k at 4.9 Ghz all core, 2x16 GB DDR at 4000 16-17-17-36, feeding an evga rtx 3080 ti ftw3 ultra in overclock mode.

As mentioned, running OpenXR_toolkit FSR 90% sharpening at 80% scaling and 85% world scale.

I get a near solid 40 fps with the above. The only time it dips occasionally and temporarily into the upper 30’s is when over metropolitan areas. All my flying is below 15k ft.

I have to recant my claim about no AA/shimmering of building and trees. On my climb out right after takeoff, there is a band of distant ground objects seen at about a 10 to 30 degree aspect angle that are a shimmering mess as I climb. Once the above that aspect angle everything clears up, including all ground objects for as far as I can see. BTW, I have excellent vision and hate jaggies with a passion. VR has been an exercise in visual clarity compromises for me; I’ve come to the place where the VR “whole” experience is DEFINITELY much better than the sum of its parts.

Really looking forward to when (if?) MSFS implements DLSS for VR. That will be a grand day indeed!

Mods, please excuse my indulgence with this post.

1 Like

you mean FSR 90% and 80 sharpening?

FSR with 90% sharpen and 80% scaling. Updated my post to note this.

Try turning off windows game mode and/or HAGS if you have either of them turned on.

Regarding the shimmering: Yes, what you describe is the big issue I have. I believe the reason it clears up once you climb further is because the buildings are simply no longer rendered and the scenery switches to 2D (but it still looks normal as you are now at sufficient altitude).

1 Like