openXR updated

openXR update in the store… Can’t say I notice anything new/better but I’ll leave that to the fps chasers :wink:


3080 and G2. Saw increased clarity, less stutters and improved reprojection artefact handling. I only fly with reprojection on.

A big upgrade for me.


Hi, what render scaling do you use in open xr with your 3080 and G2? Thx

1 Like

Is that using the latest Preview version or not? (i.e. in the Developer Tool, do you have “Use Latest Preview” checked?)

I’ve updated the OXR Dev Tools yesterday (it showed up in the Store) but this morning, checking the version in OXR Dev Tools, it still shows 107.2108.5003.

However since I’m not using “Latest preview OXR runtime”, because up to yesterday at least, the preview 108.x was not giving good perf, could this update just be a new “preview” only, and not a release update?

PS: enabling the preview tells 108.2109.10009 on my test system.

checking the version in OXR Dev Tools, it still shows 107.2108.5003.

yeah the last couple of updates were like this for me

Interesting. My “non-preview” version is now showing 107.2109.10010

Preview is 108.2109.10009

my preview off / on versions are currently the same as cptlucky’s, but just noticed a cumulative update for windows waiting to install. Will check after that’s done

edit - All Windows updates done (last cumulative was KB5005565 - win 21h1) and MS Store updates done, but still the same as above.

1 Like

I notice if I mess around a bit with the use preview button and swap between tabs to check the version number it tends to be inconsistent. ie 09 becomes 10 and back with the wrong selection or at random. Must be a bug for now.

I noticed that too, but can’t get it to ever show 10

Latest preview - 108.2109.10009

1 Like

After last update in OpenXR Tools, i was able to finally fly the whole plan (SBCT->SBPA) without CTD or headset unsync in… months! I was going to just give up trying to play this game in VR and turn back to pancake mode, but now I have a little hope that things are going to get better.

are they still updating without releasing a change log of any kind?

Has anyone tried this with quest 2? I’m Relatively satisfied with performance at the moment so don’t plan to be the guinea pig here :stuck_out_tongue:

Quest 2 doesn’t use this - this is OpenXR for WMR. Quest will use Oculus’ implementation of OpenXR which is separate.

I see, I thought this was something to do with the general OpenXR system that all the headsets used. Thanks for clarifying.

1 Like

Yeah that’s annoying.
OpenXR 107.2109.10010 and OpenXR DevTools 108.2108.10009 now here.

1 Like

Just got an Open XR WMR update in Microsoft store. It wasn’t there 24 hours ago.

When turning preview off, it’s now showing OpenXR 107.2109.10010 (still got to toggle back and forth between Dev Tool tabs to get it to show up)

Preview on is still v9

At this stage I can’t see any improvements

Do i need to use openxr with Pimax 8KX?


I’ve done a test yesterday and although prior 108.x preview was not good for me, the newly updated 108.2109.10009 didn’t show any particular perf or visual problem compared to 107.2108.5003 on my test system. It is just one test though so this is rather inconclusive until testing more.