Orbx Cityscape Sydney not working after SU5

Orbx Cityscape Syrney.
After the latest update it did not work anymore. The original scenery is disappeared but the Orbx scenery
did not appear. i discussed that with Orbx however they had no solution.
The other Orbx cityscapes (cape town, Paris, Frankfurt , London etc.) are working well.
Has anybody an idea?

Doesn’t bode well for my recent purchase of Orbx Mumbai City Pack (which is, btw, absolutely stunning and worth far more than the modest £6.50 I paid for it via Orbx Central). Well, I’m downloading Sim Update 5 now - just 37GB to go - I’ll soon find out if Mumbai’s still looking so good!

Orbx City of London halts then crashes system to desktop. Deleted purchase then London looks great. Sorry but Orbx needs to get their act together. On another update they at least pulled their scenery for repair. If a newbie buys it they will blame Asobo/Microsoft. When Orbx is asleep at the wheel having had sufficient notice of this update. Innsbruck and Zell Am Zee work fine it seems although I only did a short test.

FPS on the new update is great thank you to Asobo; job well done.

Orbx Sydney works fine for me, Orbx London halts while loading an then crashes.
Sydney is bought from Orbx direct, London from Marketplace.

1 Like

Orbx Cityscape Sydney was the first addon i tried with the new update and it is working perfectly for me. (Purchased via Orbx Central)

Does it improve the ground textures in Mumbai as well? I was massively disappointed with the default depiction of Mumbai in the sim (and the rest of India sadly)

EDIT: Just had a look at the product page…looks fantastic. for that price i’d be mad not to take a punt… im going in!

after installation of sim update 5 Orbx Sidney works well again. :grinning_face_with_smiling_eyes:
No idea wether the simupdate was the reason… :thinking:

same for me.

After su5,i came across with 2~3 CTD each time i loaded a planned flight. So i thought there might be the community fold .Now i keep the fold empty ,the game runs well .I will try several more times in the following days to see if its the problem.

Asobo has GOT to do a better job of letting developers have access to Sim/World Updates well in advance of release so add ons from responsible developers can work right the same day the update goes public. If this means they have to freeze the development of the updates a few weeks before they become live and available for end users, so be it.

The madness of large numbers of add ons breaking on the new updates is ludicrous and needs to be addressed.

SU5 ran so beautifully with an empty Community folder. Adding in a half dozen or so of my essential add ons didn’t cause issues. But when I started to add more back in, but still a small fraction of all my add ons that used to work great, fps drops considerably and I got huge freezes and stutters. So now I’m going to have to spend days figuring which I can use, which I can’t, at least until they are updated.

Asobo really needs to add some sort of accurate resource monitoring per add on, so it’s obvious which ones are causing the problems.

And I would kill to be able to load and unload add ons without restarting the whole sim like P3D can do. At least between flights. A full restart means testing to find bad add ons is incredibly time consuming. The sim needs to help find the problems!!

After update 5, two Orbx addons (Sydney and Dubai) don’t load anymore. Besides, fs stops working and I have to go to task manager and close it. Did it happen to anyone else ?

Just tried both a few minutes ago. Nothing wrong for me. Maybe it’s conflicting with another addon you have?

I don’t know, but I think it’s another problem, because it was running well before su5

I needed to uninstall the packs using Orbx Direct, and then I did a reinstall. It solved my issues.

Thanks, I´ll try it

I have the same issues as you bought 3 packs from the marketplace, all dont work after the update.