Owners of GeForce 600/700/900 series cards, please chime in

No, it’s not fixed yet. The issue is “under investigation”.


I’m sure I am quite late to the party, but I have also encountered the flickering clouds with my 960M. Worked fine before the new updates. Thanks so much to all of you for working hard on this. I am glad I’m not the only one suffering this issue. I’ve made sure to vote, hopefully we’ll get a fix soon.


Thanks for the votes, the more of them the better our chances are! Make sure to send a Zendesk report as well if you haven’t already, it’s the most direct way of sending feedback to the developers.

1 Like

“This issue has been tracked in our internal bug tracker to be fixed in an upcoming patch. Please keep an eye on our development updates & Patch Notes in the next weeks.

In the meantime, we would recommend to turn off the volumetric clouds in the graphics settings. “

Note that adjusting those settings didn’t work for me

1 Like

It might not be this patch! Hopefully soon

1 Like

Thanks! Now it says to keep an eye on the patch notes “in the next few weeks” which is somewhat encouraging, though it could mean the late January patch as well.

Still, it’s sad to see that support are still not aware that “Volumetric Clouds” is not a graphics setting in the options menu. It shows that there is not much thought behind those replies, and it makes me wonder whether they are actually trying to fix this.

1 Like

I don’t really think you can turn volumetric clouds off in the graphic settings, only to low.
You can turn them off in developer mode, but then you have to have dev mode on all the time and then logbook doesn’t work I think.
Actually, it is somehow possible to have some dev options change and left on (like FPS etc), but it’s kind of hit or miss. There is a save settings option in the dev menu but not really sure how it works. May have something to do with how you turn dev options off. I’ve played with the settings and had things stuck on or off. Again the combo of things I mentioned (save settings, how you turn dev options off) and the setting that is on when you shut down the sim. Also activities that force weather. No real guide or manual and results are very hit or miss. Only thing that works somewhat consistently is leave dev options on and volumetric off. But then no logbook.

Yes, I am also one of the squat nice weather fliers. I also thought that my laptop Acer 2.6 - 3.5 GHz with 16 GB Ram and a GTX 860m met the minimum requirements! Is probably not the case in retrospect. I also paid for the big package

There is in Dev tools. But,didn’t do much

Support have said that they will prioritise a fix accordingly based on the amount of people that report the issue. As such, if you haven’t already, you need to send a report to Zendesk and upvote the two threads I’m linking below (by clicking the blue “Vote” button next to the thread’s title) to help towards the cause.

This will be fixed with Sim Update II according to the latest Feedback Snapshot! Our ancient graphics cards will be brought to life again!



Sounds fantastic but are you sure it’s not update eleven!


Good thinking, though if you look at the way “2021” is written, the “1” looks different than the “II” in this section. Besides, if it were Sim Update 11, then we would be looking for a fix in 2022 or something!

Support said to look out for patch notes in the next few weeks, so I’m confident that this Tuesday we will be able to fly with clouds again!


I am looking forward to flying through clouds again. This is great news and it really shows what a bit of organizing can accomplish. Thanks to Asobo and MS for prioritizing this.



And you CS!


Great news seeing that the issue is “FIXED”.
I would like to thank you ChaoticSplendid for spearheading and organizing all of us in what seems like a successful effort.


I already have a new computer, but I’m glad our commitment made them fix this bug. Not everyone can buy new equipment right away


Terrible clouds

With the latest patch including a fix for this problem that has plagued us for nearly two months now, it has been confirmed by owners of Kepler and Maxwell 1.0 GPUs that the flashing clouds are gone now. Thanks to everyone for the reports!


We must thank u man :slight_smile: