Paid but nothing in content manager

I just finished the payment for add-on “Yosemite scenery” but notification show me “purchase failed”,afterward I checked content manager but nothing found,anyone has same experience and how to solve it?


I had it some weeks ago (Xbox Marketplace) get always the error message purchase failed (but I had a email from PayPal that it is paid)

After shutting down the Sim restarting the Xbox and starting sim again it worked - may it helps you as well ?


Thanks mate!I will try it later on!:handshake::handshake::handshake:

1 Like

If you are on a PC and using steam, make sure that the steam game overlay is enabled. Otherwise the purchase won’t work.

yea having the overlay enabled is not guaranteed either. I’ve made a successful purchase once a few months ago but my second attempt, also getting Yellowstone, failed. I still haven’t seen it available for me and the funds are gone from my Steam wallet. So I will likely be following this soon…

Same with me tonight,bought KBOS and nothing showing only usual message of it’s failed.
Personally i’m getting sick and tired of downloads failing,this didn’t happen until the last update and still isn’t working as it should.
About time they got this issue fixed!!

If you’re on Steam, putting funds in Steam wallet first does seem more reliable than the full process including PayPal.

1 Like

The exact same happend to me yesterday as I tried to purchase the Yellowstone airport. Contacted support but they haven’t replied yet (weekend).

I just had the same problem while purchasing EIDW and I’m on Steam wallet debited but the download failed and nothing in the content manager, after restarting the sim. I never had a problem until this purchase. Hoping for a quick response from customer service.

I submitted a support ticket as instructed by the link I posted earlier and a day and change later had the product approved for my account and just downloaded it. While it’s annoying I had to go through this extra process, at least it was handled well for me

Had it happen yesterday; I was mutlitasking at the time (can’t even spell the word. let alone do it) and the connection dropped. I have yet to find the item that I was downloading from Marketplace ; and if it was successful, like it said it was, how could it have been successful in 10 seconds? Don’t have time to chase MSF for $13; happy with their stock!
Going to pay closer attention going forward; it’s usually worked so effortlessly in the past.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.