Partial Volumetric Lighting

Please only post bugs that are new in this build, and tag your post with #pc and/or #xbox.

Are you on Xbox, Steam or Microsoft Store version?
Microsoft Store

Are you using Developer Mode or made changes in it?

Brief description of the issue:
Full volumetric shafts in the right-eye, but only partial, cut-off shafts in the left eye…creating a choppy, diamond-like pattern when viewing with both eyes.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:
A32NX in heavy fog or clouds, look over your left shoulder and check left wing flashing strobes.

PC specs and/or peripheral set up if relevant:
i9-10900KF 3090 Aero

I confirm. Same thing I can see flying in the default Cessna 172 (most likely all plains). In case with 172 I have landing and taxi light on, so it is not just strobes.
I am using Rift S. Both eyes the same.

1 Like

Same issue here with a Quest 2.
Issue not fixed.


Hello paisl3ypark, would you be able to share a video of the issue?

Did more testing in King Air.
The problem not just on the left side.
It is more (easily) visible on the left, since you are flying from the pilots seat.
Moving to the right seat you can see the same problem on the right.
The landing light and taxi light cones volumes are beautiful. The problem is at the end of the cone. Looks like the circle is showing triangles (3D mesh?).

EDIT: And some more testing on King Air. I can now see the problem with all lights: nav lights on each wing, recog on each wing, landing and taxi on the gear. The more you turn your head to one side (left if in the left seat) the more triangles you see (red for red nav light and white for white recog light on the left.) Landing and taxi on King Air on the nose gear, so the triangles at the end of the cone are on front.

EDIT: Additional info. Taxiing behind AI plane at night in low visibility. You can see the same problem with the AI planes (in this case the plane was passenger 2 engine jet) landing/taxi light.

Please let me know if you need more details.

Hello everyone that voted on this issue! We are wondering which headsets you are seeing this issue on (right now we have Oculus), so if you are currently experiencing it can you post your headset type for us to check?

Thank you so much.

Hello. I am using Oculus Rift S

Thank you for looking into the problem.

It may also be beneficial when testing to disable any external apps that may effect rendering to ensure nothing else is interfering.

would you please give an example

I don’t think I am running anything other than:

  • MSFS2020 (Tried with and without “Community” folder contents).
  • Oculus home (public test channel is on, so the latest beta)

Running on Nvidia gtx 1070ti with latest drivers (everything is set to default in NVidia control panel)
Window 11 Pro everything 100% up to date (os, drivers for all my PC components, latest BIOS for my motherboard, all windows store available updates).

I will try (later today) to make sure Oculus Debug Tool and/or similar programs I have are not being used.

I did try to set my volumetric clouds to different settings (from low to ultra), did not help.

I was thinking more along the lines of NIS/FSR upscalers/Reshade etc

Got it. Not using any.

I first encountered the issue using a Varjo Aero and no mods. I also have a Reverb G2 that I can test but unfortunately I am out of town until next week. Will attempt to provide a video of the issue if no solution is found by then. Thanks @OlieTsubasa443 and @Jummivana

Vive Pro 2 here on a RTX2080ti. Drivers 471.41

No triangles in the lighting with DX12 (Stuttering does occur), however in DX11 I do have them.

Here is a video I made.
Sorry for the quality, but you can see the problem.
You can clearly see the problem for the landing and taxi lights (towards the end of the video). I was trying to also show the nav lights, but because the video was recorded with a phone from my computer screen, the same problem with nav lights is not visible in the video.


Hello. I shared a video of the problem. Please see my last post.
Thank you.

I experienced some similar problems in 2D Mode.
FBW A32NX lights randomly turning invisible when flying through clouds and weird rendering bug as shown in the linked Video

I have been experiencing this with the Reverb G2 and RTX 3070.

I haven’t tried it in yet, but was definitely occuring in previous SU8 betas

I am experiencing this also with Rift S, RTX 2070 super

Still the same in

  • 1070ti with Nvidia 511.79 drivers with everything set to default.
  • Windows 11 Pro with the latest update:
    General Availability Channel 2022-02-15 22000.527 [KB5010414]

Reverb G2 with a RTX3090 on 511.23.