Performance drop 15-20% after World Update 3 (

I have just taken a 15 minute flight after applying this “fix” and observed no stutters. Will test more thoroughly next week when I have more time, in the meantime it would be interesting to see if it works for others…

Stuttering From Last Update | Fixed!!!

I have an i7 8700, 32gb RAM and a GTX 1080 Ti, fine specs for the sim, and it used to run at about 35-40 fps buttery smooth (for a sim) on (1080p) ULTRA with everything maxed out before world update 3. I noticed that one of my CPU cores was usually pegged at 100% and the GPU sitting at about 50-70%, the fps reader showed that I was Main thread limited, no problem, totally normal for FS2020.

BUT after the update, the sim dropped to 20fps in areas and planes I used to get 35fps or higher (I tested this objectively) and upon further inspection, I was mainthread limited BUT my CPU core was now maxing out at about 75%, GPU dropped to about 30-40%. I made sure I was on windows high performance mode etc etc but still no dice. Have a look, I used to get over 30fps here with this exact aircraft, now 20:

The issue here is the difference between 20 and 30 fps, IMO really makes it a bit annoying and sometimes borderline unplayable


Guys, I struck gold! I managed to solve my issue and got the framerate back up to where it used to be!

Keep in mind that I have no idea how this worked, or if it will work for all of you.

All I did was move all my community folder packages to a different place, start the sim, and set the graphics to the preset ULTRA, applied and saved, and then turned up the settings I wanted to turn up again (such that it was back to the way it was when I experienced low fps) and hey presto! Back to 35fps. I even moved all my community folder stuff back to where they were, and still no drop in fps! Running at >30 fps no problem, and its maxing out (100%) my CPU core AND GPU!

So it wasn’t a problem with community stuff… I think re-applying the graphics settings is what fixed it.

Again, this only worked for me and I have no idea why. Try it and see…

[edit] I know OP did re-apply his settings, and it still didn’t work… Maybe re-applying after SU3 helped? No idea…

Example of what I am seeing. Flight from KLBB → KSAA, so not a whole lot of scenery to have issues with. Started with FPS in the 50s on takeoff. This was fairly close to the airport, but the time I landed the Nvidia FPS counter was fluxuating between the teens and <10, which is the worst it has been (had to keep AP down to last 100 ft).

Looking at the task manager, this is consistent to what I always see when FPS drops. The last logical processor is always pegged. While not present in the screen shot, also seeing 1-3MB/s bandwidth usage, wonder if flying an area I hadn’t been before is causing it.


Exactly the same problem on my side. CPU usage at around 40% with the last core hitting the limit. Therefore limited by Mainthread. Seems like the CPU isn’t able to devide the workload even to all available cores.

1 Like

A new thread has recently been created pertaining to the implementation of optional beta versions of the game before the mandatory updates are rolled out. If this interest you then don’t hesitate to cast your vote

1 Like

Excellent initiative from “Unreality145”, it just got my vote!

Well… I tried the set settings to ultra then set to my desired configuration and unfortunately no luck…

What I did find is that my CPU usage was at 100%.

1 Like

I’d like to try this but I can’t get access to the Windows/Apps folder to get to the .exe. Appears to be owned by TrustedInstaller and it sounds like changing ownership can cause things in this folder to quit working. How can I get to the .exe to make these changes?

Wow!..what a difference. This was a big help. While I was pretty close to some of these settings, what smoother performance these tips gave.
Thanks much! :100: :+1: :+1: :slightly_smiling_face:


Great. Glad to see it helped!

1 Like

I did notice a post where someone took possession of the “Windowsapp” folder and it caused all kinds of problems with loading of programs and other things. I did not opt to do that. Still was good!

It’s also possible to access the FS folder without taking ownership of the entire WindowsApps folder. You just have to know the full path. That’s how I do it:

  • start a command prompt as administrator
  • cd \program files\windowsapps
  • dir *flight*
  • copy the folder name (in my case Microsoft.FlightSimulator_1.14.5.0_x64__8wekyb3d8bbwe)
  • in explorer enter c:\program files\windowsapps\ + paste the folder name
  • Now you can disable the full-screen optimizations in “Change settings for all users”

This seems a better way than messing with folder ownerships.

I did this after most updates, but I’m not really sure if it made a difference


Ok…so I take a short flight with the King air from KPVD to KBOS. Everything going fine, high settings like usual. 15 minute flight. Multiplayer, real weather, name tags all on with no issues all night. Start to see a little glitch, hear snapping with ATC talking heading into and getting near Boston. I quickly go into settings and turn off Photogrammetry and go back to flying. All went away. Landed with no other occurrences.

Thanks for that info it really helped as once I disabled full screen optimizations it improved my fps and smoothness when not in one of the 1/2 normal fps, or 2-10 fps areas!

While today’s patch restored performance lost with SU3, I’m still suffering from the perfomance issues that came along with WU3.


With as much as problems have been reported prior to the patch, I will say that the latest patch appears to have solved the manipulators issue I was seeing.

Same exact spawn in location at KMEM, same plane, same mods, now getting 50+ FPS vs teens last night. I even increased resolution scaling to 110% (running 3440x1440 with a 3090 FE) and still in the high 40s-50. Constantly GPU limited.

Semi-concerned this is the first time I’m hearing my GPU fan fire up. Seeing up to 75C GPU temp and max 104 GPU mem temp, need to see if there are concerns there. Of course, just in time for the 70+ weather to start rolling in.

EZEd1063 I have a 3090 and see my temps up in the 70s depending. If OC’d oh yes, I’ve hit 74 celcius. Mine usually runs around 64 degrees with 130% resolution scale 3440x1440. Everything ultra except shadows, it will take it but heat rises more. If I got to 150% scaling I can hit 70 degrees with no OC. The Vram temp does seema little high though. try it with your case open. Might have a ventilation issue

We now have an issue after this latest patch of CTD’s while in the flight planner
Was setting up flight plans and have dropped to desktop twice

Happiness is back. :star_struck: With the latest update and choosing the proper settings, the game runs smooth over London and KATL.