Persistent Stutters

I am looking for any kind of guidance I can get here, because the stutters in my game are really ruining the experience for me.

Let me first start by saying how incredible this sim is. I have been a big FS fan since '98 and have been playing every version ever since. What MS and Asobo have done is beyond incredible. I know folks have had download issues (I did too) and some other weird CTD issues (me too), but outside of these bugs, the sim itself is incredible.

The one thing that is killing me is the stutters. They are consistent and seem to change for me after every patch. I generally get pretty good fps and that is not the problem. I run the game in 4k and when it runs smooth, it is great! I generally get anywhere from 35-55 fps (depending on where I am) in 4k on mostly high/ultra settings)

My specs are:
32Gb DDR4@3200mhz
RTX 2080ti

I have tried everything I can find in these forums and on the internet, including, but not limited to:
*Fresh reinstall of windows
*Process Lasso
*Turned off Hyperthreading (this helped a good bit)
*Reinstalled the game (three times)
*Set windows to prioritize background apps
*.exe optimization fix
*changed every Nvidia CP setting I can find (one-by-one)
*Vsync (on/off) both in game and Nvidia CP

I feel like I have a good system that should not result in these stutters, but it is generally when I am turning and loading new trees/scenery. It has to be something with my PC (and a little bit the game not well optimized yet), as I see many others that do not have these issues with lower specs than me.

I am just at a total loss of what to do to fix these.


Certainly sounds like you’re having the same or similar issues as I am. I’ve got it running really well, good FPS etc but I’m getting stutters/lags/spikes after about 15 mins of flying. They do go away but then come back after a few minutes and it’s making it unplayable.
Like yourself, I’ve tried pretty much everything apart from a reinstall of Windows.
I have nothing on my PC apart from FS2020 on a separate drive to Windows. I’ve no antivirus and I’ve killed all unnecessary background tasks.
I’m at a loss and I can only think it’s the sim.
Strix 1080Ti, 8700k 4.9ghz, 32gb RAM.

Just a thought but have you overclocked your 2080Ti? I overclocked my 1080Ti using MSI AB and flight sim hated it…stuttered like crazy. Removed the overclock and it was fine. Well, apart from the issues above…

I’ve got a similar setup to you. The ONLY way I’ve found to get rid of stutters was to change my monitor refresh rate to 30hz, turn on Vsync in game (the 60 fps option), AND use RTSS scanline sync -1 with the 30hz refresh rate. If your monitor can’t go down to 30, use RTSS scanline sync x/2 -1. That will give you a frame cap of 30. I know it’s not ideal, but I like to maintain a consistent framerate, and 30 isn’t that bad, plus it allows me to turn some other settings up higher due to the extra headroom for the GPU.

I’m running a i7 10700K at 5.3, 32gb DDR4 at 3600 and a Titan X pascal. In any scenario, I’m typically GPU limited, unless it’s a busy high density airport. Unlocked, I typically get between 45-60fps depending on the situation, in which case it can easily drop into the 30’s. I’ve also disabled photogramatry because of the draw distance bug. Tweaked in the User.cfg, I’ve got the draw distance up to 3.5. In 99% of situations, I can maintain a constant 30fps in every plane, unless i get GPU limited by night lighting. I also had to put Ambient Occlusion to Low…that was really destroying frame times for me, for some reason.

Everything in the Nvidia control panel is default as it was giving weird blurries when i tried tinkering with it.

Try the 30hz thing and let me know how you get on.


Using RivaTuner (comes with Afterburner) to cap my fps at 30, plus turning off VSync in MSFS and its nice and smooth on my PC (i7-7700K and GTX1080Ti @1440p).

I have similar specs. Doesn’t seem like enough computer power to do 4k with high/ultra. I do high at 1440p and get 50-60fps no stutters. Also make sure you have the glass panel refresh set to high that gave me stutters otherwise.

check disk usage , I had some aweful stutters yesterday and noticed my HD was chriping away , I disabled Windoessearch and Searchindexer and it solved the issue…

I dont know how this applies to ssd or installed on other drives, but its worth trying.

That’s interesting, I’ve set mine to low…thinking that would help with any potential stutters. I’ll give high a go.

That was the point for me!
I have an old 60hz monitor (can’t go down to 30hz). In RTSS i set the fps limit to 30 and scanline sync to 29. (ingame vsync off)
90% of the stutters are gone!
During turns the movement is completely smooth and near the ground the trees don’t stutter as much as before.

Thank you so much for the tip!!!

I am not convinced that they have made the streaming scenery not cause FPS drops when network latency occurs. We are all used to giving system specs in terms of CPU/GPU/Memory and even storage – but with this sim, I think network speed and Internet speed are just as critical as CPU/GPU.


Wait, you did both? you set the FPS to 30 in RTSS AND scanline?? interesting, they shouldn’t work together at the same time, but hey, if it works, great!

Yes, i did both.
It just worked for me.

Interesting. Try putting scanline back to 0 and see if you get the same results

I did some test flights:

Frame lock: 30
Scanline sync: -29
Ground stutters: very small stutters, sometimes.
Stutters during turns: none

Frame lock: 30
Scanline sync: 0
Ground stutters: sometimes.
Stutters during turns: sometimes noticeable but negligible.

Frame lock: 30
Vsync: off or on.
Ground stutters: a lot near the ground, no stutters at higher altitude.
Stutters during turns: there is many during sharp turns.

Ground stutters: small stutters near the ground, no stutters at higher altitude.
Stutters during turns: small stutters.

Frame lock: 30
Vsync: on

Fame lock: 60
Vsync: on.
Ground stutters: small stutters near the ground, no stutters at higher altitude.
Stutters during turns: small stutters.

I think we can state: RTSS is the EMPEROR! :slightly_smiling_face:

(My config: i7 6700K, RTX 2070S, 16GB RAM, SSD)


interesting. where did you get the idea for scanline sync -29?


I have the same stuttering.

Please don’t mind me asking what is RTSS? Where can I find this and scanline sync


Gosh, thank you all for the feedback. I’ve tried it all. Still stutters. The RTSS setting to 30fps definitely helped, but I still have significant micro stutters. I just don’t get it.

1 Like

Just out of curiosity, does everyone have i7 processors? I feel like I’ve been noticing a trend that for some reason i7’s don’t seem to like this game (or vice versa)

interesting…i DO get some stutters while in the external view looking at about a 45 to 60 degree angle, but the FPS counter still says a solid 30. I dunno. I noticed that after updating to the new nvidia driver, not the newest one, but the hot fix one when the 3080 dropped. In the cockpit, it’s completely smooth.

Maybe it’s thermal throttling on your card? I upped my max temp to 90 degrees so it wouldn’t thermal throttle. I run a test when I’m getting stutters tho. I’ll bring the rendering down to the lowest in the FS settings (30), turn off any AA and see if there are stutters. That way i can know if the stuttering is due to the GPU or CPU. If I can fly in the same scenario and not get stutters with these lowered gpu settings, then I know it’s the gpu acting up. That can be easily remedied by lowering GPU intesive settings.

Rather than up your max temp, wouldn’t it be better to set your fan curve more aggressively?