Photogrammetry Scenery not fully rendering

When flying low over built up areas, I can see scenery like buildings and trees rendering as I fly over them, but only up to a point - they are never fully rendered, even after circling above them a few times and waiting a minute or two for the data to stream.

Below is an example (excuse the poor image quality but screenshots don’t work well with HDR):

My broadband connection isn’t the best (only 35mb/s) but didn’t think that would prevent scenery from loading fully, just that it would take longer to do so. Is there something I can change in the settings that would help? I’m not limiting my data usage currently.

Intel Core i7-9700k, 32GB 3200 RAM, GTX1080Ti

  • Microsoft Store
  • Ultra/4K
  • No Addins
  • Not using Developer Mode

Photogrammetry doesn’t look good up close. I’m not certain this is any worse than what it always looks like.

Ah really, I didn’t know that thanks. Would explain why it stops rendering. But looks really awful in places.

This is a shopping center a few miles from where I live. My feeling is that the scenery is intended to look good from a few thousand feet up, not a few feet.

Seems this sat data was acquired during the Halloween season…

1 Like

I noticed the blocky textures appear on loading screens as well, like the Paris discovery flight. You think they would have fixed it for the stills at least!

Theres no way it was supposed to look like this and indeed when i first bought this on release day on xbox PG didn’t look like this at all.

Was it in the same areas? I have screenshots from pre-release that look worse than the above, so it’s not a recent thing.

Well I’ve just flown London City to heathrow as a test. Photogrammetry was poor, it looked better with it off although it then doesn’t generate some bits of the map.

Tried turning online off and switching it on. But when landing at heathrow even the autopen buildings were not rendering, i had some houses and flat houses on the satellite image. Its usually fine around heathrow.

I just can’t fathom this game out. maybe if Asobo could actually clarify if photogrammetry or the servers had issues that would help?

I don’t get it, when you look at aerial views of the same area in Bing maps it looks fine. Is it because the engine is trying to render 3D structures from a 2D aerial image? But then at least the tops of the structures should look right.

Its a weird one.

I was flying up state New York to Stewart International yesterday and the autogen and bing maps looked really good and New York was okay-ish on PG.

But today in London - boom. Originally i started flying in that glider like plane that only does 80 knots over London, it was like it had been nuked.

I’ve been having the same issue but thought it was down to my laptop’s low end 1050ti graphics card not coping well. I’ve just built a £2000 pc with 12700k 3080 12gb and still getting the same issue along with multiple crashes to desktop. I am disappointed to say the least. I won’ recommending msfs to people anymore. It’s a pretty poor show I still love flying it but thought that throwing £2000 at the SIM would improve these issues

Sometimes areas just have poor photogrammetry quality. Sometimes areas have better photogrammetry quality but the servers/internet can’t keep up. Using the manual cache feature can help, but not if the photogrammetry data is poor.

I have a decent computer but very slow connection (4mb) which requires a lot of patience but I’ve been very pleased with the results…mostly. There still some elements to the program which remain a mystery. I wish Asobo or MS would release a primer as to the limitations and suggestions.

For the initial flight, I flew high and slow to get the entire landscape. Zig-zag back and forth when approaching large cities to let the program take small bites of the complex data involved. Then take a lower flight going back and forth over one small area. It usually cleans up after a dozen passes but sometimes hillsides can remain “smudged” due to a lack of mesh, or trees interfere with the roads and buildings underneath, and the program simply doesn’t know how to solve that. The program has to find and overwrite each section of tile it fixes.

One trick that seemed to work: Look out the left side and just circle for a while.
It should clear up eventually.

Photogrammertry requires a huge data set of high quality aerial images to render all the objects and this involves most of the world! Sometimes that data is not available or their servers get overloaded. I’m flying over Rio De Janeiro tonight but only got autogen with photoscenery, which still looks good but is not the real thing. No photgrammetry was downloaded unfortunately. Perhaps I’ve used up my data allowance or they are waiting for missing info before it is released. A city composed of half-autogen and half-photogrammetry would look odd.