Pilatus PC-6 Uncontrollable Water Taxi

Are you on Xbox, Steam or Microsoft Store version? Steam

Are you using Developer Mode or made changes in it? No

Brief description of the issue: Aircraft is uncontrollable in yaw axis while operating on surface of the water. With water rudder up, no yaw action can be achieved. With water rudder down, initial turn in can be achieved, however continued turn in beyond approx. 20 deg. is not possible and A/C enters essentially a side slip condition where course is not aligned with heading, before the aircraft eventually starts yawing in the opposite direction until rudder pressure is released. In forwards motion this effect occurs in both direction in yaw and is correlated with a rapid decrease in GS and increase in drag. When operating in reverse thrust, the AC enters a left hand yaw motion that cannot be arrested with any control inputs.

Lowing landing gear while on water allows for normal yaw movements, however GS is limited.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered: Multiple locations and flight model settings.

PC specs and/or peripheral set up if relevant:

Build Version # when you first started experiencing this issue:

For some reason the AP systems have become unresponsive and overall unreliable as well, have you found that? I’m on Xbox, I also find it pretty bad on the water.

This is a well posted issue, and seems to be a limitation of the sim in regards to float planes.
It isn’t unique to the Pilatus.
Do a search for “Water Taxi”

Other floatplanes seem ok in zero wind conditions, this seems to be a seperate issue than the over strength weathervaning issue reported on other AC.

1 Like

Haven’t tried AP sorry, just short flights.

1 Like

The Cub Crafter works great, haven’t tried the 172 in months but the Icon was good the last time I used it. I’d like to get a decent quality and decently fast 3rd Party sea capable plane but the physics as they are really make me hesitant to waste that kinda money. I’m sure there are plenty of us that would like to use seaplanes more but I definitely shy away.

Resolved as of SU 8, however using full lock will result in similar behaviour.

this is still a problem in the Asobo PC-6 floatplane - water rudder does NOT work after SU8

I join the discussion only now because I never flew the PC-6 floatplane before… It appears the problem comes from the aircraft itself, it is uncontrollable on water, with or without water rudder, making it impossible to take off. On the other hand, the C172 float plane works like a charm. It is not as controllable as on ground, which is normal, and behaves in a realistic way, as far as I can tell (I never flew a float plane in real life). I can easily land and take off with the C172.

It’s worth remembering that some of the historical float planes were often maneuvered by men in row boats, even steam tugs weren’t abundant everywhere.

Did they use row boats for take off? :slight_smile:
I’m joking of course, but what I mean here is that when the PC-6 aircraft is correctly aligned for take off and I set power, the aircraft turns and I can’t control it to keep it on a straight trajectory :frowning:
I am sure that even historical float planes didn’t behave this way.

1 Like

Now that would be worth watching

1 Like

Still bugged. Had the same issue for a couple years now.