PMDG DC-6 Gyropilot / Flight Plan Issue

I think I am doing something wrong but I cannot determine what it is…I have searched the forums but have not found a solution.

Flying the DC-6. I load a low altitude ILS flight plan from point A to point B, from the World Map. I start out at the gate cold and dark. When I get to the point of requesting clearances from ATC, I get a response that I am cleared for a touch & go, even though that is not my flight plan that is populated in the GPS. I have GPS selected using the CDI Button. After take-off, when I set the gyro pilot, I am unable to get the gyro pilot to follow my GPS flight plan. I cancel my flight & go landing intentions, toggle the CDI switch, toggle the gyro pilot selector switch, etc.

However, if I do everything the same but start my flight out “ready to fly” on the runway, ATC acknowledges my flight plan and I have no issues with the Gyro pilot. I am sure there is a procedure I am missing but I cannot seem to figure it out. Any suggestions or help would be appreciated! Thanks,


Hi Rob

Well I’m thinking it may be an issue with the In sim ATC at the moment
I’ve been flying the DC6 successfully for a few weeks now building my AirHauler2 empire lol
And planned ILS flight plans all ok …that was until today

Now whenever I got to where I’m cleared to the approach …for some reason I cannot get the DC6 to intercept and follow the flight plan …so I repeated a flight but in the stock C172 gps and had a similar issue today tried again this time I managed to intercept the approach but then the ATC disappeared lol I never heard from them again and had to fly the approach and land myself with no ATC.

Never had that before so assuming there’s an issue with in sim ATC logic today
My flights were with various aircraft but all 530/540 Garmins …,haven’t tried with G1000nxi yet but will see if I still have a similar result

Anyhow hope this is helpful
Ex Tenebris

Thanks Ex Tenebris! I am hoping that it is something I am doing wrong rather than a bug. It is easier to fix my procedures than to fix bugs! I appreciate your help!

ATC shouldn’t be able to affect what the gyropilot is doing. When you start up, make sure the entire gyropilot stays in its default “off” state.

Selector to Gyro (full left I think?), as it won’t engage with LOC or Approach selected. Mechanical disconnect off (down), gyropilot switch off (down), altitude hold should also be down at this point.

Especially make sure that altitude hold is off and it’s set to gyropilot and not LOC or Approach when you try to enable it, then select those after engaging everything.

Yup, I got that all down. I appreciate you taking me through it to confirm that I am doing it right.

I am assuming that since I develop the flight plan while in the World Map section, that I do not have to “file a flight plan” but since this problem only happens when I start out Cold & Dark, could it be that I have to manually file a flight plan? If this is the case, I am not sure how to manually file a plan? The flight plan is populated in the Garmin GPS.


It’s been so long since I’ve used stock ATC I won’t be much help. I remember not being able to plan touch and goes; are you flying VFR and requesting to depart to remain in pattern? That would make them clear you for touch and goes, I think, otherwise I wouldn’t think so.

Still don’t see how ATC could affect the gyropilot unless it’s knackering your flight plan, but if MSFS is loading it into the GPS ok it should be fine.

You may have hit on it!! I AM requesting to depart in pattern! I did not realize that would clear me for a touch and go. I hope it is something this simple!! Thanks!


The disappearing ATC is a “bug”. If you let your AI co-pilot handle the Comm radio, he has magical hearing and can hear the ATC requests that us mortals can’t.
You will be able to hear his responses and see those in the ATC window, so all won’t be lost.
You will then know what was requested of you.
A lot of folks have had luck with switching the ATC Com window and the Airplane com radio to COM2 when this happens.
Sometimes it takes a litlle playing around with the control buttons for both of them though, and remember to turn the airplanes COM2 radio volume up. When you get that to work, all is restored.

Thanks for info
Will give that a go
Is this a fairly new bug then, because up until today I’ve not had any issues ? Or is it scenery airport specific
Just wondering

It’s not new, but it is not scenery specific.
It can happen anytime, anywhere.
It affects some, others not so much.
My best guess, is it’s been around for 4-5 months now.
I get it about every 3rd or 4th flight!

Yep, that would do it, depart but remain in pattern means you’re staying in the local traffic pattern for practice. You’d want departing straight out or one of the cardinal directions to let ATC know you’re leaving.

Unfortunately this was not the problem…The only way the gyro pilot will lock onto my GPS flight plan is if I start on a runway, ready to take-off…


At this point I would head over to the official PMDG forums and see what they say.

Wait, check the intro manual in the documentation. I remember there being something about the GPS not working quite right and you had to jiggle the CDI/VLOC button a few times to get it to take.


Good suggestion…the PMDG Forum will be my next stop…Thanks.
I did try the jiggling / toggling of the CDI button and switching the selector switch. It has to be something with the DC-6 because I don’t have the same issue with other planes. Thanks again for all your suggestions!


Is it OK to mention there’s no such thing as an “ILS flight plan” or a “GPS flight plan?”

I understand what you’re asking but IFR (or VFR) flight plan would be the correct usage. No big deal and I’m nit-picking really hard here. :slight_smile:

No problem…I am learning. Thanks!


1 Like

After the Australia update I have the issue that when I am on gps inside that my vor 1 appears on the outside view on the compass, but it follows the gps plan. When I switch again the CDI switch back to vloc and back to gps, gps appears on the outside view but the planes does not follow the gps flightplan anymore.
That never happened before and I got this great majestic plane since day one of its release.
I make only cold starts with this plane.

But if I need to request permission to land, and I can’t press the button to do so. What to do then? The co-pilot is certainly good and hears well, but I can’t get him to request permission.