POI Very Late Rendering/Draw/Pop-In *SOLUTION FOR ASOBO TO FIX IN THIS THREAD*

*SOLUTION FOR ASOBO:

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
No

Are you using Developer Mode or made changes in it?
No

Brief description of the issue:
Devils Tower (USA) & the White Cliffs Of Dover (UK) are just two prime examples of incredibly poor “Render/Draw/Pop-in”, I have to be a few hundred feet away from them until they suddenly appear.

This is VERY immersion breaking, it happens in both Flat Screen & VR with TERRAIN LEVEL OF DETAIL at 200, OBJECTS LEVEL OF DETAIL at 200 and TERRAIN VECTOR DATA on ULTRA.
I have tried all manner of CACHE options (when that works…), and have UNLIMITED Data Bandwidth but nothing “fixes” this issue

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
Set Options to their Highest levels, fly over the two areas listed (there may well be others)

PC specs for those who want to assist (if not entered in your profile)

Did you submit this to Zendesk? If so, what is your ticket #?

I just took this Picture in Dev Mode, could it be that the LOD is simply incorrect? All the others start with a [1/3] but this LOD pops in when it loaded for the White Cliffs with [0/1]

URGENT ATTENTION PLEASE (regardless of “Votes” required), this Sim is sold with POIs as a Feature and they are clearly not working correctly.

3 Likes

Nice observation.

I am extracting the models now from the BGL to see if they literally just forgot to add more LOD levels and/or incorrect minsize parameters.

Update: Only a single LOD level confirmed…

And exported, only 1 LOD level.

image

I dont see any LOD entries in the XML file, so minsize should be 0.

4 Likes

@DronkeyKlong Excellent many thanks, check this out to perhaps compare:

Here’s Portsmouths Spinnaker Tower (POI), clearly it is visible a long way out and therefore “working correctly”

Edit: the first picture is a bit grainy but it was clearly visible in game from that distance unlike the aforementioned other two.

Can you please check Devils Tower and the Spinnaker Tower as well?

And with that model (spinnaker), it is the same, 1 LOD level.

I think we need to see at what distance this happens.

Also the tower is a waaaay smaller object than the cliffs.

Update: I would think for large custom models such as Dover or Devil’s Tower, there should be at least 2 LOD levels, probably 3-4 would be good.

Update2: Devil’s Tower also just have 1 LOD level.

Update3: Another thought. Objects just dont render at all from a certain distance and not even 200 OLOD gets that far.

1 Like

Thanks again @DronkeyKlong

I tried the Forth Rail Bridge (UK, Scotland) and that renders nice and far away and is a large structure.

So it’s either a missed and forgotten LOD or two for the Cliffs/Devils Tower (and god knows what other POIs…) or they just didn’t do them…which would be a major cause for concern IMO.

The main issue for me though is quite how this got through testing & released in this state in the first place, as an experienced Beta Tester LODs are one of the most basic Checklist Items before Release, so this is a massive oversight IMO and needs rectifying much sooner rather than later - but seeing as Devils Tower has been out for so long now I’m not holding much hope :frowning:

2 Likes

I had this issue too with cliff palace (USA update). I would appreciate if you can see the LOD levels in it too.

I don’t understand how this things pass quality tests…

I have not seen evidence of any POI models with more than 1 LOD level in both the Microsoft POI packages for USA and UK. I think this is done external from Asobo.

Update: Correction: The aircraft from the graveyard has multple LOD levels. Also an oilrig. So there are models with multiple LOD levels, not going to look further.

1 Like

What would you test for in Blender?

My bad. I thought you was using blender to see the LOD levels

Thats fine your research has led us to pinpoint the issue, many thanks.

Asobo now need to fix this and I stress again this CANNOT be about getting a required number of Votes, these Bugs/Issues should be a priority regardless of the number of people “affected”.

4 Likes

Same, just 1 LOD level

But as I was looking for it (was named mesa), there are a lot of models with multiple LOD levels. So was this just an oversight? Or was it pulled due to size? Is there an issue when objects have 1 LOD level that it has some implicit minSize?

1 Like

I don’t have any idea. But is curious that those models are the ones that don’t spawn until you are close enough.

I hope @Jummivana can give this some visibility.

I am going to do a test by explicitly adding a single LOD entry in the model.xml to see if it behaves different.

3 Likes

Nailed it! On the left is actual, on the right is same model with LOD entry.

My XML

<ModelInfo version="1.1" name="DoverLOD" guid="{424af5ee-7b8d-4eaf-84ec-1593a95f36cb}">
	<LODS>
		<LOD minSize="1" ModelFile="doverlod.gltf" />
	</LODS>
</ModelInfo>

From testing it exposed the actual issue.

Models without LOD entries will only load when you around 1nm from it, then moving away, it will actually stay loaded till quite far away.

Omitting minSize in LOD does not change anything.

Edit: All testing done at 200 OLOD.

5 Likes

Nice catch. I’m surprised no one else has suffered this issue.

Maybe just want so noticable with smaller models. Or it could be a regression? Does it behave any diff in cliff palace between the updates?

I had the issues with cliff palace on the previous version. Didn’t tried in this one yet. But I guess is the same. So it’s something coming from a earlier point. That’s for sure.

1 Like

Yep. That’s pretty much what I assumed. What is odd however is it doesn’t unload as you fly away from it. Which is nice because the cliffs look great from a distance.