[Polls] 40th Anniversary Edition/Sim Update 11 Discussion

Lol… I had to reboot to get the MS Store to correctly indicate that I did in fact own it after all. That’s the only solution. Reboot.


I just rebooted my Pc and opened the Microsoft store, clicked get updates on the right and now it appears to be downloading the update, so definitely do that if yours isn’t working.

Doing now in Portugal (Premium Edition - Steam - around 22 GB of download to 40GB final disk used)

40GB is the disk space requirement, update is only 21.58.

Thanks. I deleted my ‘rolling cache’ file and that seems to have fixed it. Cheers.

Any release notes?

They are posted.


No issues with update process, 20 minutes start to finish.

Time to check Content Manager.


Ah thank you!

1 Like

Once again, MicroSobo never fails to bring a tear to my eye with their trailers. Absolutely well done and stunning as always.


At work, so how is Kai Tak going to work? Replacement area buildings on approch or is it mission only

1.6GB of updates in Content Manager.

1 Like

Correct, I have amended my post now

It’s amazing what we get.

1 Like

Does anyone list what we get?

Check the release notes, link posted above.

Poll items will not accept input, Can’t vote. PC


So why doesn’t it tell you much additional space you need!!

I mean, seriously, how hard can it be? It’s clearly already done the calculation for it to be able to determine that there isn’t enough space. All it needs to do is display the information.

This is just soooo Microsoft.

1 Like

Found it, holy schnikies… Only thing I’m not necessarily ‘getting’ is princess Juliana overlap. Mainly because I’d lose grand case if I run the MS version

Interesting, after finishing the updates and loading into an airport to look around. I went back to main menu and was told there were essential packages that needed to be updated.

The sim is essentially restarting now, but no update.

However, I do see the A310 in the marketplace now, which it wasn’t a few minutes ago… And I was able to use it (that’s what I tested with).