Poor Graphics on the 4090

Hi all, I’m still getting poor graphics with shimmering, flickering and image quality. I’m at a loss now where to go? I’ve uploaded images for reference including a benchtest result, which i still don’t think is very good given my pc specs? Any suggestions?

4090
ryzen 7900x
64gb/5200mhz ram







I would seriously consider giving DLSS Super Resolution a try instead of TAA. Or DLAA if your machine can handle it at the higher resolution (not suitable for VR really as it’s pretty heavy). TAA causes the shimmering for me too if I am reading your description as I imagine.

There is also a “hidden” Ultra Quality DLSS setting.
Here is a guide of how to set it up (quite a few steps and a couple of extra things you need to download, but all the info is here if you follow it closely):

You will need NV Profile Inspector and also find the ISSUE LINK # and new extra file you need from that which the guy mentioned in the video (and how to find it / where to put it):

ALSO remember to replace (manually or with the free DLSS Swapper App below) the DLL file (3.5.10) to get the latest DLSS benefits. It is MUCH improved.

If you go with DLAA then you don’t need that file for Ultra Resolution.

2 Likes

Thanks ill do some homework on it now :+1:

1 Like

Also, are you really running only 1080p with an RTX4090?

I suppose first you could try doubling the Render Resolution there and see what happens with the shimmering - but still DLSS or DLAA looks way more natural to me and just as good with the 3.5.10 dll replacement.

3 Likes

Not sure any of this matters, but…

  • NVCP shows DX12. Sim shows DX11
  • Set Anisotropic Filtering to 16X in NVCP. Turn it off in sim.
  • Try DDU to remove existing nVidia driver, then clean install 536.67
  • I second Baracus250’s suggestions re: Profile Inspector and DLSS-Swapper.

1080P makes your system CPU bottlenecked. You should at least invest in a good 2K monitor - 4K if possible. That will unleash the power of that expensive GPU.

I’ve followed that guy on youtube and set my settings as his. I’ve also cranked the render res to max (200) and so far its looking loads better. Still running on TAA tho, as i found slight shimmering on dlss.

I will be upgrading for a new monitor at some point. Im thinking ultrawide over 4k, but for now 1080p will have to do.

Thanks for the advise👍

1 Like

Good stuff. :+1:

Yeah but, with the 3.5.10 dll it is seriously LOADS better. The one included in MSFS is really really old (2.5.2 I think) so it’s really behind where the tech is now. Really worth a try, and it is less resource intensive than TAA so you would likely be able to max out everything else, especially at 1080.

To explain (bearing in mind I am an idiot)… the DLSS means Deep LEARNING Super Sampling. But the LEARNING is not something that automatically improves your own installation over time. The learning is something they gather (in some way, I really don’t know how, from some kind of neural network from users machines globally?!) but anyway, the new things they have LEARNED about how to best upscale to retain image quality in various scenarios is included in the code they put into the future versions of that DLL that drives it all.

If you don’t update that, you are not getting the benefit of the new AI learning.

I did download to 3.5.10 and tryed dlss on ultra quality and i still got some slight shimmerings/flickering.

I also tried it on my pico 4 vr and the quality isnt good still, but i’ll look into that further

Render scaling needs to go above 100% so that supersampling AA is enabled. That’s why quality looks so ugly. You don’t need 200% on high native resolutions but the higher the better, specially for native 1080p. I wouldn’t go below 125% in any case.

4090 can work well even with high resolutions, high render scaling and demanding AA like TAA so ignore DLSS and stick to TAA + medium or high render scaling. You will get the best results.

Cheers

2 Likes

Yup, put TAA on and set render resolution slider to 105%. Works wonders.

1 Like

so the PC seems to playing up again? take a look at the frame rate indicator bottom right. image 1 Innsbruck, image 2 climb, image 3 Gatwick. something is seriously blocking the 4090 from doing its thing and im at a loss with it all, A/C FBW320



Get a 4K monitor ASAP. Running a 4090 at 1080p is kind of pointless and won’t be helping anything. You may find all your problems go away if you get a full 4K monitor. These monstrously powerful GPU’s are not meant for 1080p gaming.

1 Like

4k or ultrawide? Im split between the two.

The Unigine screenshot looks like it’s detecting the CPU’s integrated graphics? If so it might be worth disabling that in BIOS to make sure MSFS isn’t actually running on it.

Edit: Don’t think there’s anything to be concerned about with that benchmark result by the way. Here’s mine for comparison:

I’ve disabled the onboard gpu via device manager, but i could go to bios and do it that way. Oh ok, thanks for the screenshot.

Personal preference here for ultrawide as it allows for wider POV, which is better for your peripheral view in the sim and gives better sensation of speed.

Others dislike ultrawide for the ‘letterbox’ view of the sim. Plus, it’s harder to see out of the windshield and view the bottom part of the overhead panel simultaneously.

Another vote for ultrawide way better view. Also, you should not have to disable your IGPU.

I am swayimg towards ultrawide as others have said you get a better sim experience. What’s the resolution like on them?

Oh ok, i disabled it anyway incase there was conflict between the two. Still unsure why im getting poor fps and performance tho

Resolution is great. Mine is 5120 x 1440.

1 Like