Poor performance as time goes on


I’m hoping someone could help resolve this issue for me, I’ve been having it since prior SU5 and also during SU5. My simulator seems to lose performance as time goes on, especially from the two and a half hour mark onwards whilst flying. I can go from 50FPS on takeoff to nearly 15/20FPS whilst at cruise some two and a half hours later, with no clouds around or anything.

A check of my usage shows CPU at 37% utilisation, and GPU at 38% utilisation. My RAM is well within its limits, so it’s not a hardware issue.

Changing the simulation graphics makes no difference, including dropping it to 480p at the lowest rendering resolution. It does this across all planes in the sim, and I cannot for the life of me figure it out. Like I said changing graphics settings doesn’t change the performance at all, which just shouldn’t be possible. Any help would be greatly appreciated.

Had the same problem yesterday.
Main Thread & Manipulators going black while CPU is just at 10%.
Saving & Reloading flight didn’t help. Maybe a memory Leak somewhere?

Sounds like classic vram overutilization. Check and see what happens to your video memory through a flight

Same thing happened to me I tried to do a 6 hour flight, by the 4th hour i was capped at 30 fps and by the 5th hour i was capped at 22 fps.

I’ll bet you have Real-Time Online traffic on.

As you see the frame rate decrease in flight, switch it off and your frame rate will return instantly. After you switch it off and regain your FPS, you can switch it back on mid flight.

I had exactly the same problem.

No I don’t sadly, no Online Traffic, no AI, no Multiplayer

Oh I’m sorry I couldn’t hep.

Did a long flight today with FBW A320 and hadn’t these problems like yesterday with CS777-200.
Must be something broken with the plane…

Oh no, I’ve had the exact same issue since the beginning, haven’t been able to do a single flight for more than 4h before going down in the single digit FPS. I would have thought that SU5 would have fixed this issue at last, but apparently not, I can’t test at the moment but I will soon.

I literally just changed my resolution from 1440p to 1080p and my frame rate didn’t increase at all not even by a single frame, what a joke, I just don’t understand this - it’s not a memory leak either as all the RAM is normal.

What are your specs if you don’t mind me asking?

intel i9-9900K CPU @ 3.60GHz
Nvidia RTX 2080 8GB

I have an old i7-4790K (so LGA1150 MB), a 2060 6GB, an SSD and 16GB DDR3.

Hi, did you have any luck with this. I am facing an issue in some cities (experienced it with Sydney and Tokyo) where after takeoff the FPS went from 40 to 9. This has only happened since the latest update. My CPU, GPU, RAM and VRAM usage are really low (around 30-40%) and the fps tanks. If I skip to a later part of the flight the FPS recovers fully.
I have a i7 4790k with 32gb of ram on an RTX 3070

For further information, this is what FPS counter in Dev Mode in showing me.

These are my respective CPU and GPU stats in Task Manager, so as you can see I can’t tell why this is happening. I can confirm there’s no temperature throttling occurring.

But there is definitely something up AND important thing to note, it is really TIME dependant, not distance. I’ve done tests where I was just sitting on a runway in the Sahara for 8 hours, and sure enough, my FPS went from 30 (in VR) to under 10, memory usage was higher although I didn’t move a centimeter. At the beginning I was limited by GPU but at the end I am limited by Main Thread.

Now even weirder, sometimes, going in the menu or disabling/enable online functionality brings the FPS right back, but it often doesn’t work, the online disable/enable worked only once for example.

Yep, going into the menu for me brings my FPS to 100+

also when you go back in game? (it is what I initially meant, like sometimes going in the menu and back in the game restores my fps, after a LOONG freeze and some memory being instantly freed.)

I already made a post on the issue, and there are other threads about it as well

If I were home I would try a complete reinstall of the sim but I have limited data right now.