Poor performance on the ground

My guess is that with every WU there were also some core sim changes pushed. However when doing this test the core changes stay and only the actual WU content can be uninstalled and reinstalled.

1 Like

I was hoping deleting the world update content would make a difference, but it did not.

After deleting everything except USA content, I am still seeing 2-5 fps on the ground. The CPU utilization spikes to 100% (and GPU utilization troughs) are still present (main thread limited), causing lengthy stutters.

Turning off photogrammetry resolves the issue and 30 FPS return (GPU limited). The testing location is YARN, Alice Springs Australia (no photogrammetry nearby). Cessna 172 with no live traffic.

To be clear, this issue originally appeared with WU6/offscreen terrain pre-caching.

1 Like

Hi @GloucesterRoad7, do you mean you had this area manually cached? If so, do you still have it manually cached?

No, I have never used the manual cache functionality. My comment about WU6/offscreen terrain precaching slider was to describe the timeline when the poor performance on the ground began (after taking WU6). Thanks!

1 Like

Yes, this thread has melded into all sorts of issues… the problem you are having is the main photogrammetry issue that has plagued certain users after WU 6, 7 in this thread. I have had this photogrammetry issue along with others and have tried everything under the sun. Until this bug/issue is acknowledged by MS/Asobo, the only resolve is a reinstall of windows.

1 Like

Hi @Hester40MT thanks for pushing this up.
Can easily confirm this.
CYTZ, C152, MP off, Live traffic on, photogrammetry on, empty community folder. all WU’s installed was getting 25-28 fps on the ground.
Removed all WU’s. Restarted sim. Same settings. Getting 58-62 fps.
Interestingly, installed USA, didn’t see much if any drop.
Installed nordics, also didn’t see much if any drop, so confirming @f14billy findings. So I’m thinking its one of the other ones, but haven’t had time to test the others.

2 Likes

Did you try restarting the sim after uninstalling the WUs? in my case I would not see a change in performance until after restarting it.

1 Like

Yes, and I actually rebooted as well, since there appears to be some Windows OS component to the issue.

Uninstalled all WUs and the sim, reinstalled sim. Still the exact same problem (CPU/main thread limited and 2-5 fps) The only thing I haven’t tried and will not try is reinstalling the OS. Photogrammetry seems to cut off the GPU alltogether on my system.

There seems to be solid evidence that uninstalling certain World Updates make a huge difference for some, which is very constructive feedback that Asobo need to see.

However, given the length of this thread, and the countless arguments in all directions, I think it would be both wise and appropriate to Zendesk it and open a new thread. I don’t have serious problems with FPS or stuttering myself, so I’m probably not the right person to do that.

1 Like

That precache slider is more trouble than it’s worth, try pushing it to ultra (which should effectively be off). IMO it only seems to affect culling and does nothing against popping-in anyway.

1 Like

I had the same experience as you, the problem persisted even after a clean installed vanilla game, whether I was standing at a large airport, or a grass strip in the middle of nowhere, the only thing that solved the problem for me was a clean installation of Windows from an ISO file, after I did that I have had no problems with stuttering or fps loss at all.

The problem is LOD, no windows. If you reduce the LOD to minimum the Stutters are gone on the ground. I have everything on ULTRA, including Resolution at 150 with great FPS and as soon as I increase LOD the stutters appear (and when I say increase is hardly 50)

Is defo a bug, reinstalling windows didnt help. The CPU is not maxed out is actually LOCKED by the sim and produces stutters.

I run LOD 200 at Ultra and have no stuttering at all, there is no problem with Lod for me since I reinstall Windows.

1 Like

I have zero stutters after windows reintall as well. With LOD at 250… never get below 30fps now, no matter where. Again… maybe LOD helps with some stutters but for this specific photogrammetry bug only windows reinstall works.

1 Like

Seems to me that there are probably two different performance issues since SU7:

  1. Photogrammetry drops the FPS to single digits and seems to be fixable only by a reinstall of windows.

  2. Certain World Updates decrease performance on the ground with Photogrammetry on significantly but not to single digits. And this is the one I am experiencing and seems to be worked around by uninstalling all WUs except USA. Nordics lower the FPS a little but not as much as the others.

2 Likes

Hello !

Some test this evening regarding the World update:

Pc Win-10 21H2; proc i7-9700K, 32 GB RAM; RTX-2070
Cessna C172 at KHHR runway 25; at 12.00; Clear sky; traffic OFF; Photogrametry ON (last test with pg off and WU I jap)

With all world update : 30 fps

Without all World update: 61 fps

With WU-VI Ger-Aus: 48 fps

With WU-V Nordic : 60 fps … no perf issue

With WU IV France Benelux: 46 fps :

With WU-III UK : 47 fps

With WU-II: USA : 60 fps, no perf issue

With WU-I Japan : 46 fps

And With photogrametry OFF with only WU-I jap : 69 fps

9 Likes

So…
No perf issue with WU-II USA and WU-V Nordic
Same fps loss with WU I Jap ; III UK ; IV France Benelux ; VI-Ger-Aus-Swiss

Thank you for testing! Hopefully, Asobo can resolve this issue with haste!

2 Likes

I wonder if the re-install of Windows is actually just resetting something that was changed in the past either intentionally or inadvertently and that change caused problems. I remember doing that when I tried VR 6 or 8 months ago - I probably made a hundred changes chasing decent performance, which I never got. After that I had problems in 2D, so I reinstalled Windows and that cleared things up.

Also, I have only WU II: USA and I haven’t had any performance problems. (RTX3070, 32gb, i9-10850k, everything on Ultra).

1 Like