Post SU10 VR Performance

I’ve noticed a nice little performance boost in VR from SU10 which allowed for some TAA head space.
I’m now able to push from (SU9) 90 to (SU10) 100 TAA and OpenXR Toolkit FSR 100 with1.3 SS on my Rift S via Oculus Debug Tool using DX11 in VR. Don’t care to use DX12 at all for now. The image has never looked this crisp for me until now and the lighting seems better in SU10.
Great crisp image and performance on my older 1080ti/8700k system.
My settings combo really is a sweet spot in the Rift S every update since SU6 has allowed me to push more VR pixels. The coastal terrain warp issue seems to be fixed and I’m not noticing any pixelated clouds yet.


You think your image looks crisp… You’ll explode with joy when you try the Reverb G2. I know I did lol.


I own the Quest, Two Rift S, Samsung O+, G1 & G2.
I really prefer the Rift S over them all, so much I bought a second one. Oculus really put alot of genius into Rift S’s pixel display pattern.


You`ll go nuclear if you try the pimax 8kx kdmas, I love mine and could not go back to binocular vision after 200 degree fov.


So. hardware: i712700kf 32gbddr5 rtx3080 Oculus CV1

performance in general seems better than SU9 for sure. when working correctly… However I am experiencing a game breaking bug. This is with or without mods in Community folder, I call it the 100% gfx card bug which results in abysmal FPS. unplayable.

I used to get this on final at “some” airports during SU9. never found the cause. however since SU10 I now get this bug just switching between VR and 2d. The bug does not disappear until entering Main Menu, sometime it consists even at the Main Menu to which I have to restart the sim.

So I have now found out if i make sure my Oculus CV1 is running before starting the sim, and make sure it does not shut down I can avoid the bug. If i at any point switch back to 2D the bug activates. 100% graphics usage and terrible FPS even while 2d, to which I know my usage should be around 60% in 2d due to only running 1080p. mostly high/ultra settings in game, also using OpenXR toolkit and Oculus Tray Tool for 1.5SS. I have managed to get 3 1/4’s of a flight in so far stable with great FPS to which then approaching LOC on arrival airport I get the 100% gfx bug again. So I have not had a full flight yet in SU10 with stable FPS throughout. likewise if I fly 2D. So unhappy right now I have been using the sim since release and never had such a bad experiance. Also using GSX has given me the 100% gfx bug in 2D just sitting on the ground loading Pax… something is not right. any help is welcome because I just cant get a good flight in. It seems as soon as the game has a hiccup BOOM 100% bug. restart sim needed.

1 Like

Varjo Aero, 3080ti, latest studio driver, dx12. High/ultra setting mix. Mindblowing buttery smooth and crisp. I feel like a fanboy when reading all the complaints.

1 Like

I’m also experiencing this weird bug. I use an HP Reverb G2. First time I go into VR and start a flight FPS seems to be normal. If I exit VR back to 2D and back to VR then the FPS are single digits. No way to overcome this, back and froth between 2D and VR still results in bad FPS.
I run a GTX3080. Anyone else noticed that?



Yep, I’m noticing this bug as well.

I’m using a Quest 2 with an RTX3070. I never had any issues prior to SU10.

I hope to do some sim flying tomorrow and will run some more tests whilst I’m at it.


1 Like

Same issue, what helps for me is actually fully closing WMR, then 2D goes back to normal, but there is chance of crashing…

Same issues with Quest 2 on MSFS (PC link or Air Link) where switching in and out of VR during a flight borks BOTH the Quest 2 (Oculus app NOT the native headset) AND MSFS FPS. My headset goes blank black or shows a once very few seconds partial image and the MSFS is down to 1-8FPS in 2D.

A fix would be great!


I’ve noticed an amazing performance uplift.
Today for me was the first time i have been absolutely blown away by vr, tu10, dlss and the new Nvidia studio driver have finally put a smile on my face, for the first time in about 8 months its been nice being able to fly low level in an f-18 feeling the speed without out constant stutter, i cant believe what a difference this new update and driver have made its been awesome.
My system Intel 12 Core i7 12700K Alder Lake standard clock, asus rog strix mother board, 32gb fast 14clk memory, founders 3070 ti, Quest 2 with link cable.
I use msi after burner for undervolting but with small overclock and in the quest debug tool have asw off and 500mb set, in fs i set dlss balanced and a mixture of medium and high settings.
Hags off! Nvidia control panel vsync Fast and let the program decide.
Before i updated to the new studio driver when ever i turned my head frames would drop from 37 to 18 and be very laggy now im getting 47 frames constant even when moving my head in any direction, its so smooth it actually feels like flying.
Im also using Directx 12.
Cheers to all concerned it was worth the wait, thanx.



I can confirm kind of the same on a 3070Ti and Oculus 2. So far I’ve only tried it using flying a A32NX.

As soon as I turn on VR I have either a black screen and or the hourglass animating.
And if I remove my headset and put it aside I can see that it starts working again on my screen (still in VR mode)

Also it’s connected to complex airports. So if I take off from a complex airport (where I must avoid VR in order to get airborne) . When I’m reaching cruise level it starts working again and it does so when I land on one of the default airports.

Some additional notes

  • I’m using Hardware-Accelereated GPU Scheduling (turning it off for sure won’t change this)
  • In the VR Settings I have a blank field in “Global Render Quality” setting.
  • Latest Nvidia Driver
  • Did not empty the community folder while installing SU10
  • Have tried the Beta version of Oculus Link
1 Like

I have been flying VR the last two weeks with DX12 on my HP G2 and 3080Ti. Full immersion test, no frame counters allowed. It is very, very solid now. I don’t have OXRTK installed anymore.

1 Like

Same experience here. When the fps drops I just put aside the Quest2 until seeing fluid image on the flat screen (always in VR). Seems a common issue.

How long do you put it aside for? Do you quit any oculus or msfs apps?


So far Rick I just keep it aside until I’m clear of “memory consuming areas” like a complex airport. Sometimes I try it too early and then I put it aside again.

Usually when it starts working again it lasts all the way to landing and taxing. I might have to restart the flight before T/D which improves the performance (restarting a A32NX-flight is though not supported by FBW and e.g. the landing gear is extended and not that easy to retract etc). And sometimes I also restart Oculus( closing the link program, deleting the OVRServer_x64.exe, starting the link program, putting on the headset and click myself back, and the last thing, turning on the VR)


It´s kindda funny, I just put the Quest2 aside, and then I put up the oculus app, or the Oculus tray Tool up to the front, then I minimize that app and abracadabra!, fps are running up in the simulator… No cientific explanation… believe it or not

So, I downloaded the Nvidia Geforce experiance beta, updated to studio driver, switched to DX12, disabled Open XR toolkit. NO DIFFERENCE! still getting 100% gfx usage bug terrible FPS when switching between 2D and VR. (see specs and original issue above) So now the only thing to try is updating OpenXR toolkit to 1.2 and trying to roll back on Win 11 update. (XXXXX73)

Yes, i also had this before SU10, but i had a work around.
Restarting MSFS after it first loaded completely, but now it’s not working anymore.

I notice when the intro (Aboso and Xbox logo) is sluggish, i have te restart MSFS.

But after SU10 it’s sluggish al the time. Can’t past 20 FPS in the main screen with VR on. With VR of it’s over 300.

So so so frustrated… Really thinking about dropping MSFS for Xplane 12, but i love it so much…
SteamVR - Virtual Desktop
3080 - AMD5800x3d

Airlink on the Quest 2 seems to be working fine for me at the moment, however, I can no longer achieve a stable connection with Oculus link. Prior to SU10, I only ever used the link cable and it was great.

Now, the link cable creates a stuttering mess within minutes and never recovers. I have to force exit the Oculus app and reconnect.