Post-SU6 Update - Flight "blue progress bar" loads to 100% but flight won't start

Please tag your post with #pc and/or #xbox.
PC

Are you on Steam or Microsoft Store version?
Microsoft Store

Are you using Developer Mode or made changes in it?
No

Brief description of the issue:
SU6 update completed successfully. I set up a quick flight and it appears to load completely, based on blue progress line moving all the way across the screen but flight won’t load/start. Stuck there. Music continues playing…

Provide Screenshot(s)/video(s) of the issue encountered:
None required.

Detail steps to reproduce the issue encountered:
See above. I end up having to close the sim, as it won’t completely load the flight, even after over an hour of waiting. I searched but could not find someone having a similar issue.

PC specs and/or peripheral set up of relevant:
PC specs are fine.

Build Version # when you first started experiencing this issue:
MSFS 1.20.6.0

Do you have any mods in your community folder?

I’ve had exactly the same issue - removing them all (bar the specific ones I wanted for that particular flight) solved it for me.

Add-ons which are completely irrelevant to the flight you’re trying to load can cause this - I had an issue with an add-on aircraft causing this a few months back, even though I hadn’t chosen that aircraft to fly in on the flight I was trying to load up.

Quite how I’m now supposed to pin-point which of my 250 add-ons is causing this is anyone’s guess…

Thank you, DressierCone45. I have heard that mods can cause issues and I should have started with that first.

I resolved it (I hope) by first loading a training flight (which did load fully) then exiting. I then loaded the free flight, which this time loaded fully and worked.

Another tip that I do when this happens to me – I delete my content.xml file (it rebuilds every time you run MSFS). That always helps as well.

1 Like

Thank you, moxiejeff!

Thanks you, and that’s a great tip - this worked for me. Now I get to fly at least a little tonight.


Hi i too face this same issue its happenes to discovery flights particularly Paris and new york

Tried in safe mode…same things happne there too with community folder empty

Any workaround for this issue?

It happened to me again and I followed the advice given by fellow simmers:

  1. Clean out the mods in the Community Folder.
  2. Remove the content.xml file.

As soon as I did that, the sim worked perfectly. Thanks again DressierCone45 and moxiefeff!

So you are not supposed to use mods that you pay for for it to load? Deleting content.xml doesnt work for me… i have CAS WSSS. and it wont load.

Well that’s the annoying thing, the problem doesn’t seem to actually be with mods nessicerily as I can sometimes turn LOD right down or deleting old cache files and be loaded within the standard few minutes, then other times the exact same thing will just not load even after 30 minutes. Given how many there are of us I also highly doubt is a common thread as some who don’t use mods are reporting the same.

We just have to hope that the problem is fixed, which is with the the sim so falls on Microsoft/Asobo’s end, and try the workarounds listed just above in the meantime to fly.

Just an update: The problem reared its ugly head again. The two options provided worked only the first time. When I tried to start a flight earlier today, it wouldn’t enter the flight, just stuck in the blue progress bar section. Later in the day I tried again and it then worked. There’s no rhyme or reason here…

1 Like

I also have the same problem. But not often. Once I get stuck in the blue bar, I will restart the game… Then I can pass the blue bar normally… The maximum probability of this occurs is usually the first time I run the game after my computer is turned on. No matter what. This problem occurs with or without MOD installed

Mine only gets to a little over 50% loaded before it completely stops. This is after a new reinstall of the sim with an empty community folder.

I have spent 2 days troubleshooting this.
I also noticed that by removing any payware cityscape or city pack will always help in this case but it’s not a solution as this means we can’t use something that we have purchased.
I also noticed that (atleast for my case) uninstalling REX airport texutre and Mash packages from Orbx Central will help. Please also delete the REX folder in the community folder after uninstall from Orbx Central. Some of the packages especially those bought from marketplace are usually found under packages\official\steam (for steam users).
Delete also content.xml while you are at it.
Re-installing the city packages again from MSFS content manager will work while in session but will stop working after relaunching MSFS.
Btw, I only have this issue recently after update 6.

I had this issue for a day or so, for me the fix was verifying the files for my orbx cityscape scenery. No issues as of yet after doing this

I’ve been slowly reintroducing the mods, one at a time, beginning with the paid ones first. So far, LFVR’s KMIA and FSdreamteam’s Key West airports work fine and cause no issues.

Next are the several Orbx airports. I’ll finish up with free mods.

the loading issue is rather random now for me but happens daily. I turned developer mode on now. When it hangs at loading, i will use the teleport console to go somewhere and back to main menu and reload again. This way i avoid the long wait of relaunching the game. However on one occasion after doing this, the whole game hanged midflight, not even CTD, had to hard restart the pc.
Another thing is that I notied in the developer windows console, there are usually 2-3K lines of error messages. Not sure if this is common.

I have the same problem as you. And it happens every time the game is run for the first time after booting. The game can be restored to normal after forcibly closing the game and restarting the game. After a few days of observation, it turned out to be rex simulations-misc- The real-global-airport-textures MOD conflicts. After removing this MOD, this problem never happened again… Currently I use ZINERTEK, a similar MOD, to replace rex simulations-misc-real-global-airport-textures .This problem hasn’t happened again so far…

I initially thought it was REX too after removing it i still couldnt resolved it. I already have ZInertek installed in the first place. My community folder is very lean at the moment with just couple of payware that i have regularly use. The fact is that I am able to load now (after the teleport work around i mentioned before) i will start to introduce other mods. I suspect this will not be resolved any time sooner as Asobo will point their fingers at the sellers of payware and vice versa until this issue is big enough and affecting a large number of users.

1 Like

After removing REX, do you have the general scrolling cache and some record files to delete? If only remove REX without deleting the related files, the same problem will still occur…