PPM levers not moving simultaneously

Hello all,

I have mapped my propellor RPM controls (increase and decrease propellor pitch) to my keyboard. however when trying to decrease my RPM one lever moves at bigger increments than the other, which I then have to correct using my mouse. The problem mostly occurs when I move my joystick in between tapping the keys. Things I have tried: I have bound the RPM controls for engine 1 and 2 to the same keys on my keyboard (instead of the global RPM buttons). I have tried binding the “increase/decrease propellor pitch (small)” ones instead of the normals ones. And I also tried binding the them to different keys on my keyboard. Sady all options are producing the same result. I have made a video demonstrating the issue: Microsoft Flight Simulator RPM lever bug - YouTube

Thanks in advance, Harro

I’ve been having the same issue since day one of the sim. Have you had any luck on getting them to move simultaneously? I’ve tried the same things you have tried and no luck. I have them mapped on an axis. I found that if I make small slow adjustments on the axis the right engine #2 will always move first and its worse when decreasing RPM. If I make large quick adjustments its not as bad. For example RPM at 100% slowly decreasing RPM down to 50%. Engine 2 will be at 50 and engine 1 will be around 80 to 75. I get the same results when mapping to keys or buttons on my joystick or throttle controller. This only happens with the prop RPMs. I map the same axis to the throttles and they work just fine.

Has anyone had any luck on figuring it out?

Watch the video Harro has linked in the above post if this is hard to understand.

1 Like

Also getting frustrated with this. Anyone found a solution yet?