Pro Flight Yoke Disconnecting

Hello :grinning:

I have a Saitek / Logitech Pro flight Yoke. It comes with a throttle quadrant that plugs directly into the yoke. I also have another Saitek throttle quadrant and the Saitek rudder pedals.

Very often, my yoke (and the throttle quadrant which is connected to it) cease to work in the sim and become totally unresponsive. The only solution ? To unplug the yoke, and plug it again. But it never works for long…
When I have this issue I can still see the Yoke as being detected by Windows (it doesn’t totally disappear from the computer), however it is unresponsive if I try to test it in the Windows calibration tool.

  • This issue only affects the yoke and the throttle quadrant directly plugged into it. I don’t have any issue with the rudder pedals or the second throttle quadrant (USB), they keep working when the issue arises.

  • I tried to plug the yoke into a powered USB hub, no effect.

  • I tried to plug the yoke directly into a USB 2.0 port on my computer, no effect.

  • I tried to disable the Windows Power Saving options for all my Saitek (now Logitech) USB controllers (even the ones not showing any issue), no effect.

  • I tried to disable the XHCI handoff into my BIOS, no effect.

Note that I only have one throttle quadrant plugged into my “faulty” yoke (the one which came with the Yoke), I am not using the yoke integrated USB hub to connect the rudder pedals or the second throttle quadrant.

I doubt it is an issue with the yoke itself, it used to work just fine with FSX on my previous computer.

I think it has something to do with my new hardware (it is a new PC), or the latest versions of Windows 10. I also noticed that the Yoke no longer displays system time, a feature that I had on my previous computer (which was also running Windows 10 but an earlier version). *It seems that there are no Logitech drivers for my current OS, or I couldn't find them, which is annoying as I suspect it may solve my issues.*

I am on Windows 10 Professional 20H2.
My motherboard is a Gigabyte B460M.
I have an Intel Core i5.

Can you guys think of anything ?

Thank you very much, any help or feedback is much appreciated.

*Edit: I have found some drivers on the Logitech website, the issue was that it tried to install 32bit drivers on a 64 bit system but you can bypass the automatic OS detection and select other driver versions -- I will need to test if it changes anything, standby for an update :) *

*Edit 2 : Even after the 64 bit driver installation the Yoke bug is still present. However the time is now shown on the Yoke (but it resets to 00:00:00 with no reason, then works again, then resets, then works... Which is probably related to the issue I am experiencing in the sim)... So problem not solved despite fresh drivers installation. Any idea ? *

2 Likes

Just wanted to keep this thread alive. I have exactly the same problem. Any help/thoughts on this would be great.

We sometimes use the yoke only to use the throttle quadrant, flying the A320 with a stick instead. It’s frustrating to find that on touchdown you can’t throttle back without getting on your hands and knees to disconnect and reconnect the cable…

If I can’t find a solution it will have to be returned. I will be opening a ticket/similar with Logitech. Most frustrating.

2 Likes

Maybe we can try to find what we have in common to see if we can identify the source of this issue.

What is the brand of your motherboard ?

On some forums I have read that some brands may have some USB issues with the Logitech Pro Flight Yoke.

Its a MSI MPG B550 GAMING CARBON Wi-Fi. I’m currently plugged into the 2.0 port at the back, the front 3.0 ports experienced the same behaviour.

1 Like

Okay, thanks.

Like I said in my initial post I have a Gigabyte B460M so apparently it is not related to a specific motherboard or brand as we have different ones but the same problem with the Pro Flight Yoke.

Maybe a software issue with Windows ? I never had this issue with earlier versions of Windows.

And like you, USB 2 or USB 3 makes no difference at all.

If anyone has some suggestions…

Same problem. There may be some relationship to the help menu. Still figuring that out

1 Like

Sorry you’re having problems with your yoke. And I have only just spotted this thread so sorry I am a bit late to the ‘party’.

Am I right in thinking that you are using this driver: Flight_Yoke_System_x64_8_0_213_0 and id you un-install the old drivers first. Did you follow the procedure whereby you only plugged your yoke in when asked to during the installation?

And are you able - via ‘Control Panel’/‘Devices and Printers’ - able to see the icon for your yoke and can right click on it and calibrate your Yoke from there?

Sorry [again] that’s a lot of did you’s and are you’s!

Addendum:
When you say it disconnects, is this every minute or hour or how long?

This may help. Right click on the Windows icon bottom left on the screen and select Device Manager. Choose Human Interface Device and right click on your USB Yoke. Select properties and the Power Management tab. If “Allow the computer to turn off this device to save power” is checked, uncheck it. HTH.

1 Like

I am having the same problem and have done everything suggested above, my system:
AMD Ryzen 9 3950X16 Core 32 GB Ram 64 bit Nvidia RTX 3080 with windows 10

I was helped by Logitech support which only recommended the same suggestions above basically only using a USB 2.0 port and turn off the power management feature. After several discussions with Logitech support, they agreed to send me a new one. It arrived today and after 30 mins of fun play, it too disconnected. It has happened while playing MSFS and X-Plane 11. So now Im stuck with no answers. If anyone has found one please let me know

There has to be something in Windows causing this to happen. What other processes are also running. E.g. Restore or a virus checker etc.

Im just down to MSFS with Logitech Yoke system with throttles no anti virus running while playing. Its frustrating because I see quite a few posts with promising leads which I have followed to no avail. Many have reported the same thing happens, they have tried the fixes, it works for a bit then fails. I have ordered the Honeycomb system and hope it doesnt do the same. But it wont ship til November

Same here. I have tried many different things. Still not working properly.

  • powered USB hub
  • disabling USB power saving options in Windows
  • Windows updates
  • latest drivers updates for the yoke

It is probably related to a Windows update as I didn’t have this issue several years ago (I stopped simming for a bit). I doubt it is related to FS2020 as the issue can also be seen in the generic Windows calibration menus. All the axis / buttons become greyed out, and you have to unplug and replug the device for it to work… but usually not for long !

Maybe I should try to find someone in my area who could test my Pro Flight Pro to see how it behaves on another computer. See if it changes anything…

Yeah, I have tried everything Ive seen on internet and what Logitech recommends but it still keeps happening. They have not put out a new software update since 2018 so unlikely to mesh with MSFS but it even happens in X-Plane 11. I gave up trying now I Have the Honeycomb Alpha Yoke still waiting for Bravo Throttles so using My Logitech Extreme 3D but there are some overlapping compatibility issues. Cant use the Logitech throttles because they were connected by a seven pin connection which the Alpha yoke nor my pc have

If you also have this issue on XPlane my guess is that it is related to Windows as it is not sim specific.

But what exactly triggers this issue, I have no idea unfortunately. A new driver would be welcome.

Try
https://forums.flightsimulator.com/t/mouse-clicks-not-recognized-after-some-time/407119/9

1 Like

I am not at home but I haven’t tried this one yet.

I will give it a try when I can. Thanks for your suggestion, I hope it works ! :slight_smile:

1 Like

hi guys, did anyone found a solution ? I tried every thing but i still have my yoke bug after a few minutes …