PSA: OpenXR Toolkit mod is not expected to work with SU10 during beta phase

No, OpenXR Toolkit is an add-on, you don’t need it to play the game in VR. Please state an actual problem if you have one, instead of writing those cryptic messages.

1 Like

it means i cant play vr?

If you’re not going to spend time writing comprehensible sentences, I will not spend time replying anymore. Please file a new thread for your issue that seems 100% unrelated to OpenXR Toolkit and 100% unrelated to the current thread… sigh

12 Likes

Dude this is nuts! DX12+DLSS+OpenXR toolkit with the resolution turned up to oversample is giving me by far the best experience on this sim in terms of clarity, smoothness, high FPS - both on the ground and in the air, all leading to much improved immersion.
Adding FR back in will be the icing on the cake.
Thank you so much!

2 Likes

I have DX11 with DLSS and OpenXR Toolkit running and this gives me a nice perfomance boost, although graphics are a bit more blurry. However I am not able to use VR with DX12. The sim will not switch to VR, nothing happens when using the the assigned button or the menu. No crash, nothing. I tried to disable OpenXR Toolkit but also no joy…

I think you have to read this thread from the top. It should answer your question. :grinning:

1 Like

Hi,
I want to report something for your openxr toolkit. If Pimax XR is active in the control center, the horizontal offset in fixed foveated rendering is not working. And it appears C_/_.
If I change to SteamVR in the control center, it works but they move towards the same direction (both right or both left).
I hope it helps. Thanks.
Any posibility to add any sharpening when using dlss? In msfs it appears amdsharpening but it doesn’t do anything.

I added the new key in the registry. That fixed the DX12 CTD problem but now I get a shaky video no matter what I set the Openxr render to or turning my MSFS graphics down. It’s acting like a continual tracking problem in that every head movement is tracked with a slight delay. This remains the same when I adjust the Shake Reduction in the OpenXR menu or adjust from 0 to -100. My FPS remain steady about 30. When I lay the headset on my desk (and look at my monitor) the image is totally still with a crisp detailed image that looks great.

When testing using the DX11 setting everything performs terrific, better than SU9.

I hope this helps.

HP Reverb G2 (latest bios - April 22)
AMD Ryzen 7 3700X
ASUS Prime X570 Pro
32GB 3200 MHZ
SSD 1TB
AMD Radeon RT5700XT - (Driver 22.6.1)
PS 1050w
Windows 11
MB and GPU set to defaults

Edit 1: I also uninstalled and reinstalled WMR, OpenXR, OpenXR Toolkit and the HP Reverb G2 bios.

Edit 2: RESOLVED!!!
Not that I have an understanding why but I always had “FSR” selected in the in OpenXR menu when I was using DX11 and it looked great.
In DX12 I had to turn it off. Now I have a great video!

1 Like

You mean that you have fix for having DX12 and Foveated Redering? :smiley:

No, foveated rendering remains broken. I have a fix so that DX12 can be used for other features like post-processing etc.

5 Likes

I have identified a few things:

Regarding DX12, thanks!, the regedit key works :slight_smile: but you still have to disable Overlay. If overlay is on, it will fail. I had to reinstall OpenXR and remove the whole key:

Computer\HKEY_CURRENT_USER\Software\OpenXR_Toolkit\FS2020

To later identify it’s the overlay messing up.

Also, side note. DX12 is not really smooth for me even with OpenXR, it’s a stutter fest. I have a 3080ti. Looks great, but I couldn’t make it work.

Hmmm that seems to be just you. Having no problem here, and a couple more users confirmed there is no issue with overlay and DX12.

I see, weird, yeah, I was using “advanced fps” option

If you have FSR enabled like I did try it disabled.

1 Like

Hi I have seen the same tracking stutters when using NIS or FSR , I have an AMD 6900XT GPU. Disabling Upscaling and adding disable_interceptor allows us to at least test SU10 DX12 and Toolkit.
Question is this an AMD GPU issue ?

DX12 is a complete stutter fest for me also. Tried it with the registry edit for the Toolkit, and I just couldn’t get a smooth experience. Kind of disappointing. I’m on a 3080 GPU.

Back to DX11 for now, which is still nice and smooth. I’m not using DLSS (too blurry for me) and not nearly enough of a performance gain to justify using it imo.

I’ve decdied to just stick with TAA and Motion Reprojection unlocked. This gives me the best balance between visuals and smoothness. Though I will say for whatever reason, I feel like I’m noticing a bit more artifacting / wobble with MR in SU10.

Are you not using FSR / NIS, and using the override resolution feature to oversample?

1 Like

Yes, disabling FSR and NIS eliminated my DX12 stuttering.

For me is more related to not having enough VRAM. If I lower the settings it consumes less mem and it works good. If I try to use the same settings I use in DX11 imposible. I guess you need to have 16GB vram to run it smoothly.

BUT sorry, got distracted and this is offtopic to OpenXR

Just as a point of interest, I opted into the beta this morning and tried DX12 in VR with the toolkit disabled. I’m on an all AMD rig, so DLSS was a non issue.

To my surprise, with both Open XR and in game rendering set to 100% and AMD sharpening @ 200%, I was getting 45fps with my G2 in clear skies in the C172 G1000, about 10fps improvement under the same settings prior to the beta.

I then used Radeon chill to limit framerate to 30fps and had a smooth and glitch free experience. Visuals were great and the panels easy to read. Meanwhile, here and on the beta threads many nVidia users seem to be having all sorts of problems with DX12…artifacts, weird landscape and stutters.

Ryzen 5800X3D
Radeon 6800XT
X570 mobo
32GB 3200 RAM
G2

1 Like