Quest 2 almost giving up

Tried most settings. Had it working for few days until I tried figuring up the problem I had with my throttle calibration on the fbw when suddenly my mouse cursor lagged in VR and stutters returned back. Tried all sorts and even reinstalled windows and put only fs2020. Now sometimes it starts working and than its as if I get the screen tearing and does not stop.

These are my specs

MSI RTX 2060 super ventus OC (over locked again with afterburner)
32 GB Ram
Intel i7 8700
MSI z390 gaming edge AC mb

FS2020 bought on steam but not using steam VR.

Xplane works perfectly with many add-ons /

Is the tearing you report the ASW feature of the Quest 2 ? You could try disabling it by pressing control and numpad 1 (numpad on the right of your keyboard) when in game ?

Asw is disabled.

Am thinking of upgrading to a 3060ti or upgrading the CPU ?

I also have Mous Coursor stutters.
and Audio stutters via Oculus Link when I`m looking around the cockpit.
Hopefully asobo will improve the VR expirience in a future update.

This was already reported as a bug with your other peripherals.
Do you have have Logitech’s throttle quadrants?
If so they are your culprit. Move you levers a little bit until the mouse become response again. It has something to do with a cheap and ■■■■■■ hardware/USB signal implementation of these peripherals that cause this issue in MSFS.

I have the Logitech’s throttle, but honestly never had this problem.

I have a thrust master hotas x and the slow mouse cursor issue was only for a minute.

Sometimes I think it’s an Oculus issue. Yesterday upgraded to a 3060ti but still have intermittent stutters and tearing. Something is triggering these stutters.

I had that and reinstalled the VD app on my PC.
Now it runs great again.
Check fe latest post on Airlink or VD for screenshots on settings.
Good luck!!