Quest 2 Cable Link Slow Down

I am new to the VR scene, recently purchased the Quest 2, and here is my issue.

I can start the cable link up with no issues and everything looks great in the headset, as soon as MSFS starts to load the link gets very bogged down (best way I can state it) and jerky. This is while MSFS is loading and not even switched to VR mode.

I can not tell you how many things I have tried, and no matter which OpenXR I use, Steam VR, OpenXR Toolkit, OculusXR or MS OpenXR (WMR), I get the same result.

I do not believe it has anything to do wit the in game video settings, as I stated it happens as MSFS is loading and not even in VR mode.

My Setup:
i7-11700F overclocked to 5ghz
16 GB Ram
RTX 3060 ti
Windows 11

I have all the latest drives and versions of all the software.

Is anyone else having this issue?

Did you try disabling ASW? This can be done in the Oculus Debug Tool or Tray Tool or by keyboard shortcut Ctrl-numpad1 (the 1 key on the numerical pad, the 1 key on top of the keyboard doesn’t work). The latter I find the easiest and can even be done while loading into a flight.

@Ashippun5411

Hi, sorry to hear the Quest 2 isn’t working well for you at the moment.

Yes, what you’re describing can occasionally happen during loading of the game (in specific parts).

Try the ASW suggestion and let us know how you get on. If that doesn’t work, happy to share my settings.

I use Quest 2 and official link cable on similar specs to yours (mine is Win10, RTX3070, i7-10700K, 32GB RAM). I have a great flight experience using Oculus link and love flying in VR.

Cheers,

I will make sure to check if ASW is off, l won’t be able to check now for a couple of days. Thanks for the input.

I also found this on the Oculus Forum from another user. Sounds exactly like the problem I am seeing.

[Taiser35]

Options

‎08-09-2022 10:16 AM

Hi. Strange issue that I’ve been trying to fix for a week. Whenever I start MSFS, whether it’s in VR or not, my Oculus home on my Quest2 starts freezing and rubber banding like crazy. I can load the game and switch it too VR but it’s unplayable. The entire quest2 link bogs down, again whether in VR or not. Same over air link. As soon as MSFS starts loading, the link goes crazy! Tried changing all settings, going back to defaults, tray tool on and off, debug tool settings and speeds to zero, DX11 vs 12, nothing changes! It’s nuts!

MSFS also is bogging down, the mouse barely moves and stutters when the link is active. Runs fine if the Quest is off or not linked to the PC. All other games like DCS and IL2 run perfectly in VR. It’s not the PC, worked fine before and running a 3080ti and 9700k proc. It’s got me baffled as to what can possibly be in MSFS that breaks

Hmmm… interesting read.

I noticed tonight that I may too be experiencing possible issues when using the link cable in MSFS on the Quest 2.

I switched to airlink tonight simply out of curiosity and it ran smoothly. I left the cable plugged into the headset, but only for charging purposes.

I have some flights planned tomorrow in the sim so I’ll run some more tests whilst I’m there. Curiously, I never had any issues prior to SU10.

Cheers,

I have an RTX2070 with 9700K@4.8Ghz and Quest2 and OpenXR ToolKit: Here are my settings:
NOTE: If things get real slow, best to CTRL-TAB MSFS to nonVR, take down Oculus Link/Airlink and restart it. It appears to me that limited VRAM is the issue

NOTE: Start with MSFS Activities->Mt. Everest and check that GPU is at 17Msec exterior

  1. Airlink v42 - 150mbps, 2912x1536 Link HUD (Oculus PC app says 80Hz@4704x2384 )
  2. Oculus Debug Tool (for 80Hz, ASW 30 (27.5) FOV=0.75;0.75, PD=1.3, 2304x2336 Res (PD HUD)
    3.MSFS 1844x1868 - medium airport , high level clouds
  3. OpenXR Toolkit 1.4
    FSR 80% 40% Sharpness
    FFR 1x 75% 1/2x 92% 1/8x
    ~50% 46% Exposure Vibrance 0.4 Highlights 100%
    -15% Shaking Reduction

Versions:

  1. PC Oculus App 44.0.0.137.455
  2. Quest 2 43.0.0.178.120
  3. Windows 21H2 (22000.856)
  4. Nvidia 516.59

Disabling ASW did not solve the issue. I will continue experimenting.

Can someone also tell me how I can check to see which openXR is running? I have SteamVR installed, which I do not start manually.

Go to your oculus desktop pc app settings/general tab. On top it will tell you which openxr is being used and if it’s not Oculus then you can activate it with the enable button.

It always shows Oculus, even with OpenXR Toolkit installed and active. How do I disable the Oculus OpenXR?

Tried many different things still no luck, so I have ordered more VRAM, going to 64gb. Hope this is the solution.

If you’re on Windows 11, did you try the oculus debug tool with console open?

Also, try setting AWS to 18% and turn down your settings like resolution until you get a smooth image.
From there on, try increasing settings again. Resolution and FOV have the most impact on Graphics card.
LOD (fs2020 settings) has most impact on CPU.

off topic. AWS for me is the only way to get a smooth image.

Well, I finally had the time to get the additional memory installed, now at 32GB, much better, but still not maybe what I was expecting. I get 35fps, most settings in MSFS on high, picture just doesn’t seem clear. Maybe I am expecting to much from this headset, it defiantly is not like looking at my 4k monitor in 2d. I will keep messing with the settings and see if I can sharpen the image.

What I am seeing as if there is no anti aliasing happening, I have it set DLSS and quality. Changing it does not make it any better.