Quest 2 Oculus link problem

Does anybody have any idea how to fix the link problem with the oculus Quest 2?
I’ve tried to revert back to the AMD drivers that last worked but they are now incompatible with my RX6800xt and won’t install. Any help would be very appreciated.
I’m dyeing to fly in VR again.

About 6 months ago I was having this problem with the link cable, eventually it resolved itself. I assume its not showing your headset connected to your PC?

I remember doing a system restore to sometime before the issue fixed it for me. Idk if it’ll help here or not, but worth a try.

Also, if you havent tried it maybe opting into the Public Test Channel beta in the Oculus app may resolve it too.

Sometimes unfortunately the last resort is to factory reset the Quest 2, but its was 50/50 for me.

Are you using the 21.9.1 or the 21.8.2 drivers? I’m using the 21.8.2 which works fine with Airlink and my Q2s. I haven’t tried the 21.9.1.

I’ve never had a problem with re-installing older drivers. For a while I couldn’t use XP11 with VR but it worked fine with FS 2020. I dropped back a few updates and that fixed it. These last few have worked fine (for me) with both XP11 and FS 2020.

I am using 21.11.1 drivers now but the problem I’m having is the link shows a connection but when I try to enable it from the headset the screen goes black like it’s connecting but then returns to the home screen.
It used to work fine but one day it stopped and I don’t know changed.