Quest v27 has been released and broke the Refresh Rate

My Quest desktop has been upgraded to the v27 last night and now I’m not able to adjust my refresh rate anymore.
Even when I select 90Hz, the actual rate stays 72Hz.

Do you have the same issue as well?

Welcome to the club. I assume you are not on the beta public test channel hence you only just got it?

Yes 72hz regardless of your settings.

Absolutely mind-boggling they released this with this bug still present. I reported it three times myself. It’s been posted in their user forums, on reddit, here, and various other places online. Other people reported it too. And yet they pushed it out of beta with it still broken… good grief.

I am baffled too. I tried the beta version of 27 several times and every time rolled back to 26 by opting out of beta again. Yesterday it installed 27 official and still not good. How can I roll back this one?

Do you mean Quest ONE? AFAIK 72Hz is hard wired. I’ve the same model and never saw a different frame rate. Quest 2 can operate at 90Hz if I remember that right, but you need a facebook account to run it :frowning:

If you’ve been on the beta test channel its been this way for weeks. Personally I’ve stopped caring as it’s improved my MSFS experience dramatically.

I did revert back to Version 26 to get my refresh rates back and I ran the Dirt Rally benchmark loop at both 72HZ, 80 HZ and 90HZ. Honestly my eyes couldn’t tell the difference and I actually thought it looked and ran best at 72HZ, probably because it’s easier for your system to maintain that frame rate.

Nah it effects Quest 2 as well. You can still select 72, 80 or 90 HZ but despite what setting you choose it actually only runs at 72Hz. You can confirm this with a frame counter or log into Steam VR and it will tell you.

They are releasing 120 HZ mode soon so it won’t be long before it’s fixed. Honestly as I’ve been on the beta test channel I’ve been stuck at 72HZ for weeks and even with a 3090 I prefer it as my game performance is much better. I just don’t notice the refresh rate drop at all, but I do notice smoother frames and being able to crank my visuals to max.

That’s indeed a bad habit :wink:
As I wrote mine is number one. So I was always bound to 72Hz. But since the PC hardware is sort of ‘medium’ I’m quite happy with the resulting GPU framerate of 36Hz (according to Win+G > performance widget). Smooth enough for my budget :wink:

Just to clarify for others – this thread is referring to the PC Oculus software, not the Quest firmware. They both have similar version numbering right now.

1 Like

LOL, looks like it works now. You need to activate BETA channel in the PC Oculus App, and it won’t even download a new beta version, but now refresh rates are working.

Oculus App Version 27.1.0.47.507 (27.1.0.47.507)

The way I read their 120Hz announcement, then it will be for apps/games installed on You Quest 2 and have to be activated within the Oculues Quest 2 “Experimental” menu.

So I doubt it will be available for Oculus Link

Strangely it’s still stuck at 72Hz for me, even with the PTC re-enabled. I had the public release of v27 already, which received some kind of smaller update late last night again, which I assumed was to fix this refresh bug… but it’s still stuck at 72Hz. Enabling the PTC changes it somehow without actually downloading anything (restarts the app), but even doing that, it’s still stuck at 72Hz.

I have the hotfix patch for the Quest 2 firmware that came out yesterday, too. So at least for some people, even after all of these hotfixes and patches, Link is still stuck at 72Hz. :expressionless:

Seems 120hz is coming end of this month
( April ) so guess it’s a 72hz deal until then

Unless they send a hot fix our prior

We got our frames back. Latest oculus update is out v28. I’m back up to my setting of 80hz.

No more 72hz hard stop

Sorted it
Try windows update ,
Few more windows updates came down then my quest2 could do 90hz again

I think Oculus assumes our PC’s already have all Windows updates