Random change in performance VR

I’m having SO MANY problems with MSFS in VR.
Most of the time after I switch to VR the FPS are really low (5/6fps) and the only way to make it go back to the 30/32 fps (as it supposed to be with my setting and computer hardware) is to open the task manager and randomly click on the desktop. Like magic most of the time the FPS go back to normal.

Other time I connect the VR and my fps are 60 or even more but the quality decreased without me changing any setting from the previous gameplay.

I did a lot of testing with same airplane, same airports.
I have a RTX 3070 and when everything works as it supposed to work I have a good experience with steady and nice fps but that doesn’t happen often.

my antivirus is off, I don’t have any background app kicking in beside the Oculus apps (that seem to be ■■■■ IMO…)

Anyone has the same problem?

2 Likes

I find there is always an FPS dip switching to VR, likely as a result of textures having to reload for the VR rendering engine, however I find if you wait 15-30 seconds your normal VR performance returns without having to do anything else.

I use the OpenXR Toolkit. I had it set to show FPS today during Cessna Sunday. Lots of aircraft at one time, and even on the ground at KSMF today, the frame rate never dipped below the high 30’s - in the air it was generally high 60’s to low 70’s. I had Little Navmap and Discord up and running as well, and - of course - the Oculus software.

I am running a 3080, so not too much different than your setup in terms of GPU power. I have also installed only the driver for the 3080, and left the GEForce Experience software out of the equation.

I have not experienced a random drop (or increase) in performance since the SU9 update. I do agree that the Oculus software leaves a lot to be desired, and I’ve had to restart a time or two to get it to “work and play well with others.” :slight_smile:

Are you using Windows 11? That’s happening because Oculus doesn’t support Win 11. If you check Oculus forums you will see a lot of topics about this performance issue. There were some workarounds like toggling oculus debug tool service visibility etc etc. But for me nothing worked. Oculus announced that starting with V41 they are adding Win 11 support. (beta though) so i am expecting improvement.

2 Likes

I’m using Quest 2 on Win 11 indeed. Thank you for your reply, I didn’t even think this could be the problem; I’m surprised Win 11 is still not supported after almost 1 year… I’ll check their Forum and see if something helps me.
thanks again!

1 Like

Not sure but v41 Oculus Quest 2 should be a beta of official Win 11 support

I don’t think this is Win 11 related as I have a very similar problem on Win 10. After switching to VR it is extremely laggy and FPS low, sometimes it seems to resolve itself after 5-10 minutes and sometimes it can be fixed by Alt+Tabbing to another window and then back to MSFS.