Random CTD no error message 5-45 mins into flight

I have been getting random CTD since 12/22 update. Usually around 45 min into flight but it can sometimes be as soon as 5 min.

What I have tried.

Fresh install on Windows with latest Radeon drivers and fresh install of MSFS. No over clocking. No random tweaks in windows. No mods installed.

I have monitored temps and CPU stays around 40-50 GPU around 70-75

AMD 3700x and 5700xt with 32gb ram. Only bios change is to enable XMP.

Game did not crash before update.

I run on a mix of high/ultra with multiplayer off and with live traffic and weather on. Scaling at 80.

I always fly from cold and dark and usually plan my flight in the cockpit vs the world map.

Has happened in multiple aircraft.

Usually fly in around the Boulder/Denver area and into the front range.

Internet is 1 gigabit and hardwired.

Help me Obi Wan you’re my only hope!

Search the forum:

1 Like

While there is some threads that I read through most of them give an error message like the example you gave. I get nothing. Just true CTD NO error message. There is one massive thread that is just filled with all random advice that dates back to launch and same again even though the title says “no error message” most people are posting their CTD followed by what error they are getting in the comments.

Personally I think it has to do with traffic and servers/internet. Last night I installed the Xbox pc app and was able to complete a 45 minute flight. The only other change I made was changing the traffic models to the high res ones instead of the generic low res ones. I’ll try a longer flight today and see how it goes and update this post.

=> topic

=> possible answer/summary

I have never experienced CTD’s until after the December update. I’ve tried all of the advice and the only thing that works is turning all traffic, both live and AI off, I have noticed something though that appears to be linked to the CTD’s with no error messages. I am using Neofly to give me some added interest in the sim. Normally I choose a flight in Neofly, set it up in the sim and then connect in Neofly. I have had absolutely no issues until now. What I have noticed is that about 10 minutes before the CTD, Neofly disconnects from the server. The CTD always follows after this. The problem is not with Neofly because it happens whenever I have live traffic enabled when not using Neofly. All I am saying is that I was noticing the disconnection from the Microsoft server via Neofly and that lead me to believe that this is 100% a server issue.

It is increibly frustrating to suffer from random CTD. Like many others I purchased a new computer system for the sim and have been rewarded with these random CTD.

I have tried many things without success, I do notice before the CTD the game starts to pause briedly during flight with the simulated radio “static” sound at the end of the transmition. The graphocal pause lasts as long as the noise and then carries on - this is a pretty good indication that I am going to get a CTD.

The last CTD shows the followig in event viewer, is this fairly standard with others?

Faulting application name: FlightSimulator.exe, version:, time stamp: 0x5fda32ba
Faulting module name: CoherentGTJS.dll, version:, time stamp: 0x5fc6a6c2
Exception code: 0xc0000094
Fault offset: 0x00000000001781ae
Faulting process ID: 0x2ec4
Faulting application start time: 0x01d6e1fd0a185624
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.12.13.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.12.13.0_x64__8wekyb3d8bbwe\CoherentGTJS.dll
Report ID: 6b2f8c29-69d5-4365-bdad-5b920d592c0c
Faulting package full name: Microsoft.FlightSimulator_1.12.13.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App

After weeks of experiencing zero CTD events, I got seven or eight in a row yesterday, in the same A/C, at the same place on the map. So, I did what I’ve done in the past (this is the fourth time I’ve resorted to this fix… it’s a lot of work.)

  1. Go to Settings; select Apps; scroll to Microsoft Flight Simulator. Click on the title and then click on Advanced Options in blue.
  2. Along the left-hand side you should see options that look like the screenshot below.
  3. Click Reset… you should get a check mark once that process is complete.
  4. Start Flight Sim using “Run as Administrator.”
  5. Now for the fun part: the entire base code will reinstall. (I do this overnight, because it takes some time to complete even with a fast connection.)
  6. Once complete you’ll need to open Content Manager and reinstall the A/C and options you want. Depending on how fast your internet is and how much content you want, this can also take some time to complete.
  7. Quit Flight Sim and reinstall clean copies of each mod you use. Make certain they’re the “latest and greatest” so as not to cause any issues.
  8. Restart Flight Sim and - hopefully - you will be able to fly without CTD events.

It’s a hassle, but this method has worked for me every time.

To test the results, I flew the exact same route in the same A/C today: no CTD event.

Good luck!


I am also experiencing randomly occuring CTD without any valuable error message… I think it occured after the latest update last month (don’t exactly know because I was not playing for a period of time and missed one update in between)
In my case, the workaround for me was disabling the air-traffic (AI- and LIVE-Traffic). I hope MS/ASOBO does have a bugfix on their list for the next update.

I hope they provide more error details/logs in future to help to better identify/analyze bugs by ourselves.

Hi! I don’t see the blue thingy…

  • bob

Looks like you have a Steam installation?

Hi Seven,

Yes I do.

  • bob

My installation is from the MS Store. That’s likely why you do not have “Advanced Options” showing up in the list.

1 Like

You say “everytime”, so this means that it doesn’t work, because you have to repeat the process!

Location in region of: 22Deg 18Min 32N 114Deg 12Min 19E (Between Hong Kong and Kowloon islands)

Since two months, I thought that all my CTDs in that area were to do with scenery. I continued with my flights in that area. Still I was getting CTDs in the same location vicinity. I undertook a number of completely mod free flights (empty Community folder), in and out of VHHH. In exactly the same spots I encountered CTDs. Obviously there is a buggy thing there.

I don’t have rolling cache and photogrammetry is turned off.

The CTD is the same, a short sound stutter and a freeze of a couple of seconds and I’m looking at my blank desktop!



=> 22°18’32.0"N 114°12’19.0"E

no issues…

except funny users :wink:

Hi, yes that’s the vicinity. I have lodged a ticket with Zendesk. This has been happening there since Aug, with no mods and an empty Community folder.

have you more exact position, alltitue ? because I can’t reproduce your issue…

On water, on land and overflying. Because it has been happening regularly I looked at all operational situations, including operations from and to VHHH and VHSX.

hmmm… but because there is no CTD on my side, it can’t be a issue with the map.

I don’t have rolling cache and photogrammetry is turned off.

System: Omen 30L GT13-0054na Gaming PC; Windows 10 Home 64-bit OS; Intel Core i9-10900K CPU @ 3.7GHz; RAM 32GB; Samsung S34J55x Monitor 3440x1440 @75 Hz Resolution; NVIDIA GeForce RTX 2080 Ti. MSFS P/D; TM Pendular Rudder Pedals, TM Warthog Hortas Throttle/Joystick Combo.