Random CTD's no obvious cause

Hey all,
I wonder if any of you can help me with this one. I’ve done hours and hours of testing and troubleshooting at this point and I wouldn’t post here if I really wasn’t stumped.
First, I’ll just say I’d consider myself one of the ‘lucky ones’ when it comes to CTD’s as I’ve never really found myself in this position before. The sim has ran relatively well for me since release and CTD’s have been minimal and when they have, I’ve managed troubleshoot and resolve. I’ve also worked with a number of my viewers to successfully help them with their own issues and CTD’s over the last year so this process is not something I am unfamiliar with at all…

So the issue begins somewhere around 25/01/22, the sim has started randomly crashing to desktop. No popup to explain, no seemingly obvious or reproducible cause and any info I can garner from event viewer means nothing to me and Googling also just seems to lead down an endless rabbit hole of ‘fixes’ that don’t appear to work.

When I say the crashes are random - I’ve had one happen after 30 mins, after less than that, after a bit more than that, after 2-3+ hours. There does not appear to be any specific trigger either. I had one when pushing back, one when sat on stand without any power the aircraft just a static drone view that I was using as a start screen for my stream, a few in flight again after multiple hours and not. Happens in different aircraft and in different locations. Couple examples: crashed at KDEN on the ramp in DC6, crashed at EDDK on the ramp in the A32NX (and when pushing back on a repeat attempt). Happened on a 2 mile final from EIDW in A32NX.
I’d love to test with other aircraft too but considering I don’t really know what I’m testing for or have any leads on a potential root cause and I’ve only so much time.

I will note that sometimes, it doesn’t crash and I can run the sim for hours on end.

The only thing I can definitively say is the crashes are not happening when the sim is loading or in the menus. It usually only seems to happen in flight, though I don’t spend forever in the menus so I suppose this can’t be entirely ruled out.

Things I’ve tried so far:

  • Empty community folder
  • Remove 3rd party addons purchased in marketplace
  • Run the sim without any external simconnect or similar applications running
  • Update every conceivable driver on my computer
  • Update Windows and MS Store apps
  • Run through all troubleshooting steps on Zendesk in relation to CTD’s

I have not:

  • Made any changes to my system or hardware in the recent period before this started happening up until now
  • Made any major changes to any system wide or gaming related settings or to the sim itself including graphics options
  • Made any changes in devmode

My system specs are:

  • Ryzen 5 5600X
  • Nvidia 3080
  • 32gb RAM
  • Sim is installed on a 1tb M.2 drive as well as my addons excluding some less commonly used which are on 7200rpm HDD
  • I have 2x 24" monitors, 1440p and 1080p
  • The sim runs on my 1440p monitor, my graphics settings are modest, with most settings being on high with a few on ultra and a few on medium. LOD sliders are on 100.

I’ve dealt with some strange problems with this sim in the last year and a bit but I don’t think I’ve ever been quite as stumped as this.

If anyone can spot anything I’m missing I would be more than eager to hear your view.


Hi Rob, I’ve had 3 this week, like you at different phases. Prior to this week I’ve had 2 since the sim came out. All happened since the mini update on Tuesday I think it was which updated some of the Nav data. My tests seem to indicate it’s when the sim loses contact with one of the online services (even briefly). It’s not an issue with the internet connection as I’ve set off a continuous ping to the opendns servers and I don’t drop a packet. Also, if I play offline, there’s no CTD’s.
I know Microsoft have had a nightmare week with availability issues on several services so I’m wondering if it’s related to that. In saying that, I’d an online flight today of about 45 minutes without issues, so hopefully it’s all good now.


Interesting observation and not something I’d considered to be honest. How did you manage to work that one out? (assuming there is no notification)

You may find this post offers an explanation.


Thank you so much! That thread entirely? Or just that post? Nevertheless that post is quite an interesting one. Doesn’t explain why I’ve gone the better part of 12 months without anything like this but is an interesting and encouraging one nevertheless. Thanks again!

1 Like

Just through a process of illuminating the internet connection by flying offline verses online. I know there’s be problems with various azure services this week (not specifically MSFS)

1 Like

Just that post, as it certainly explains your CTD’s
I wouldn’t put too much effort into trying to figure out if your system is at fault!

1 Like

Great stuff, thanks! This has never been a part of my troubleshooting process. Will bear in mind!

I’d love to agree and say that’s the answer but aren’t they talking about a memory leak issue whereby there is a gradual decline in performance?

A memory leak will contribute greatly to CTD’s
Remember last year this time CTD’s after longer flights, it was caused by memory leaks
I suspect you’re one of the “luckier” ones. A lot of folks are experiencing a severe drop in performance, or stutter, with an immediate CTD at almost every airport.
Here is a link to one thread, but there are a lot more.

1 Like

Have you tried turning Hardware acceleration (HAGs) off as currently with latest driver this causes CTD for me but it is easily reproduced so may not be your issue but worth a try if you haven’t.

1 Like

This is very interesting. I am having an identical issue as @BobbyFuzzy. I guess I will just sit tight and see if this issue gets addressed soon.


Thing is, I’ve not really had any issues with perf. Things feel smooth and consistent, perhaps more than ever! Hence why I had not thought about something like this being an issue. Will check out that thread, thanks again!

Yes I always run with this off as it doesn’t play well with OBS Studio which I frequently use for streams etc.

Likewise… I just find it bizarre there’s little to nothing we can use to troubleshoot things like this. We need a log ASAP!


With all these utterly random CTDs with no discernable reasoning at completely random times in the flight and at multiple random geographical locations, is there really any hope for a solution? Having followed all of the prescribed troubleshooting procedures, things actually seem to bet getting worse. Meaning: these CTDs are becoming more persistent - they are happening not only at custom airports (Bespoke, Payware, and Freeware), but at autogen default airports as well. I truly hope this issue gets addressed soon and a fix implemented. It really sucks not being able to play a game you spent $120 for.

Mine resolved again. Uninstalled the Nvidia drivers, making sure to delete the existing ones from device manager, restarted, let windows install the default ones from MS update and all good.

I’ve actually managed to do a couple of flights over the last 2 days with no crashes. Nothing else has changed on my system…!

Still keeping tabs on it however.

Will bear in mind if I get any more! You removed using device manager? Not DDU?

DDU should really be the last resort. Just uninstalling the gpu before running the Nvidia app should be just as good and even then is mostly unneccessary … However I do recommend not choosing GEforce straight away but opting for Custom and then ticking the clean install checkbox, the only downside is that you will lose your NVCP settings so make a note of them first although it’s actually better to recalibrate them entirely. After this you can restart the installer and select GEforce if you need it.

Don’t know if you’ve read much of the rest of this thread but we’re definitely approaching a last resort situation! :flushed:

Like I say, things seem to have magically improvement so just monitoring for now.

Thanks for your input!

@BobbyFuzzy, I wish I could say things have improved. For me, things have been getting a bit worse. The CTDs have become more of a commonplace experience. I believe I have tried every troubleshooting technique we’ve discovered since the Tech Alpha phase of development, and still no joy. I’m at a loss, and am believing that I’m going to have to wait for the next Sim Update to see if a fix is implemented.

What is your Windows version?

Latest is 21H2 19044.1526

What version is your sim?

Latest is

Follow these steps…

I stumbled across the reason for my persistent CTDs. I discovered my solution right here in our forums when I happened upon a post about a piece of software, I use in my photography studio called CaptureOne. I don’t know why this item affects MSFS, but it does. I uninstalled CaptureOne and everything is working fine. At least now I know.

1 Like