Reappearing trees

I recently(a month or so ago) excluded some trees on the approach path at St Barts. When i was flying in today, the trees are back. When i go to the SDK, the polygons are still there and the vegetation is all set to 0, but there are now the original trees. Any help would be appreciated.

if you add new exclude does it still remove tree’s or does it not work?

if the vegetation exclusion doesn’t work then delete the two highlighted files here it will re-add them next time you load the sim and should hopefully fix it. has done the times I have done it.

Hi, I have the same problem with trees reappearing inside polygons with vegetation density set = 0. It started either with 1.13.16 or 1.13.17 - not sure. It seems to happen only with trees added by other third party sceneries. Trees of the default scenery seem not to be affected. Polygons in default areas stay void of trees.
Meanwhile I use MSFS 1.14.5 and SDK 0.11.0
I re-digitized the polygons and re-compiled the projects with this latest SDK - no effect.
I used the delete-file-proposal mentioned above by DORRAGER, again without success.
As the third party scenery did not change, I would think, it is the MSFS.
Any ideas welcome.

1 Like

In your case you might need to re-order third party add-on and your own add-on in the content.xml folder so that your changes show up. Think yours should be below the third party scenery, could be the other way round though. Just copy and paste it then delete the copied file.

Hi and thanks for the prompt response.
I tried it both ways and it makes no difference, I’m afraid - at least as far as the trees are concerned.
I identified the BGL controlling the vegetation in the third party scenery. I will move it aside (i.e. rename it), adjust the layout.json file and then create my own vegetation.

Hi, I think I found a work-around for something, which might be a bug.
In the past I had tried to erase vegetation by digitizing polygons and then setting vegetation density to 0. This used to work, both for the default scenery and third party sceneries.
After the recent updates, the trees of the third party sceneries re-appeared. Trying all kinds of things, I found, that using a vegetation density of 0.034 (the smallest above 0, I can set the density to) and setting the scaler to something small, but also above 0, has the desired effect. Third party vegetation is reduced to almost nothing.
Setting one of the two - density or scaler - back to 0 brings all vegetation back.
This looks to me, that 0 has become an illegal value for - or is misinterpreted by the simulator.
I tried this with several polygons and it had the same effect everywhere. So, for the time being this work-around is good enough for me to continue.

1 Like

I have had the same issue ever since the UK update. All my vegetation polys now not working. Not only do they not remove trees when selecting 0 for density , if you want to add trees it does not work anymore. Basically the vegetation density slider has no effect. I have not tested scale yet.

Are your trees from 3rd parties or from the default scenery? For example: I just removed the trees from the default Stonehenge scenery. No problem to do this.

I will definitely try this.

Default trees. I think I may need to do a complete re install of the sim.

I am afraid, I cannot help you any further :slightly_frowning_face:

I just re installed the sim and the vegetation polys now work. Something broke when I did the UK update.

Hello All, I’m trying to remove the trees from st barts approach but is impossible following all tutorials from the internet. Can anybody point me in the right direction ?

Can’t help, but I hope you succeed. A bit of tree removal would certainly help the realism of that iconic approach.

Hi, could you please give me a hint of how were you able to remove it ? I have tried polygons and exclude rectangles and no luck.