[RELEASE] MSFS Kinetic Assistant - SimConnect util for soaring and aircraft carrier landing/takeoff

1 Like

New updates available for our programs - Kinetic Assistant (0.9.1) and ALBATROSS (0.5). Most improvements in replay functionality was made this time. Now you can use manually created track files for the tow plane, so no more weird AI behavior. More various routes will be added soon. You still can enable ATC controlled tow plane in options, but prepare for troubles as it does not work properly on many airfields.

If competition contain tow plane track (currently Race 100 LOIJ and Race 159 EDFY), to start towing process just open Aerotow tab, press AI TOW button and prepare for takeoff.

You can test out recording/replay functionality, but it is very unfinished at the moment - you can’t perform some aerobatics and expect the program to play it properly. Further improvements will be applied soon, but our first goal - to make the plane follow proper route - is reached.

I experimented with imported thermals from little navmap and something is wrong. I tried thermals with a radius between 1 and 2 miles and strength between 1 and 5. Setting the tag field in LNM: (1 1) or (1 5). As soon as I reach the thermal area the nose of the plane is pulled violently downwards first an then goes vertically upwards. The plane can not being controlled anymore. Weather preset has wind on 0 kts.

That’s not right. What about API thermals, is it same behavior?
And have you changed SimConnect requests frequency slider position (top of the window)? Anyway, you can try different values (like 10 14 18).

Thx, I will look into simconnect setting. I do use Spad.next to drive some hardware. It’s possible that there’s something conflicting with simconnect…

now using the program for several day.s .I must say, it’s wonderfull.Really enjoy using it.
Thanks you made my day…
greetings Andre

1 Like

Hi, I have been trying to load thermals from little navmap into kinetic assistant but when I select the file to use it says ‘userpoint record does not have enough parameters’ an I wondered what would cause this. Thank you

Actually, I managed to fix the problem. Turns out in the CSV file I had exported lots of VFR waypoints as well :joy:

1 Like

After months of the development and adjustments, we are finally close to the end of the process. Most features work smooth, the user interface is simple and logical.

Several things still should be improved - like ghost recording, and maybe new thing will be added soon - it has experimental status right now, if will work well - could be passed to our testing team soon.

New tow option was added in this version - ground crew push. It is really helpful for gliders and navy pilots, so you can park your aircraft, or move to the runway/catapult, by yourself.

In-game panel now included - you can see and control zoom of navigation screen inside of the game (works in VR!). No tutorials on it yet, but it’s enough just enable the “Kinetic Panel” option in settings (scroll down available options first), and click on Install link - drag and drop archive content into Community folder and you will see a new panel option with glider picture.

ALBATROSS updated as well, check out our new gliding competition - Race175 Oloron-Herrere! Don’t forget to get France add-on to have the ultimate level of scenery quality. We are all here for breathtaking sight viewing, right? =)

1 Like

Just discovered this today and I’m encountering some crashes when landing on carriers. Is anyone else experiencing this?

is it game crashing or application?
I guess at the moment when you touchdown the carrier with tail hook deployed, right?

It’s the sim that crashes. For more info, I just found Kinetic assistant yesterday to use with the freeware carriers on flightsim.to, more specifically the WW2 carriers to land the Milviz Corsair on. So at the Hawaii location (ACPE code) there are two landable WW2 carriers, rwy 04 and rwy 05. Rwy 04 I can land on without issue however rwy 05 is the one that is crashing the sim for me. The tool stays running after the crash and still believes the hook is extended and yes, the crash happens as soon as I touch down and the deceleration starts. I haven’t had a chance to test other locations but I’m working on that now.

thanks for the info, will try it myself

I did a little more testing and it seems to be related rwy05 of any ww2 carrier location, which is the second carrier in the group. It even crashed when using another third party arrestor program, though with that one it crashed shortly after completing the landing.

I am the carrier developer.

That’s proper weird. I’ll release an update today or tomorrow so I’ll give that runway another look, but I can’t think of anything different about it compared to any other. Perhaps a recompile will sort it.

Any other WW2 locations you can think of that should be added? I’m running out of ideas. At the moment it’s just the Quonset area.

Hey! First off great work with the carriers, they’re a blast with the kinetic assistant. It’s very strange the issue, I was going to do some more testing without any tools loaded up to see if that specific runway causes issues.

As for added locations, one in the Solomon Islands would pair nicely with the ww2 airfields scenery package for the area.

I hadn’t seen that. I’ll throw that in.

Just had a quick look at the code for that runway. It’s totally standard info. Anyway, a recompile might sort it out.

I just did a test without any arrestor tool running and still got a CTD landing on the rwy 05 carrier. I also conducted this test with a different aircraft, the Bell 47, so it’s not related to the Corsair I had been testing with.

I’m not sure if it matters but when the carrier is a bit of the way out, before the LOD adjusts you can see a large hump of water coming up the sides of the hull, around where the arrestor cables are located. This hump of water seems to disappear when you get closer and the LOD changes.

That happens on most of them if you catch them at the right/wrong angle.

It’s the terrain LOD doing its thing, or rather not really doing the thing it should be.

I’ll erase the runway and stick a new one but it’ll be the same data entry basically. It might exorcise the gremlins anyway.

Thanks for looking into it! One last thing, I noticed at the Hawaii location in the middle of the pack of ships is a carrier that’s totally flat, is it possible to make that one land-able? I tried to land on it and fell straight through!