Render Scaling does not work!

I understand, but I don’t see this deviation, when the white menu thing is not there. My advice is get rid of it, by parking your mouse somewhere else.

I also cap at 40 but in sim its 20, best performance smoothness and temps for me

I can press the ‘up arrow’ key to remove the white indicator - it doesn’t matter if that is present or not - the tearing at that location persists with or without the white indicator on the screen. I only use it as a reference point (where to look) so everyone can see the glitch

Ok I pass… driver version issue ? I have 471.11 at this moment, I don’t see the deviation here.

btw I open NVidia properties, see this… :cat:

image

I have tried older drivers, removing the community folder contents, default MSFS settings of low, med, high, ultra, nothing works. I can maybe have one flight without it but not two in a row. sometimes it starts immediately. No other problems with other simulators - not temperature issues - no other indicators or system errors or faults. I just see the image sort of ‘snap’ and then I see that tear across the top of the screen and the view switching is distorted.

1 Like

Can confirm that this is related to render scaling.
I usually run render scaling 150 but when it happened this evening I tried a few things.

Put ATC pop up window in the area which has the artefacts. It hides the artefacts. (No issue over the window)

Toggled all graphics settings low / ultra - was visible as issue in both settings.
(*Note, toggling between ultra and low does not appear to change render scale)

Switched render scale to 100

Issue instantly gone.

Turned it back to 150.

Issue reappears.

Restarted sim with render scale 150.

Once again fine.

GPU temp was around 40 and memory junction around 50

1 Like

I have that set to 120 - are you saying to set it to 100 - then what? pause the sim during a flight, set it to my 120 or your 150, then end the flight - close the sim and then restart it now at the new 120 or 150 and that works?

I usually have it at 150

Setting it to 100 mid flight resolves the issue when it happens…

Once it has glitched any render scaling above 100 that I tried would cause the glitch to reappear.

In my case it only happens now and then. Not all the time.
Restarting the sim also clears the glitch for me even if I have render scale at 150

It can be fine for days and then I get one flight that glitches.

See, that’s the issue with opening new threads while there is one already.
I pointed it out very early in this thread, there is already a proper report about it with basically all the findings that are now discussed here.

Hi somethingbrite,

This is what I mean, we are chasing our tails, well done by finding a temporary solution to the tearing because that looks quite annoying. But with the SU5 update not saving the settings we have selected, we cannot say for sure where the hell each of us is when we click start!
We may still have to do the workaround but I am sure everyone has custom settings, so still a nightmare.

The workaround is " before each flight " click on LOW settings, then Ultra ( or your settings ), then start flying.

I think this is a pretty major problem and Asobo are aware, It may not be implemented with SU6 but as a Hotfix.

This has nothing to do with render scaling since the scaling is not part of the graphics presets.

2 Likes

Technically yes, but you see what I mean.
You’re upscaling to render a better picture, but if we are not sure what we are currently viewing in the settings, you cannot be sure of what you are actually looking at selecting a higher scale.

The FPS display in dev mode shows the rendered resolution, there is no known issue with the effectiveness of the render scaling as far as I know.
Unfortunately the title of this thread is misleading, render scaling does work, but it seems to cause some sort of issues with the engine and/or drivers if set above 100.

then it’s broken - IE: does not work

1 Like

Okay, if it makes you feel better call it what you like. :man_shrugging:

My render scaling works - it scales the rendered image as expected. It just has negative impact, but that doesn’t mean it’s main purpose isn’t working.

My render scaling works with zero probs at 150, but turned it back down to 130 for high FPS.

I don’t have to do that. My settings are kept as they were every time I start a new flight.

I took your advice and used DSR to do this on my 1080p monitor, and the results are amazing! DSR 4x in Nvidia control panel to render 4k, render scaling at 70% in-game produces about the same load on my GPU as I had running native resolution with render scaling at 120%, but the picture is just…richer? I measure the load on the GPU based on render latency targets, not total percent of GPU load. And the frame timings are SO much tighter. I have been running stutter free for a long time, but it never looked THIS good.

I have understood the need to increase render scaling to load the GPU and allow the CPU to “keep up” to smooth out stutters for a long time, but the idea of creating a 4k picture and downscaling it to achieve the same results on a 1080p monitor had never crossed my mind.

So thank you. This comment has opened a whole new perspective for me.

10700K @ 5.1 all
3060TI (full power and voltage, but +0 on clocks)
32 GB 3600 Trident Neo
All in-game settings maxed
Vsync locked at 30fps in-game to unload CPU and prevent screen-tearing
DSR @ 4k, 70% render scaling, 1080p monitor

Absolutely butter smooth.

Also, I haven’t experienced the artifacts descrbed in this thread or CTDs since removing the GPU overclocks.

4 Likes

…hmm also might have something to do with AA settings. just like OP, post SU5, I get artifacts akin to tearing when render scaling is > 100 (3080ti).
BUT then setting anti-alias to anything other than TAA, then artifacts don’t occur - but then of course, its at the expense if image quality.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.