Repeated CTD's &

Before the Hotfix I had a load of CTD’s doing most things bar a proper flight with SU5, discovery flights for example crashed several times. After the Hotfix no more crashing on anything, though plenty of nice new bugs, with more being seen every day. But that ended up short lived, on my first flight just now, I just did a test flight in the 172 classic, a short hop, landed, turned around to take off again and there it was, my desktop that is.

They better be working hard to fix what they broke and get another hotfix out sharpish so the sim is actually usable. A full year of bugs, server issues, crashes, insane design decisions and plenty of scenery to buy. I’m so tired of Asobo’s incompetence, and so disappointed in the sims lost potential so far, will they even get this sim to release quality by ten years? I really have to wonder.

I hate to write it here repeating what everyone has been reporting - CTD, Quality downgrade for performance etc. I wouldn’t have even bothered to write here if this was a free open source community driven project but that is not the case. Every single person that has reported on this forum has paid money to get this simulator and is frustrated because they cannot enhoy it. Most of us are not BETA TESTERS to test and report the issues because you guys did not do your part properly and release something that is going to cause hell lot of issues. I still understand it will not be a 100% and there might be hickups but OFCOURSE NOT as much as this much considering its been a year. I pay for the game pass every month and each DAY I am not able to play the game because of all these issues you guys have caused its just waste of money for me.
Onbehalf of the entire community we would like to get this fixed ASAP!!


I vouch for that last sentence! So true!! I can already see that happening.

CTDS after a few minutes, seems to me to have something to do with controllers and controller profiles. - - Tried to delete all non default profiles → CTD

  • Tried to unplug usb controllers (Saitek yoke and pedals), start and replug → freeze then CTD
  • Restart, flight loaded, first control input → CTD
  • Managed to start another flight, about 2 minutes in. CTD

Community folder empty, Real time traffic only. All other traffic, boats, cars and airport life at 0
RTX3070 i510600K 16GB RAM Pro Flight Yoke+Pedals
This is unplayable. Sim update 5 when it works is great but this is alpha-level stability at best. :rage:

All faults give about the same generic error 0xc0000005 so its an access violation

Faulting application name: FlightSimulator.exe, version:, time stamp: 0x00000000
Faulting module name: FlightSimulator.exe, version:, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x000000000232dd76
Faulting process id: 0x3ffc
Faulting application start time: 0x01d7876ae1ac747c
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.18.14.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.18.14.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Report Id: 0ea53841-bb92-475c-97fd-832db25fba2d
Faulting package full name: Microsoft.FlightSimulator_1.18.14.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App

So i haven’t played on my PC since the xbox launch, as ive been testing it on my series x. But even on the X, I’m still getting CTD’s. At first it was with every plane and always during a flight. Now it has eased some since the hotfix, but it’s not completely gone.

With that said, I would hope this is still avidly being addressed as it’s still affecting both platforms. But i also know that this will take some time. I’m keeping my fingers crossed.

Installed the update from the weekend and so far its beenmore stable but the A320nx (Dev Version Updated 2nd August) still a no go CTD where it almost always happens towards end of loading into flight.

I don’t know how useful this information is to people but I might as well share here as well as to Zendesk in the hope it might save someone else’s sanity.
After SU5 I suffered from the CTD’s at the loading screen with Exception code: 0xc0000005.
These were the things I tried and the results.

Verify integrity of files via Steam - CTD on loading screen.
Run as Administrator - CTD on loading screen.
Increase page file to match RAM - CTD on loading screen.
Deleted AppData and let MSFS build a new one - CTD on loading screen.
Removed my Xbox login from Windows credentials so it would force a new login - CTD on loading screen (after signing in).
Ran sfc /scannow - Fixed an error but still CTD on loading screen.
Complete re-install (12 hour download - nice), ensuring all files had been removed - CTD on loading screen.
Altering DRAM clock speed between 2000-3400MHz - No change, CTD on loading screen.
Limiting FPS globally to 30 FPS - Managed to start a flight but crash within 5 minutes.
Remove FPS limit and reduce GPU clock speed by 400MHz - Able to start flight but unstable, random CTD’s.
Live weather/traffic turned off - 4 flights done in the A32NX dev build, no CTD’s.

I still get the temperature/altimeter bug which is annoying.
Whilst I now have stability, I shouldn’t have to underclock my hardware to be able to play a game, lets hope a permanent fix gets put in place soon!

1 Like

I wonder if this is ASOBO’s idea of a one year anniversary of the game: bring back the launch day feeling…

1 Like

See if running your CPU on the lowest setting helps.

I only have CTDs with the FBW Airbus, but those disappear if I run my i7 at its base speed of 2.6 Ghz. Anything above and the sim collapses on the Airbus. GPU capped at 30 frames.

I think they have thread timing issues. The faster the system the more problems (it seems).

I think you’re right about the thread timing issues.

I only tried the GPU first as I saw nvcontainer crashing at the same time but I might try this to prove the point, its been as stable as ever since changing it.

For something that was supposedly beta tested, I simply can’t believe they were running it without problems during the development phase. It’s incomprehensible really.


I’ve had probably around 4 or 5 CTD in the hundreds of hours that I’ve played since launch. Had around ± 20 CTD since release of Update 5. Some CTD happen while loading in to the game, some happen in the menu, and some happen as I press Fly. I usually don’t get more than 30 seconds in the sim before it crashes. Tried all of the fixes possible. Did a uninstall and reinstall and tried the fixes again with no success. Zendesk fixes don’t work. Fixes tried from all the forums don’t work for me either.

GTX 1660 - i5 9400f - 16GB DDR4 RAM - (Game is installed on 500GB SSD) - Windows 10 Pro

Starting and flying whilst in cruise acts absolutely fine for me, as soon as I get around 6000ish feet or near my approach the game CTD’s, COmmuinity folder is empty, Tried absolutely everything

Today I’ve been trying to complete the activity Rijeka to Santorini. But every checkpoint I get to either landing or taking off the game crashes to dashboard. This is only since the latest update.

Anything in the log ?
Does it happen on other bush flights ?

Il try one of the others and report back.

Latest CTDs with occurred when I was spawning cold/dark in 787 and FBW A320. Airports were LFPG and KLAX.

Got no error message, just CTD

I think the FBW is still in beta isn’t it ?

Have a new computer, RTX 3080 and just had my first crash. Never had any issues before update five.

1 Like