Repeated CTD's 1.18.14.0 & 1.18.15.0

No. They’ve updated it a few times since su5

1 Like

I tried the C172 for the first time since the upgrade virtually fubaard flying airliners. And only got as far as taxing to the runway before the customery CTD.

I’ll try this after work, haven’t been able to fly since the initial SU5 update.

Constant CTD’s :sleepy:

Also is there any truth to the “Nvidia users -400 mhz” fix?

Happy flying

EDIT: the below issue was finally solved by uninstalling from Steam, and reinstalling.
I kept the packages folders as they were, other than deleting fs-base, and the FS folders in Local and Roaming, so a full redownload wasn’t necessary
It looks like something broke / got corrupted in the actual steam installation directory


NEVER had any CTD before this latest hotfix.
I have a good rig and excellent performance with the sim prior to hotfix.

It crashes at a black screen, before the menu / credits begin to load

Steam version

I have tried absolutely everything
Community folder deleted
MSI Afterburner & Process Lasso uninstalled
Sound disabled
Reinstalled US voice pack
Sfc /scannow
Nvidia drivers rolled back to a stable version
Appdata folders deleted
Nvidia profile reset / tried at 30fps
Redistributables reinstalled
Tried without G-Hub and Discord (seriously, guys?)

Still getting this

Faulting application name: FlightSimulator.exe, version: 1.18.14.0, time stamp: 0x00000000
Faulting module name: KERNELBASE.dll, version: 10.0.22000.65, time stamp: 0xfb11046d
Exception code: 0x406d1388
Fault offset: 0x000000000004467c
Faulting process ID: 0xaa0
Faulting application start time: 0x01d787ece7b0a330
Faulting application path: X:\SteamLibrary\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report ID: 3e4cee16-4cfd-438f-a984-2b58ca4b3b0e
Faulting package full name:
Faulting package-relative application ID:

1 Like

For transparency here is one of my crash logs:

SYMBOL_NAME: FlightSimulator!FlightSimGetProcessId+15379b8
MODULE_NAME: FlightSimulator
IMAGE_NAME: FlightSimulator.exe
STACK_COMMAND: ~0s ; .ecxr ; kb
FAILURE_BUCKET_ID: NULL_CLASS_PTR_READ_c0000005_FlightSimulator.exe!FlightSimGetProcessId
OS_VERSION: 10.0.19041.1
BUILDLAB_STR: vb_release
OSPLATFORM_TYPE: x64
OSNAME: Windows 10
IMAGE_VERSION: 1.18.14.0
FAILURE_ID_HASH: {3aa64f92-502c-b627-c4fa-7704fe6bc9f3}
Followup: MachineOwner

I’ll give that a shot [+]

1 Like

What about aside from FBW ?

After 1.18.14.0 mine is much more stable have not yet had a CTD other than trying to load FBW (CTD 3/4 way during loading screen every tiem).

Me also, just won’t lsunch. 6 dsys now…

Completed a flight this morning followed by 8 CTD’s throughout the day.

Checked xbox live. Everything seems to be working.

Went to settings>Gaming>Xbox networking. Looking at Xbox live Multiplayer clicked Fix it button.

FS 2020 loaded twice with no CTD.

Asoblow is so incompetent and have yet to be able to offer even a glimmer of hope that a legit simulator will somehow come out of this complete destruction of a legendary product. And MS doesn’t care one ounce that it has, once again, totally screwed its most loyal enthusiasts. And why don’t they care…? Because they’re making millions off this cleverly marketed xbox ‘game’ .

The dev’s haven’t been able to fix the same problems that have plagued this game since release. What do they do instead? It’s what I call “The Carenado Approach”. Flood the users with more and more prettier options that still can’t perform basic functionality.

[And while im ranting… when I look at all these airports for purchase in the marketplace, they all look just about THE same as what orbx has had available for the last several years in FSX.]

2 Likes

Ever since recent update I have not been able to use sim
Whether I select a training flight >> FLY or
World Map >> set up flight >> FLY . . .
no joy.
My windows has been updated with most recent updates
All my render settings are on low.
Does anyone have some suggestions? or has same problem? Thanks

CTD with no mods. no marketplace. empty community… CTD even at menu after 5 mins

Faulting application name: FlightSimulator.exe, version: 1.18.14.0, time stamp: 0x00000000
Faulting module name: FlightSimulator.exe, version: 1.18.14.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x0000000001a0dd67
Faulting process id: 0x4788
Faulting application start time: 0x01d7881a02994ee0
Faulting application path: C:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Faulting module path: C:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Report Id: 23d3e39c-b52f-46a4-b830-bc7616b2096d
Faulting package full name:
Faulting package-relative application ID:

Why there isn’t a verification of fspackages option is beyond me. It’s like Windows, it just assumes it’s going to work, and if it doesn’t, well hard cheese, reinstall. If you live in rural England reinstalling takes a couple of days.

1 Like

@GINAWZF

You know that if you have lots of CPU cores (MY i9 10900K has 10 with 20 threads) and you turn off core 0 and 1, you’re doing FS a big favour. These cores are now available for Windows and other applications - I still have 8 cores for gaming. Also, I do not overclock my CPU, RAM or Graphics card. It’s well known that FS doesn’t play well with overclocking.

Now, there’s a CTD fix thread here by @AmbitousPilots who tells you how to do this (and other things like changing FS priority to low - yes, low!). It has worked a treat for me and stopped stutters completely. Before this 1.18.13. 0 update and hot fix 1.18.14.0 I was using a batch file to launch FS with core 0 and 1 turned off. It no longer works so I simply use the task manager after starting FS to turn off these cores and set FS priority to low. Why set it to low? The answer is in the thread I mention above. Basically, it gives Windows the oxygen that FS starves it from when FS priority is set to high. It’s logical. Also, set your Nvidia FS program settings to “prefer maximum performance”. That gives your graphics card the voltage needed to do hard work. Finally, set your Windows power options to “ultimate”. Some Windows versions (I believe Home version is one of them) don’t have “ultimate” - the thread I mentioned above tells you how to make that happen using a command prompt. My Windows pro version does have “ultimate” so I didn’t need to use the cmd prompt.
Have a look at that thread and give it a shot. You’ve nothing to lose because it can all be easily reversed. There are no registry hacks to worry about either. I’ll need to find that thread to link it here. I’ll come back and edit this to make it easier for you all to find. Here’s that thread:

1 Like

Same here. Only on the Airbus. Solved it by changing my power profile to ‘balanced’.

I’ve had 2 today. Both test flights departing and arriving back at the Skydive Dubai airport which is part of the ORBX Dubai add on. Departing and generally flying around the Dubai area is great but on landing back at that skydive place, both times CTD. First test was the Robin (Horrible default aircraft) and the second was the Cessna Caravan.

Hard to determine if its the airport element of the scenery causing an issue. Going to try similar tests later on but at normal airports.

I can’t even play the game properly as I will crash in the main menu’s (Doesn’t matter where, just random menu or main UI) within a few minutes. No warning.

I basically paid a premium price not a few days ago (Including a TrackIR) so basically 300 bucks for something I can’t even use properly.

Dafuq.

1 Like

Where the hell can we even send in crash dumps or does the client does this automatically?

1 Like

Before SU5 never CTD once. But after the update and hotfix facing CTD on every flight while flying. Community folder emptied.

Faulting application name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x00000000
Faulting module name: clr.dll, version: 4.8.4390.0, time stamp: 0x609c45bd
Exception code: 0xc0000005
Fault offset: 0x0000000000669d70
Faulting process id: 0x4320
Faulting application start time: 0x01d7885431591e12
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.18.14.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\clr.dll
Report Id: 94951a26-c83c-42fc-9323-47c737e5a2b4
Faulting package full name: Microsoft.FlightSimulator_1.18.14.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App

System: AMD 3600X, 32 GB ram, RX 6700XT. Updated Window 10 Pro.

Hope Asobo and MS can fix the issue soon. Broke the game big time.

1 Like

For days after last update I could not start the sim, it would almost finish booting up then computer reboot crash.
I carried out 2 repair attempts 2 resets , one of which was successful for one flight and 2 reinstalls all to no avail.
I have an Nvidia 2070 super GC and out of sheer frustration I went into Geforce Experience and set the game to optimal which meant lower settings than my normal medium setting. I started the sim and amazingly it started without a whimper I will increase settings one at a time because I am not impressed by the low settings at all.